0

There are many posts in different forums about people having trouble reading File GDBs in QGIS 2.2, but no real solutions. Is there any word on a resolution to this problem?

I am using QGIS 2.2 (installed via the OSGeo4W online installer) on Windows 8.1 64-bit. I can confirm that the gdal-filegdb (version 1.11.0-1) library is installed, as reported by the OSGeo4W setup.

The FileGDB option does not appear at all in the Directory source type list, and if I go and choose the .gdb folder anyway I get an error about it not being a valid data type.

And please don't suggest compiling QGIS from scratch with the gdal-filegdb library linked -- that might fly on Linux but it is not a practical alternative on Windows, even assuming I did know how to do it.

  • 2
    There are a few "Related" posts listed on the right-hand side of this screen - have you tried all the suggestions in those posts? eg gis.stackexchange.com/questions/26285/… – Stephen Lead May 1 '14 at 5:35
  • 2
    @Frank, this is a burning issue for quite a few people – reviewing the solutions in related questions and clearly indicating what you tried, what didn't work (and why) would be a great step forward! (Otherwise this seems to be a duplicate) – Simbamangu May 1 '14 at 7:55
  • Is it possible that the geodatabase that you are using was made in an older version of ArcGIS? If I understand this correctly those made prior to ArcGIS 10 will not work at this time in QGIS. – LandArch May 1 '14 at 19:59
  • Maybe I've got the etiquette of this site wrong, but it didn't seem appropriate to hijack someone else's post. – Frank May 2 '14 at 10:53
  • [Wish I could use Enter to create a paragraph!] So, yes this is a duplicate post. – Frank May 2 '14 at 10:54
3

I was having the same problems as Frank, but today finally got it to work. The main change I made was to use the older gdal-filegdb version (1.10.1-2 instead of 1.11.0-1)

I used the OSGEO4W installer to install QGIS - 32 bit installer - osgeo4w-setup-old.exe

Advanced Install

Desktop: QGIS-full (2.2.0-2)

Libs: 1.10.1-2

Now the FileGDB option is there when I Add Vector->Directory and can bring in to the TOC.

Hope this helps!

  • 1
    @Frank: Did it work for you? – AndreJ May 20 '14 at 16:24
2

Rather than mentioning "many posts in different forums" without providing a link to any of them, I recommend that you choose the one which looks the most promising and then if it does not deliver the outcome you are seeking, you will be in a much better position to write a Question focussed around that.

When I looked just now I found QGIS: Using ESRI’s File Based Geodatabase which seems straightforward, is very recent and uses a configuration (QGIS 2.2, GDAL 1.10, Windows 7) that seems quite similar to yours.

I strongly recommend that you visit that link which has graphics and may get updated but in essence its author (North River Geographic Systems) says:

... assume you have used the OSGEO4W installer to install QGIS. I used the 32 bit installer.

  1. Reopen the installer and select advanced options

  2. Install from the Internet

  3. go through the next 5 “Next” Clicks accepting the default values. I say that and I accepted the default – there is a possibility you don’t.

  4. You will end up on the Osgeo4W Setup – Select Packages menu.

  5. Expand Libs and Select the gdal-filegdb library for installation

  6. Click next and install that version.

  7. Open QGIS 2.2

  8. Add Vector Data. Select Directory as the source type. Select type as ESRI FileGDB. Since a file based geodatabase is a directory – select that file based geodatabase. Click open and add your file based geodatabase feature classes.

  • Yes, this is one of the sites that I had previously visited. And, no, it didn't help. – Frank May 2 '14 at 10:52
  • 1
    @Frank Just saying "it didn't help" is not as informative as saying at which step what you observed started to deviate from what you expected and how. – PolyGeo May 2 '14 at 20:38
  • Hmmm ... well, I followed all of the steps on the website, ensuring that gdal-filegdb was selected, ran the installation and opened QGIS. Then I added vector data, selected directory as the source type ... and there was no File GDB. What else do you want me to say? – Frank May 3 '14 at 13:27
2

I recommend downloading sample File Geodatabases from ESRI. This zipped api has several small feature classes included. If these open correctly in QGIS, you know your data is the problem, not the software.

FileGDB_API_VS2012_1_3.zip (50 megabyte)

http://www.esri.com/apps/products/download/#File_Geodatabase_API_1.3

samples\data\shapes.gdb
cities
cities2
intrstat
intrstat2
multipatch
states
states2
zvalues
zvalues2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.