3

I periodically load an SDE geodatabase with about 1 GB of data that is delivered to me in an ArcGIS file geodatabase (.gdb) format. In order to run that job on FME Server I need to upload the .gdb to FME Server. I tried to upload it in various ways but since the .gdb is a directory containing lots of files in Windows, the upload dialog box does not accept the directory, instead it wants a file. I also tried to zip the .gdb, and then I got a success but no data was read from the .gdb. This is an excerpt from the log file:

2014-05-02 12:29:24|   1.9|  1.6|WARN  |Generic Reader: Unable to guess a valid reader name from dataset 'D:\FME_TEMP\fmeservertst_10_0.gdb.zip_1399026562740_14984'. A NULL reader will be used instead.
2014-05-02 12:29:24|   1.9|  0.0|INFORM|Generic Reader: No format specific settings have been found for the NULL Reader -- default values as documented in the Reader/Writer manual will be used

Can anyone put me on the right track? I use FME Server 2013 and ArcGIS 10.0.

1

1 Answer 1

2

There are two parts to fixing your issue.

Part one is that for this case you must upload the GDB as a zip file. Instead of pointing to the .zip file when running the workbench you must point to the .gdb file so the path would look like 'D:\FME_TEMP\fmeservertst_10_0.gdb.zip_1399026562740_14984\fmeservertst_10_0.gdb'.

Part two is that there is another problem with GDBs which is you MUST specify the Input Format as GDB if you want FME to read it with the generic reader. Below are two ways you can do this with the preferred option noted:

FIRST SOLUTION: You create two generic FME loaders. One which only does GDB files and one which does everything else. They can be the same in every way except the GDB one sets the "Input Format" parameter in the reader to be "GEODATABASE_FILE".

SECOND SOLUTION (Preferred option): Expose the "Input Format" as a user parameter and allow the user to specify what type of file they are uploading. I recommend making it a drop down with two options which are ""GEODATABASE_FILE" and "GUESS_FROM_EXTENSION".

In CONCLUSION:

If you use a generic reader then you MUST specify the "Input Format" on the reader to be "GEODATABASE_FILE".

This sucks because it defeats the purpose of the generic reader which is to be able to guess the input datatype and load it automatically but for a GDB you have to tell it the format. ESRI strikes again with it's big wacking stick.

Let me know if you need any more detail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.