0

I can't install the addon in GRASS 6.4.3 to my Linux mint. I've already installed the SVN and then it says:

GRASS 6.4.3 (fabian_idrisi):~ > g.extension r.fuzzy

Fetching  from GRASS-Addons SVN (be patient)...
A    r.fuzzy/local_proto.h
A    r.fuzzy/shape.png
A    r.fuzzy/main.c
A    r.fuzzy/boundary.png
A    r.fuzzy/description.html
A    r.fuzzy/fuzzy.c
A    r.fuzzy/Makefile
A    r.fuzzy/set.png
 U   r.fuzzy
Checked out revision 60053.
Compiling ...
Makefile:13: /usr/lib/grass64/include/Make/Module.make: No such file or directory 
make: *** No rule to make target `/usr/lib/grass64/include/Make/Module.make'.  Stop.
ERROR: Compilation failed, sorry. Please check above error messages.

I try to locate that directory but my usr/lib/grass64/ folder only contains scripts, bin, driver, lib, locale ect.

What am I doing wrong?

2
  • Did you install the "grass-dev" package?
    – markusN
    May 14, 2014 at 15:34
  • Welcome to gis.stackexchange! Please edit the title of your question to include enough information for future visitors to be able to find this thread when looking for the same problem.
    – underdark
    Jun 1, 2016 at 19:36

1 Answer 1

1

I resolved this going to directory that has the module:

cd /home/(personal)/grass-7.0.svn/raster/r.stream.order

as root, I type:

make MODULE_TOPDIR=/home/(myhome)/grass-7.0.svn/
make MODULE_TOPDIR=/home/(myhome)/grass-7.0.svn/ install

More information you can find here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.