2
  1. i am using Geoserver 2.4.4.my geoserver url is http://links-map.com/geoserver/web/ but when i click to loging button of geoserver its url is changed http://vmx15978.hosting24.com.au:8080/geoserver/web/ means after pressing the loging button geosver pointing to my hosting server url i.e http://vmx15978.hosting24.com.au/

2.second issue is on layer preview when i see the the source path of layer by inspect element i fount the layer is also pointing to my server url(http://vmx15978.hosting24.com.au/) not my domain url(http://links-map.com/).

why my geoserver is pointing to my hosting server(http://vmx15978.hosting24.com.au/) i am using dedicated server Centos 6.4 which url is http://vmx15978.hosting24.com.au/ and Apache tomcat server 7.0.42

i want my geosver on my domain path( http://links-map.com/geoserver/web/) all its thing layer preview ,other on the same url (http://links-map.com). not my hosting server url .

So please any body can suggest me where i can fix this problem how can i set GeoServer on http://links-map.com/

I am giving the screen shot url of this please see the screen shot http://links-map.com/error.png

Please suggest me. Thanks

  • It is hard to see how ArcGIS for Desktop which you have as a tag comes into this Question. Also, you seem to be asking more than one question so I think you should edit it to focus on whichever one is the most important to you. – PolyGeo May 5 '14 at 11:40
  • Both question has same issue and same problem.when i display layer as open layer preview. i found that the source path is my hosting server url.that is(vmx15978.hosting24.com.au).the path should be (links-map.com) – Mukesh Nandeda Dhakad May 5 '14 at 12:09
  • This looks like a DNS or proxy issue, not a GeoServer issue. How are you routing your site name to the host? – Scro May 5 '14 at 12:59
  • My site name is links-map.com and Geoserver path is links-map.com/geoserver.But when i click on login button of geoserver it redirect to my hosting server url vmx15978.hosting24.com.au:8080/geoserver so where can i set Proxy or DNS setting to fix this – Mukesh Nandeda Dhakad May 5 '14 at 13:30
  • Looks like your DNS authority is sedoparking.com. If you do not already have a handle on the DNS, then that complicates things quite a bit. Proxy is something you will have to install and configure on your server. See if you can obtain your DNS configuration. – Scro May 5 '14 at 14:34
3

To fix this, go to the Global Settings page in the GeoServer configuration UI. There you enter http://links-map.com/geoserver/ in the "Proxy Base URL" field.

  • 1
    Are there more posibilities what can cause this Problem? I am experiencing the same behaviour (Geoserver Admin Interface is pointing to an "old" URL while Proxy Base URL is set correctly). Where does the Admin UI get this URL from? – Jürgen Zornig Mar 9 '16 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.