I have geoserver deployed in tomcat Web container and i like to move the geoserver into JBOSS is it possible to deploy 'geoserver folder' directly to JBOSS??

I tried to deploy geoserver 2.5 war file under JBOSS 7.1.1 in windows XP, But when i try to enable it in JBoss management / deployment section following is the response am getting

enter image description here

and I also getting the following error in error console

Unknown error
Unexpected HTTP response: 500
"address" => [("deployment" => "geoserver.war")],
"operation" => "deploy"


Internal Server Error
"outcome" => "failed",
"failure-description" => {"JBAS014671: Failed services" =>     "jboss.deployment.unit.\"geoserver.war\".STRUCTURE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"geoserver.war\".STRUCTURE: Failed to process phase STRUCTURE of deployment \"geoserver.war\""}},
"rolled-back" => true

You should specify which JBoss version; for JBoss 7, check this thread in jboss community forum

In few words:

1. Add wo geoserver.war/WEB-INF the following xml


<classloading xmlns="urn:jboss:classloading:1.0" 


<?xml version="1.0" encoding="UTF-8"?>
        <module name="org.slf4j" />
        <module name="org.apache.log4j" />
        <module name="org.jboss.logging" />
        <module name="org.apache.commons.logging" />
        <module name="org.jboss.logging.jul-to-slf4j-stub" />
         <path name="com/sun/imageio/spi"/>
         <path name="com/sun/imageio/plugins/common"/>

Then, you have to add some jdk class to the sun.jdk module by editing JBOSS_HOME/modules/sun/jdk/main/module.xml, this is mine:

<module xmlns="urn:jboss:module:1.1" name="sun.jdk">
    <!-- currently jboss modules has not way of importing services from
    classes.jar so we duplicate them here -->
    <resource-root path="service-loader-resources"/>
    <system export="true">
            <path name="com/sun/script/javascript"/>
            <path name="com/sun/jndi/dns"/>
            <path name="com/sun/jndi/ldap"/>
            <path name="com/sun/jndi/url"/>
            <path name="com/sun/jndi/url/dns"/>
            <path name="com/sun/security/auth"/>
            <path name="com/sun/security/auth/login"/>
            <path name="com/sun/security/auth/module"/>
            <path name="sun/misc"/>
            <path name="sun/io"/>
            <path name="sun/nio"/>
            <path name="sun/nio/ch"/>
            <path name="sun/security"/>
            <path name="sun/security/krb5"/>
            <path name="sun/util"/>
            <path name="sun/util/calendar"/>
            <path name="sun/util/locale"/>
            <path name="sun/security/provider"/>
            <path name="META-INF/services"/>
                <path name="META-INF/services"/>
| improve this answer | |
  • thank you for your response @Tommaso Am trying to deploy geoserver 2.5 in JBOSS 7.1.1 under windows XP, I tried your procedure but still am facing the same problem ,That after adding these xml files to the geoserver.war, I added the war file in deployment section of jboss management console ,and when am trying to enable geoserver it struck there with out producing any results showing pop window with Your request is being processed . response – Anas A May 7 '14 at 9:44
  • The error is related to a bad "format" of the war; maybe the .xml files are not in the right sub-folder? Try to see in the server.log file, maybe this link can help you community.jboss.org/thread/199387?tstart=0 – Tommaso May 7 '14 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.