1

Following up on this question. I am trying to implement the fanout method to implement a batch clip that was mentioned as an option.

I am having issues with trying to batch clip in FME. This is my workspace: enter image description here

I feed the Clipper 3 shapefiles (each has only one part) to clip the larger clippee shapefile (that has 59 parts). How do I set up the fanout in the writer so that I write 3 separate shp files? Currently, it writes one shapefile with 15 parts.

What I tried was to expose the fme_basename of "All" ( the 3 shapefiles read in as a single merged feature type), and then fanout by fme_basename name in the writer.

1

Select the configure cog on the writer or properties from the contents.
On the general tab of the writer properties.
You should probably be aware of the excellent resources on fmepedia and the fme channel on youtube. As well as the fme knowledgebase

  • hello - I understand that the fanout option is under the general tab. What I am unsure of it how to set its settings to get what I am after: if I check fanout by attribute and I choose "_clipped", what I get as a result is one .shp file rather than three. The result I would like is to have one .shp file with the parts and I can't seem to find the correct settings. – whatIS May 12 '14 at 16:49
  • what are you saying? you want one shapefile or 3 shapefiles? – Brad Nesom May 12 '14 at 18:37
  • 1
    3 shapefiles - i did figure it out, fanning out by id of each incoming shape file rather than _clipped produced the answer I needed. – whatIS May 12 '14 at 20:05
  • 1
    Another fanout option that I often use, is to expose the fme_basename attribute and fanout by that. – Fezter May 12 '14 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.