1

I'm running QGIS 2.2 on Ubuntu 14.04. Trying to project data gives me a hard time right now.

The last time I did that was in 2.0 and I basically changed the projection by saving the data as a new file with a certain layer CRS and opening it in another QGIS project. That doesn't work right now, even when on-the-fly transformation is disabled in the project properties.

I've been trying project some vector data with WGS 84 geographical coordinates on WGS 84 UTM 32 N (Germany) but see no results from changes I make in the project or the layer properties.

  • What is the question? It isn't obvious how we can help you, unless you ask something direct. Also, it might help if you can say what the data is, and how you're working with it. – BradHards May 13 '14 at 9:11
  • Why does it not work right now? What error message do you get? What is the extent of your source file, reported by layer Properties, Metadata tab? What file type are you working on? – AndreJ May 13 '14 at 9:14
  • BradHards: You're right, my question wasn't specific enough. Andre Joost: I'm working with an ESRI shapefile of polygons representing regions of Germany. There is no error message. The extent in terms of degrees is "xMin,yMin 5.8655,47.2698 : xMax,yMax 15.0426,55.0573". The layer spatial reference system says "+proj=utm +zone=32 +datum=WGS84 +units=m +no_defs" which is my desired projected coordinate system. However, the projection shows the shapes as in an UTM world projection. On-the-fly CRS transformation is disabled, no automatic project CRS is selected. Hope that helps. – T. K. May 13 '14 at 9:26
1

If you want to reproject the shapefile to UTM, you have to re-set its projection back to WGS84.

As you can read from the extent, the coordiantes are in degrees. Maybe you tried to reproject the layer by simply using Set Layer CRS. But that spoils your data by changing the CRS without touching the coordinates.

So use Set Layer CRS once again to assign EPSG:4326 for it, then use Save As... with another filename, and the desired CRS.

  • Okay, thank you so far. But there is still something I don't understand. I have another layer whose extent is definitely given in UTM values (xMin,yMin 280371.98,5235854.71 : xMax,yMax 921300.43,6101325.43). When I add this layer to an empty QGIS project and skip setting a CRS it is displayed just the way I'm used to. But then, after I used Set Layer CRS (WGS 84 / UTM zone 32N) its shape changes. Why is that? Didn't I only tell QGIS what CRS the layer data uses? Feels like I'm at a loss right now...choosing just WGS 84 (GRS) works fine. – T. K. May 14 '14 at 20:04
  • 1
    The CRS information of a shapefile is stored in a .prj file. You can look into it with any text editor. QGIS asks for CRS only when the .prj file is missing. You can specify under Settings -> Options -> CRS how layers without CRS should be handled. Best choice is Ask for CRS. If you are unsure, you can always set project CRS to EPSG:3857, and load Google or Openstreetmap background from Openlayers plugin to see if the layer is at the right place. – AndreJ May 15 '14 at 17:52
  • Yes, I've obviously missed the fact there was no .prj file (prj as in projection I guess?). That serves as an explanation. Also, using EPSG:3857 works perfectly in terms of the projection. Thank you! – T. K. May 17 '14 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.