1

I'm using QGIS plugin OpenLayers to set the background of Google satellite under my vector layer. However, even if I project my layers as EPSG:3857 (the default and only possible projection for OpenLayers) my layers do not overlap correctly.

What is strange, is that at the beginning it was working, then I saved and closed the project and now I can't overlap them correctly any more. In addition, when it was working correctly, I saved the image and in the resulting picture the layers weren't correctly overlapped...

Any suggestion?

  • Does it overlap (mostly) correctly east-west, and just has a north-south error? – BradHards May 13 '14 at 9:55
  • No the error is huge and my vector layers fall out of the satellite image, However if I set a WGS84 4326, the vectors are slighly shifted est-west – Oritteropus May 13 '14 at 9:59
  • Can you add the extent of the vector layer, as reported by layer Properties, Metadata tab? How did you project the layers as EPSG:3857? – AndreJ May 13 '14 at 10:24
  • Sure, the vector layer has this extension: xMin, yMin 13.4532,43.5112 : xMax,yMax 13.6239,43.602. The projection is changed by right click on the layer and setting the "SR of layer" – Oritteropus May 13 '14 at 10:33
0

Please do not change the CRS of the layers with Set CRS of layer. This will make your data unusable, because it changes the CRS, but not the coordinates.

As you can read from the extent, the coordiantes are still in degrees.

So use Set Layer CRS once again to assign EPSG:4326 for it, then use Save As... with another filename, and the desired CRS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.