0

I have installed geoserver 2.5 with integrated GWC on a windows server 2008 R2 in tomcat6. I am not able to create map caches with GWC. GWC gives me "404: cannot communicate with server. I have a reverse proxy set up and a url rewrite in IIS to provide internet access. What do I have to do to establish communication again between Geoserver and GWC?

  • it should just work in that configuration - can you give more details of how you configured GWC? What the log file says (when you've turned up logging) – Ian Turton May 16 '14 at 13:50
  • Due to the length of the logs, I don´t think I can post it here....Ill have a look and see if there is anything significant that stands out – Robert Buckley May 16 '14 at 13:51
  • Stack trace is here pastebin.com/PRTir8f7 – Robert Buckley May 16 '14 at 14:02
  • I haven´t configured Geowebcache at all really. I simply tried to add 2 new grids for EPSG:25832 and EPSG:31467. I enabled Direct wms integration just to see if this did anything – Robert Buckley May 16 '14 at 14:21
2

what stands out to me is

org.geoserver.platform.ServiceException No such style THW

I suspect that you have left out a style or have misspelled it (or it might be hiding in a workspace).

  • It is true that this style is in the workspace "geoportal"...Why is it "hiding" in a workspace...the normal wms works fine- How do I "unhide" it? – Robert Buckley May 16 '14 at 14:22
  • GWC doesn't understand about your workspaces - there are some issues with the way workspaces interact with styles. Either move the style out of the workspace or add the workspace to the GeoServer URL you configure to GWC (e.g. http://..../geoserver/workspace/wms) – Ian Turton May 16 '14 at 14:24
  • Exactly right!...once I took the styles out of the workspace it worked fine..Thanks for your help – Robert Buckley May 16 '14 at 14:49
  • GeoServer 2.6 will allow you to pass the workspace through using a a parameter filter, allowing styles in workpaces to be used. github.com/geoserver/geoserver/pull/622 – smithkm Jul 2 '14 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.