0

I have a spreadsheet full of addresses to geocode in ArcMap 10. I've added the spreadsheet to the map, then started to geocode them via the context menu's "Geocode addresses" item. Many were matched automatically, and most of the unmatched I've been able to resolve within the Interactive Rematch dialog. But I have a handful of addresses where I get no result at all.

I can, however, locate these points on Google Maps, and I can get the latitude and longitude that way. How can I enter that data into the table to locate the missing points? I have tried editing the data and putting the lat/lon values into the X and Y columns, (via Edit Features -> Start Editing, then Open Attribute Table on the context menu). But when I Flash the point, I don't see it. The lat & lon are consistent with the other data points on the map (i.e., not swapped, and using the correct sign).

How can I add the points to the table?

0

The process of geocoding actually creates a point geometry. The unmatched records have no geometry, so if you just edit the attributes there is nothing to flash. There is a tool/button in the geocoding window to manually place a point. See this help page - about halfway down is Pick Address from Map, which is what you'd want.

Alternatively, you need to either use the create feature tool and right-click/enter absolute value to create a point (with a common attribute) for the record to be matched to, or create an X,Y event layer out of your unmatched records and then replace/update the records in your original dataset.

| improve this answer | |
  • I can't figure out how to use Pick Address from Map for this. The map shows all of Detroit, and I only have major streets on it, so by eye I can only approximate the location. The Goto XY button is disabled on the toolbar. I need a way to just enter the lat & lon that I have. – Carl Raymond May 16 '14 at 20:26
  • I got my Goto XY button to come to life by changing the extent of my data view from fixed to automatic. So I can manually zoom to a point and use Pick Address from Map. It's slow, but it works. – Carl Raymond May 16 '14 at 21:12
  • According to this help page you can enter the lat/lon directly into the locator. Not sure if you need to change locators to do that though. A couple of alternatives would be to load in a basemap with more street detail to use as reference, or as mentioned in my answer export your unlocated address records to a new table, enter the x,y from Google and save, create an x,y layer from those records, and then you will have points you can find and click on/near with the Pick Address method. – Chris W May 16 '14 at 21:47
0

This is probably because your dataframe or your points you're using for geocoding are projected to a different coordinate system.

If you right click on the points where you inputed lat/long and select "Zoom to feature" do they show up on your screen then? If they aren't where they are supposed to be chances are it's a projection issue wherein you need to properly define your projection.

| improve this answer | |
  • The lat/lon are within the bounds of the map, and the many other points all show up fine. However, my Zoom To is disabled on the menu. – Carl Raymond May 16 '14 at 17:38
  • When you hover over the map what shows up in the botton right corner? Another step would be to export the points you have and edit the new shapefile – GISKid May 16 '14 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.