2
 var options = {
        resrictedExtent: restrictedBounds,
        maxExtent: restrictedBounds,
        units: "m",
        projection: "EPSG:31467",
       resolutions:[305.74872463815512,152.87436231907702,76.437181159538511,38.218590579769391,19.109295289884642,9.554647644942321,4.7773238224711605, 2.3886619112355802, 1.1943309556178034, 0.59716547780890172],
       maxResolution: "auto",
        controls: []
    };

map = new OpenLayers.Map( 'map', options );

These are the map options which work with geoserver wms fine. I want to serve geowebcache layers using geoserver 2.5 with the integrated GWC. I have created a cached layer using the resolutions as they are defined above. In GWC the layer preview works OK and displays the layer as expected, but when I integrate the layer into the openlayers client, pink tiles are displayed. The resolutions seem indeed to differ from those defined by the normal wms layers. Have I forgotten something? Why don´t the resolutions match? The DPI is 96 by the way.

The URL of a wms tile which displays fine in zoomlevel 8 is:

SRS=EPSG%3A31467&BBOX=3542676.9162395,5865437.4059784,3563009.2064279,5885769.6961669 

If I change the URL to point to the GWC layer but keep the BBOX extents the same I get the following error:

400: Unable to match requested SRS EPSG:31467 to those supported by layer
  • after setting my client options to exactly those in the source code of the layer preview in geoserver, I am now getting the following error: 400: The requested tile dimensions 266x266 do not match those of the grid set (256x256)????? How can this be? – Robert Buckley May 16 '14 at 22:50
  • What is the gutter size set to in "Default Caching Options for GeoServer Layers"? – BradHards May 17 '14 at 2:08
  • gutter size is 0 - Haven´t altered it since installation – Robert Buckley May 17 '14 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.