0

I am trying to create a hillshade on my DEM because I need to be able to distinguish features which I can't do in its current state (see picture).

However, when I add the hillshade, it adds a block grey image over the top.

With out hillshade


I tried the hillshade again. When I use a stretched render the DEM doesn't appear. I have tried altering the values but it appears to make no difference. So, the same thing still happens, I try adding a separate hillshade layer and it is still a block colour - sometimes grey, sometimes black.

Any ideas as to how I can get the relief on?

With a hillshade layer @ 60%

  • What features are you trying to distinguish? Have you tried increasing the number of classes in your DEM symbology as pictured? How are you 'adding' a hillshade - actually generating one, or applying a hillshade effect to symbology? By 'block' do you mean flat/uniform gray, and if so have you tried changing the symbology settings? We need some more specific information about the exact steps you're taking and the result to be able to help. – Chris W May 18 '14 at 18:29
  • 1
    It's hard to tell from the TOC but is that a DEM or RGB image? It looks like an ESRI standard colour ramp in the stretched renderer. Can you please include a screenshot of your image display settings and indicate what version of ArcGis you're using. – Michael Stimson May 18 '14 at 22:02
  • Hi both, I am trying to add hillshade as a separate layer, when I try the 'hillshade tick box' on symbology it doesn't change anything. I have increased the number of classes to 32. Block = flat uniform grey. The reason for adding the hillshade is to distinguish lava flows from the volcano pictured above. At the moment there is no where near enough detail to distinguish anything. It is a 5m res DEM, it is classified render. Thanks for your time helping. K – Katie C May 20 '14 at 11:41
  • Generally only the person who posted the question or answer you comment on will be notified unless you include @name. @MichaelMiles-Stimson - now he will be notified I commented as well as you, since it's your question. The suggestion to increase classes just gives more colors for your DEM - a higher 'resolution' in one sense because you can distinguish more ranges. You could also just use a stretch renderer of type Standard Deviations and try different n values. To see the effects of the hillshade box on symbology, you may need to zoom in a little or change the z value. – Chris W May 20 '14 at 19:17
  • Without knowing how you created your separate hillshade and with what settings, the problem could be in the generation itself or your symbology of the result. After adding it to the map, you may need to open the symbology and adjust it. But it should come in using a stretch renderer by default, which leads me to think something is wrong with the hillshade itself and we need more info to suggest anything further. Is that 5m vertical or horizontal resolution for your DEM? Lava flows may not be distinguishable based on elevation data alone. – Chris W May 20 '14 at 19:27
4

There's definitely something wrong with the hillshade on a classified renderer (sorry, no volcanoes this is Australia). This is a 1m cell LiDAR DEM: HillshadeOnClass

As you can see only the bottom half is rendered correctly, I can assure you the level of detail in the DEM doesn't suddenly change!

Settings: enter image description here

Using a stretched renderer with hillshade gives a better result, but to be really impressive you want to actually create a hillshade layer and throw it over the top of your classified layer with default symbology (black to white, stretched) a transparency (this one is 60%): enter image description here

and it just gets better if you change the hillshade layer to standard deviations with n:2.5 and transparent 60%: enter image description here

The hillshade gives detail to the classifed data showing all the lumps 'n bumps! Now contrast that against the original with no hillshading: enter image description here

Sorry to be a bit long winded in the answer, I felt the pictures added important detail.

  • 1
    I had a similar result with the hillshade effect on a classified render. In my case at first the whole thing showed no effect, zooming in a little caused it to appear on the top 2/3 or so, and then zooming further (happen to remember it was 1:80k or better) it rendered all of it. Altering the z was having minimal to no effect as well. Does your machine by chance use an AMD/Radeon graphics processor? – Chris W May 21 '14 at 18:08
  • Why yes @chrisw, it does, HD 5700 Series. Does this not happen with nVidia? If so I might have to go and threaten / cajole / bribe our I.T. guy to get a video card upgrade.. even in Australia they're less than $1k, though nearly twice as much as in the U.S. – Michael Stimson May 21 '14 at 22:09
  • 2
    Not sure, but it would be something to test with nVidia or Intel. There is a bug in 10.1 where you pretty much can't even load a TIN in ArcScene that was traced to a conflict between ArcGIS and AMD drivers. Not sure if it was fixed in 10.2 or not, but someone recently posted another question using 10.2 also related to AMD, elevation rendering, and problems with display. I'm on 10.2 as well, so this would make the third issue with a whole lot of coincidentally related circumstances. – Chris W May 22 '14 at 0:51
  • I remember a problem in 9.0 where ArcScene or 3d view of ArcCatlog Blue-Screen-of-Death'ed a workstation if a particular ATI card was installed. According to resources.arcgis.com/en/help/system-requirements/10.2/… ATI is supported. @ChrisW this sounds like a long term bug with ATI/AMD, to be on the safe side I'm going to recommend to our I.T. to prefer nVidia graphic cards... they're about the same price. – Michael Stimson May 22 '14 at 0:59
  • The original bug I was referring to is NIM085208 and it was apparently addressed with 10.2. This post prompted me to dig out my project and test now that I have the new version, and the TIN was working. The first Related link for this Question goes to one that has some info about the hillshade effect being 'quick and dirty' and 'never intended to be the level of actually generating one'. At any rate this is all somewhat moot for this question, since OP is not using that method, and we're sort of derailing things here. – Chris W May 22 '14 at 1:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.