5

When creating a new Column, the default value for the length of the name is 10. Using the Field Calculator via the Model Builder, I want to include the names of regional areas into the columns which has more than 10 characters.

Can the length of the Output Field Name be increased?

  • If the attribute size is the most important thing, and not the shapefile, look at saving your data into a spatial database, such as Spatialite. – Ryan Garnett May 19 '14 at 13:53
  • @RyanGarnett, thanks for the advice. The attribute size was more for an aesthetic purpose than anything else. – Joseph May 19 '14 at 15:06
  • 3
    I have had that issues too. You may want to look at setting an alias. You can do this in the Properties window in QGIS, under the Fields tab. You can set the Alias, and that change will be reflected in the attribute table. – Ryan Garnett May 19 '14 at 15:12
  • Use an Alias for such situations – NULL.Dude Dec 3 '17 at 16:00
  • @Geo.Dude - Thanks, I believe that's what I did at the time :) – Joseph Dec 4 '17 at 10:38
10

If the output file is a shapefile, it is not possible due to the restrictions of the shapefile definition:

http://www.gdal.org/drv_shapefile.html

Attribute names can only be up to 10 characters long

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.