9

I am new to QGIS and the questions asked and answered here about the North Arrow do not seem to help me solve my problem below.

In the main mapping pane of QGIS 2.2.0 Valmiera, I can add the scale and north arrow, but as soon as I go to the Composer to print a map, those two things disappear from the map that I open in the composer.

The Composer has something which allows me to add a scale thing, but it shows the actual scale on the paper that I'll be printing on and not the actual scale of the surface of the earth of the displayed map. I even tried refreshing the map but it did not work.

The bottom line is this: How do I get a scale thing (sorry!) (expanding and contracting in values as I zoom in and out) in Composer, and how do I get a North Arrow in there as well.

12

The north arrow is added as an image. The behaviour of the scale depends on the CRS of your data/map.

Once you start inserting an image in the composer, you should get the option to select from a library of icons, and a subfolder is arrows, of which there are are many types. Once the image is installed, there is an option to keep the rotation of the arrow synchonised with the map.

Image showing arrow options

It seems the scale problem you mention is like it is set to 1:1. This is not the default AFAIK. I almost always work in a UTM (metres) CRS for the main mapping pane (the canvas) and so the addition of the scale bar is trouble fee. If you are working with degrees your mileage may vary. Keep working with that tool.

A simplistic answer, hope its a start.

  • Hi Willy!Thanks for your answer! I have to admit that I had to Google what CRS meant for the first portion of your answer. hehe - I'm a total noob when it comes to GIS software! – user30413 May 21 '14 at 19:55
  • Anyway, I appreciate the answer re the fact that the North Arrow is simply inserted as a picture. That was great. – user30413 May 21 '14 at 19:56
  • Then, as far as the scale thing is concerned, I found that it was indeed the CRS that was causing problems, but also the way I manipulated/changed the "Label" and "Map units per bar unit" in the Units section of the Item Properties tab. – user30413 May 21 '14 at 20:02
  • I kept the Units as Meters and changed the "Map units per bar unit" to 1,000 and then overtyped the m (for meter) in the "Label" box with km. Each 1,000m then reflected 1km on the bar on the map. – user30413 May 21 '14 at 20:05
  • I then also changed the "Size" value in the "Segments" section of the Item properties tab to 1,000.00 units. – user30413 May 21 '14 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.