4

I am using geoserver for publishing my spatial data. The problem I am facing is, Any public user can download my spatial data without my permission using default URL of geoserver. This is obviously undesirable in any context.

Please provide guidelines.

  • 1
    If you uncheck the Advertised box for the layer under the Publishing tab the layer will not show up in the Layer Preview. Would that be sufficient for your needs? – Ralph Dell May 21 '14 at 11:53
  • Yes, this is working for me. You can post this as answer. Thanks – Ashutosh Agrawal May 22 '14 at 10:10
9

If you uncheck the Advertised box for the layer under the Publishing tab the layer will not show up in the Layer Preview. Would that be sufficient for your needs?

|improve this answer|||||
7

If you don't want people to download your data, use the security subsystem or disable the WFS services, the preview is just building links to standard OGC calls. But if you really just want to remove it, you can remove it for everybody (including the admin) by taking out the geoserver demo jar in geoserver/web-inf/lib

|improve this answer|||||
1

In Data Security change the line

\*.*.r ________________    *

to

\*.*.r ________________ GROUP_ADMIN, ADMIN

and the layers with Advertised box checked will show up in the Layer Preview but hidden for the public.

|improve this answer|||||
0

The best way is to hide all layers to unauthorized users.

You can do this, by changing the rules in the security section. The default settings, when starting a new GeoServer grants access to all the demo layers of all workspaces to all users. Just change this rules to restrict the access to the desired roles, users, workspaces or layers. All the layers for which the ROLE_ANONYMOUS is not selected are hidden in the Layer Preview.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.