1

I have ran into an issue with the ArcMap tools in both 3D Analyst and Spatial Analyst.

I convert an elevation grid from meters to centimeters by using the Times tool with a constant of 100. Works exactly as expected and gives correct values.

When I use the Int tool to convert the floating point numbers to integers, the max value gets cut in half. The max goes from ~23k to 12k.

Here is a picture of the elevation grid at the start (top), after Times (bottom) and then Int (middle):

enter image description here

Any ideas?

closed as off-topic by PolyGeo Sep 4 '16 at 7:32

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Have you tried recalculating the Statistics on the output of the Int tool? – GISGe May 23 '14 at 14:01
  • ... Thanks... Someone else was over here and helping me yesterday. He was baffled and tried running Calculate Statistics from ArcMap, but it failed. I just ran it from ArcCatalog... and now the values are right... – Madeline May 23 '14 at 14:10