1

I am getting an error while using Region Group on a large dataset. The errors are specified below:

ERROR 999999: Error executing function.
The table was not found. [VAT_final002]
A column was specified that does not exist.
A column was specified that does not exist.
ERROR 010005: Unable to allocate memory.
ERROR 010067: Error in executing grid expression.
Failed to execute (RegionGroup).

I am currently running ArcGIS 10.1. I have 4 GB of total RAM. The raster I'm processing has 154242 columns and 97288 rows with 30x30 cell size (approximately 500 MB file size). All values = 1 or "nodata". Does anyone have a solution to this other than having to process in small sections?

closed as off-topic by PolyGeo Sep 4 '16 at 7:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Although the size of the dataset on disk is 500 MB, that is due to the internal compression used to store it. The raster itself will occupy four bytes of RAM for every cell while it is being processed (and the same amount of RAM again will likely be needed to hold the output as it is created), because RegionGroup is a global operation: identifying whether two cells are part of the same region (even when they are nearby) potentially requires inspecting the entire grid. Since 154242 * 97288 * 4 bytes = 56 GB, you don't stand a chance. – whuber May 24 '14 at 18:53
  • 1
    I'm always inclined to listen to @whuber, but if you were trying to debug this yourself further, try using GRID format inputs and check your scratch directories in your environment settings. Spatial Analyst is often fickle about personal/file geodatabase datasets in my experience. The only way this works though is if the tool manages to chunk the data so as not to load it all at once. Not sure if Region Group can do this or not. – nicksan May 27 '14 at 23:09