6

After major upgrade to 14.04 I tried to purge and reinstall QGIS.

Unfortunately I get and error (full listing below) and cannot finish clean installation.

Information in the log points errors to appear with pyspatialite and/or python-pyspatialite but I cannot find any solution to this issue.

Also - QGIS actually manages to start after installation but points to another error with PyQGIS this time:

enter image description here

Any ideas how to solve this issue?

rdk@hal:~$ sudo apt-get install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  grass grass-core grass-doc grass-gui libmotif-common libmrm4
  libopenscenegraph99 libosgearth3 libosgearthannotation3 libosgearthfeatures3
  libosgearthqt3 libosgearthsymbology3 libosgearthutil3 libqgis-analysis2.2.0
  libqgis-core2.2.0 libqgis-gui2.2.0 libqgis-networkanalysis2.2.0
  libqgisgrass2.2.0 libqgispython2.2.0 libspatialindex3 libtcl8.5 libtk8.5
  libuil4 libxm4 osgearth-data python-opengl python-pyspatialite
  python-qgis-common qgis-common qgis-plugin-globe qgis-plugin-globe-common
  qgis-plugin-grass-common qgis-providers qgis-providers-common tcl8.5 tk8.5
Suggested packages:
  grass-dev e00compr avce00 gnuplot gpstrans python-rpy2 xml2 grass-dev-doc
  openscenegraph libgle3 tcl-tclreadline
The following NEW packages will be installed
  grass grass-core grass-doc grass-gui libmotif-common libmrm4
  libopenscenegraph99 libosgearth3 libosgearthannotation3 libosgearthfeatures3
  libosgearthqt3 libosgearthsymbology3 libosgearthutil3 libqgis-analysis2.2.0
  libqgis-core2.2.0 libqgis-gui2.2.0 libqgis-networkanalysis2.2.0
  libqgisgrass2.2.0 libqgispython2.2.0 libspatialindex3 libtcl8.5 libtk8.5
  libuil4 libxm4 osgearth-data python-opengl python-pyspatialite python-qgis
  python-qgis-common qgis qgis-common qgis-plugin-globe
  qgis-plugin-globe-common qgis-plugin-grass qgis-plugin-grass-common
  qgis-providers qgis-providers-common tcl8.5 tk8.5
0 to upgrade, 39 to newly install, 0 to remove and 0 not to upgrade.
Need to get 62.2 MB of archives.
After this operation, 235 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis-providers-common all 2.2.0-2~trusty1 [1,539 kB]
Get:2 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe libmotif-common all 2.3.4-5 [11.8 kB]
Get:3 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libqgis-core2.2.0 amd64 2.2.0-2~trusty1 [2,607 kB]
Get:4 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libqgis-gui2.2.0 amd64 2.2.0-2~trusty1 [1,913 kB]
Get:5 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis-providers amd64 2.2.0-2~trusty1 [1,770 kB]
Get:6 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libosgearth3 amd64 2.5.0+dfsg-3~trusty1 [775 kB]
Get:7 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe libxm4 amd64 2.3.4-5 [967 kB]
Get:8 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libosgearthsymbology3 amd64 2.5.0+dfsg-3~trusty1 [244 kB]
Get:9 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libosgearthfeatures3 amd64 2.5.0+dfsg-3~trusty1 [246 kB]
Get:10 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libosgearthannotation3 amd64 2.5.0+dfsg-3~trusty1 [172 kB]
Get:11 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libosgearthutil3 amd64 2.5.0+dfsg-3~trusty1 [633 kB]
Get:12 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libosgearthqt3 amd64 2.5.0+dfsg-3~trusty1 [176 kB]
Get:13 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libqgis-analysis2.2.0 amd64 2.2.0-2~trusty1 [930 kB]
Get:14 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libqgis-networkanalysis2.2.0 amd64 2.2.0-2~trusty1 [794 kB]
Get:15 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libqgisgrass2.2.0 amd64 2.2.0-2~trusty1 [844 kB]
Get:16 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libqgispython2.2.0 amd64 2.2.0-2~trusty1 [789 kB]
Get:17 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main osgearth-data all 2.5.0+dfsg-3~trusty1 [3,946 kB]
Get:18 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe libmrm4 amd64 2.3.4-5 [56.2 kB]
Get:19 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main python-qgis-common all 2.2.0-2~trusty1 [2,882 kB]
Get:20 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe libspatialindex3 amd64 1.8.1-2 [218 kB]
Get:21 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/main libtcl8.5 amd64 8.5.15-2ubuntu1 [684 kB]
Get:22 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main python-qgis amd64 2.2.0-2~trusty1 [2,671 kB]
Get:23 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/main libtk8.5 amd64 8.5.15-2ubuntu3 [641 kB]
Get:24 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis-common all 2.2.0-2~trusty1 [6,335 kB]
Get:25 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe libuil4 amd64 2.3.4-5 [126 kB]
Get:26 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe grass-core amd64 6.4.3-3 [7,199 kB]
Get:27 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis amd64 2.2.0-2~trusty1 [4,890 kB]
Get:28 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis-plugin-globe-common all 2.2.0-2~trusty1 [780 kB]
Get:29 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis-plugin-globe amd64 2.2.0-2~trusty1 [856 kB]
Get:30 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis-plugin-grass-common all 2.2.0-2~trusty1 [1,198 kB]
Get:31 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main qgis-plugin-grass amd64 2.2.0-2~trusty1 [1,508 kB]
Get:32 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe grass-doc all 6.4.3-3 [6,303 kB]
Get:33 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/main tcl8.5 amd64 8.5.15-2ubuntu1 [13.9 kB]
Get:34 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/main tk8.5 amd64 8.5.15-2ubuntu3 [12.0 kB]
Get:35 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe python-opengl all 3.0.2-1 [364 kB]
Get:36 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe grass-gui amd64 6.4.3-3 [1,818 kB]
Get:37 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe libopenscenegraph99 amd64 3.2.0~rc1-4 [5,283 kB]
Get:38 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe python-pyspatialite amd64 3.0.1-4 [29.4 kB]
Get:39 http://mirror.switch.ch/ftp/mirror/ubuntu/ trusty/universe grass all 6.4.3-3 [6,148 B]
Fetched 62.2 MB in 5s (10.8 MB/s)
Extract templates from packages: 100%
Selecting previously unselected package libmotif-common.
dpkg: warning: files list file for package 'gettext' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texinfo' missing; assuming package has no files currently installed
(Reading database ... 500015 files and directories currently installed.)
Preparing to unpack .../libmotif-common_2.3.4-5_all.deb ...
Unpacking libmotif-common (2.3.4-5) ...
Selecting previously unselected package libxm4:amd64.
Preparing to unpack .../libxm4_2.3.4-5_amd64.deb ...
Unpacking libxm4:amd64 (2.3.4-5) ...
Selecting previously unselected package libmrm4:amd64.
Preparing to unpack .../libmrm4_2.3.4-5_amd64.deb ...
Unpacking libmrm4:amd64 (2.3.4-5) ...
Selecting previously unselected package libspatialindex3:amd64.
Preparing to unpack .../libspatialindex3_1.8.1-2_amd64.deb ...
Unpacking libspatialindex3:amd64 (1.8.1-2) ...
Selecting previously unselected package libtcl8.5:amd64.
Preparing to unpack .../libtcl8.5_8.5.15-2ubuntu1_amd64.deb ...
Unpacking libtcl8.5:amd64 (8.5.15-2ubuntu1) ...
Selecting previously unselected package libtk8.5:amd64.
Preparing to unpack .../libtk8.5_8.5.15-2ubuntu3_amd64.deb ...
Unpacking libtk8.5:amd64 (8.5.15-2ubuntu3) ...
Selecting previously unselected package libuil4:amd64.
Preparing to unpack .../libuil4_2.3.4-5_amd64.deb ...
Unpacking libuil4:amd64 (2.3.4-5) ...
Selecting previously unselected package qgis-providers-common.
Preparing to unpack .../qgis-providers-common_2.2.0-2~trusty1_all.deb ...
Unpacking qgis-providers-common (2.2.0-2~trusty1) ...
Selecting previously unselected package libqgis-core2.2.0.
Preparing to unpack .../libqgis-core2.2.0_2.2.0-2~trusty1_amd64.deb ...
Unpacking libqgis-core2.2.0 (2.2.0-2~trusty1) ...
Selecting previously unselected package libqgis-gui2.2.0.
Preparing to unpack .../libqgis-gui2.2.0_2.2.0-2~trusty1_amd64.deb ...
Unpacking libqgis-gui2.2.0 (2.2.0-2~trusty1) ...
Selecting previously unselected package qgis-providers.
Preparing to unpack .../qgis-providers_2.2.0-2~trusty1_amd64.deb ...
Unpacking qgis-providers (2.2.0-2~trusty1) ...
Selecting previously unselected package grass-core.
Preparing to unpack .../grass-core_6.4.3-3_amd64.deb ...
Unpacking grass-core (6.4.3-3) ...
Selecting previously unselected package grass-doc.
Preparing to unpack .../grass-doc_6.4.3-3_all.deb ...
Unpacking grass-doc (6.4.3-3) ...
Selecting previously unselected package tcl8.5.
Preparing to unpack .../tcl8.5_8.5.15-2ubuntu1_amd64.deb ...
Unpacking tcl8.5 (8.5.15-2ubuntu1) ...
Selecting previously unselected package tk8.5.
Preparing to unpack .../tk8.5_8.5.15-2ubuntu3_amd64.deb ...
Unpacking tk8.5 (8.5.15-2ubuntu3) ...
Selecting previously unselected package python-opengl.
Preparing to unpack .../python-opengl_3.0.2-1_all.deb ...
Unpacking python-opengl (3.0.2-1) ...
Selecting previously unselected package grass-gui.
Preparing to unpack .../grass-gui_6.4.3-3_amd64.deb ...
Unpacking grass-gui (6.4.3-3) ...
Selecting previously unselected package libopenscenegraph99.
Preparing to unpack .../libopenscenegraph99_3.2.0~rc1-4_amd64.deb ...
Unpacking libopenscenegraph99 (3.2.0~rc1-4) ...
Selecting previously unselected package libosgearth3.
Preparing to unpack .../libosgearth3_2.5.0+dfsg-3~trusty1_amd64.deb ...
Unpacking libosgearth3 (2.5.0+dfsg-3~trusty1) ...
Selecting previously unselected package libosgearthsymbology3.
Preparing to unpack .../libosgearthsymbology3_2.5.0+dfsg-3~trusty1_amd64.deb ...
Unpacking libosgearthsymbology3 (2.5.0+dfsg-3~trusty1) ...
Selecting previously unselected package libosgearthfeatures3.
Preparing to unpack .../libosgearthfeatures3_2.5.0+dfsg-3~trusty1_amd64.deb ...
Unpacking libosgearthfeatures3 (2.5.0+dfsg-3~trusty1) ...
Selecting previously unselected package libosgearthannotation3.
Preparing to unpack .../libosgearthannotation3_2.5.0+dfsg-3~trusty1_amd64.deb ...
Unpacking libosgearthannotation3 (2.5.0+dfsg-3~trusty1) ...
Selecting previously unselected package libosgearthutil3.
Preparing to unpack .../libosgearthutil3_2.5.0+dfsg-3~trusty1_amd64.deb ...
Unpacking libosgearthutil3 (2.5.0+dfsg-3~trusty1) ...
Selecting previously unselected package libosgearthqt3.
Preparing to unpack .../libosgearthqt3_2.5.0+dfsg-3~trusty1_amd64.deb ...
Unpacking libosgearthqt3 (2.5.0+dfsg-3~trusty1) ...
Selecting previously unselected package libqgis-analysis2.2.0.
Preparing to unpack .../libqgis-analysis2.2.0_2.2.0-2~trusty1_amd64.deb ...
Unpacking libqgis-analysis2.2.0 (2.2.0-2~trusty1) ...
Selecting previously unselected package libqgis-networkanalysis2.2.0.
Preparing to unpack .../libqgis-networkanalysis2.2.0_2.2.0-2~trusty1_amd64.deb ...
Unpacking libqgis-networkanalysis2.2.0 (2.2.0-2~trusty1) ...
Selecting previously unselected package libqgisgrass2.2.0.
Preparing to unpack .../libqgisgrass2.2.0_2.2.0-2~trusty1_amd64.deb ...
Unpacking libqgisgrass2.2.0 (2.2.0-2~trusty1) ...
Selecting previously unselected package libqgispython2.2.0.
Preparing to unpack .../libqgispython2.2.0_2.2.0-2~trusty1_amd64.deb ...
Unpacking libqgispython2.2.0 (2.2.0-2~trusty1) ...
Selecting previously unselected package osgearth-data.
Preparing to unpack .../osgearth-data_2.5.0+dfsg-3~trusty1_all.deb ...
Unpacking osgearth-data (2.5.0+dfsg-3~trusty1) ...
Selecting previously unselected package python-qgis-common.
Preparing to unpack .../python-qgis-common_2.2.0-2~trusty1_all.deb ...
Unpacking python-qgis-common (2.2.0-2~trusty1) ...
Selecting previously unselected package python-pyspatialite.
Preparing to unpack .../python-pyspatialite_3.0.1-4_amd64.deb ...
Unpacking python-pyspatialite (3.0.1-4) ...
Preparing to unpack .../python-qgis_2.2.0-2~trusty1_amd64.deb ...
Unpacking python-qgis (2.2.0-2~trusty1) ...
dpkg: error processing archive /var/cache/apt/archives/python-qgis_2.2.0-2~trusty1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/python2.7/dist-packages/pyspatialite/dump.py', which is also in package python-pyspatialite 3.0.1-4
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package qgis-common.
Preparing to unpack .../qgis-common_2.2.0-2~trusty1_all.deb ...
Unpacking qgis-common (2.2.0-2~trusty1) ...
Selecting previously unselected package qgis.
Preparing to unpack .../qgis_2.2.0-2~trusty1_amd64.deb ...
Unpacking qgis (2.2.0-2~trusty1) ...
Selecting previously unselected package qgis-plugin-globe-common.
Preparing to unpack .../qgis-plugin-globe-common_2.2.0-2~trusty1_all.deb ...
Unpacking qgis-plugin-globe-common (2.2.0-2~trusty1) ...
Selecting previously unselected package qgis-plugin-globe.
Preparing to unpack .../qgis-plugin-globe_2.2.0-2~trusty1_amd64.deb ...
Unpacking qgis-plugin-globe (2.2.0-2~trusty1) ...
Selecting previously unselected package qgis-plugin-grass-common.
Preparing to unpack .../qgis-plugin-grass-common_2.2.0-2~trusty1_all.deb ...
Unpacking qgis-plugin-grass-common (2.2.0-2~trusty1) ...
Selecting previously unselected package grass.
Preparing to unpack .../archives/grass_6.4.3-3_all.deb ...
Unpacking grass (6.4.3-3) ...
Selecting previously unselected package qgis-plugin-grass.
Preparing to unpack .../qgis-plugin-grass_2.2.0-2~trusty1_amd64.deb ...
Adding 'diversion of /usr/bin/qgis to /usr/bin/qgis.bin by qgis-plugin-grass'
Adding 'diversion of /usr/bin/qbrowser to /usr/bin/qbrowser.bin by qgis-plugin-grass'
Unpacking qgis-plugin-grass (2.2.0-2~trusty1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for doc-base (0.10.5) ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Errors were encountered while processing:
 /var/cache/apt/archives/python-qgis_2.2.0-2~trusty1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • 1
    Seeing the available packages for Trusty, I would think that the Ubuntugis repository is not ready yet for full support. – MickyInTheSky May 26 '14 at 10:33
4

Until Ubuntugis supports all required packages (especially GDAL and spatialite), it is recommended to use the official QGIS repository:

https://www.qgis.org/en/site/forusers/alldownloads.html#ubuntu

It works for me, except for the exotic drivers that require special gdal packages. These will be available from ubuntugis again once they are finished.

  • Thank you. That solved the issue. When will be the good time to switch to ubuntugis repo? – radek Jun 4 '14 at 13:06
  • 1
    Keep an eye on launchpad.net/~ubuntugis/+archive/ubuntugis-unstable. Trusty has 11 packages by now, precise 39. I guess you might need some more of them. – AndreJ Jun 4 '14 at 13:14
  • 1
    Maybe your issue has already been fixed: launchpadlibrarian.net/176768751/… + * fix python-pyspatialite dependency on trusty but I'm not sure about other dependencies. – AndreJ Jun 5 '14 at 5:48
  • 1
    Update: trusty now has 17 packages. The libgdal-ecw is still missing. Most other QGIS related things work ok now with ubuntugis unstable. – AndreJ Jul 13 '14 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.