2

I'm a beginner at QGIS and I'm having trouble aligning my shapefiles.

I have two datasets: one originally in WGS84 (lat/long) and another in Corrego Alegre/UTM zone 24S. I need to convert the second into WGS84 for my work, however if I go to Vector -> Data Management Tools -> Define Current Projection and choose to do so, I'm told this is an invalid coordinate system.

By going to Save as... I'm able to save a shapefile that seems to be in WGS84, but it is dislocated from the other polygons of my first dataset.

How can I get these files to align?? This is a screenshot of the mis-alignment, even though the novo-recifes-v2.shp (coral reefs) is set as WGS84, just like the continent (global_polygon.shp)

This is a screenshot of the mis-alignment, even though the novo-recifes-v2.shp (coral reefs) is set as WGS84, just like the continent (global_polygon.shp)

3 Answers 3

2

Keep in mind that the global polygon might be simplified, and may not include reef areas.

I suugest to change the project CRS to EPSG:3857, and add Openstreetmap or Google background via the Openlayers plugin.

These are far more accurate than the global polygon.

Define Current Projection is definitely wrong if you want to change the projection of a source unless you know that the CRS is wrong. Save As ... should reproject the data coreectly.

3
  • Yes, I suppose the global polygon is simplified, but I also have other data in the same projection (continental shelf, wave data, bathymetry...), so I'm stuck with the same problem even changing the landmass. Thanks for the tip on the Openlayers plugin, I didn't know about this feature! May 27, 2014 at 10:41
  • Does it get better if you change from Corrego Alegre/UTM 24S to WGS84/UTM 24S?
    – AndreJ
    May 27, 2014 at 11:05
  • No, it looks the same in WGS84 and WGS24/UTM 24S. I guess the problem is what Blackthorn answered below: that my datasets were digitised with different references, so the mis-alignment isn't a coordinate system problem. May 29, 2014 at 18:22
1

First, go to Project > Project Properties > CRS and check Enable 'on the fly' CRS transformation, then click on the WGS84 Coordinate Reference System:

enter image description here

Then you should be able to load the both shapefiles properly.

However, if this doesn't works as expected you may use the Affine Transformations Plugin, to correct the mis-alignment.

Another, even easier solution, if your mis-aligned layer doesn't contains a lot of data, is to toggle the edit on, select all the features and simply use the move tool to make the desired corrections.

1
  • The move tool was a great tip, thank you! I might have to do this, but it'll create a false image of how the reefs are positioned in relation to the shore... May 27, 2014 at 10:43
1

Looking closely at the overlap in your shapefiles, it looks like they are of two different origins. In other words, the coral reefs dataset was not digitised with reference to the global_polygon dataset but was digitised with reference to a different dataset showing the coastline. So your problem isn't one of coordinate reference systems.

Depending on what you want to do with the data, you might clip* one layer with the other to get rid of the overlap. Better yet, if possible, try to find what dataset was used as the coastline template for the coral reef data, and use that dataset rather than the global_polygon one.

Inconsistencies between layers of different origins is a common problem in ecology, and there are no quick fixes!

*See comment below.

3
  • Yes, like Andre Joost answered above, the global polygon is simplified while my dataset has much more precision. However, there are other data (bathymetry, continental shelf...) that mis-align with my own landmass polygon, so I'm sort of stuck with using the global polygon... What do you mean by clipping one layer with the other? May 27, 2014 at 10:45
  • I misspoke really when I said "clip". If you use the Difference tool under the Vector menu, then you can remove parts of the global_polygon layer that overlap with your coral reef layer. Choose the global_polygon layer as the input layer and the coral reefs as the difference layer. This may not give you the solution you want, but it could be a a rough and ready fix.
    – blackthorn
    May 27, 2014 at 13:08
  • Ok, thank you! I've used the knot tool to re-draw the part of the global polygon that should fit the islands - it consumed a lot of time, so next time I'll try this Difference tool instead. May 29, 2014 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.