4

I have a file geodatabase in which I have a feature dataset. I have some feature classes inside the feature dataset. I wonder why when I attempt to save the result of Extract Values to Points (Spatial Analyst) inside my working feature dataset, the result is genereated inside the file Geodatabase but not under my feature dataset. No matter what I do I can't make it save the result inside my feature dataset. I can easily save the results of for instance Extract Values to Points (Spatial Analyst) inside my working feature dataset. But "Extract Values to Points (Spatial Analyst)" seems to be different in that regard. Any idea why this is happening?

Edits: I am using Arcmap 10.0 calling this tool from Arc toolbox. All the layers are in the same coordinate system. Here is a snapshot before I run the tool:

enter image description here

But as can be seen here the result is generated outside the feature dataset: enter image description here

  • How are you calling this tool? Is your out point features like c:\path\file_gdb.gdb\dataset\points? – Michael Stimson May 27 '14 at 3:44
  • I am calling this tool from Arcmap, Arc toolbox. Yes, the putput I enter is something like "P:\Temp\Geodatabase.gdb\dataset\output" – Arash May 27 '14 at 3:50
  • Is the output coordinate system the same as the feature dataset? The output is a point feature class, is that right? – Michael Stimson May 27 '14 at 3:51
  • Yes, all the layers are in the same coordinate sytstem. That is correct. – Arash May 27 '14 at 3:53
  • 4
    I think you've found a bug in the tool. I have encountered this once before, I can't remember which tool or version, and got around it by using a two-step method in a model: first create the output, then copy the output into the desired location and then delete the temp output. – Michael Stimson May 27 '14 at 3:56
4

This is indeed a bug: NIM-070258 - The Extract Values to Points tool creates an output in the geodatabase when a feature dataset is specified as the destination. Found in 10.0 SP2 and solved in 10.2!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.