1

I'm using ArcMap 10, and have a very dense map of Detroit with many point features. To lay out the labels properly, I converted the labels to annotation (stored in the map, not in a geodatabase), and spent hours and hours arranging them.

Now I'm trying to place a background label for Detroit. I'm using the Maplex engine, and in the label properties, I've selected "Background label (placed first)". But the label is still on top of everything else -- all other layers and the annotations. I also tried checking "Never remove (allow overlap)". How can I put it in the background? Also, are annotations always drawn above all labels? It seems like that's true.

4

Once you convert the labels to annotations they are no longer labels and therefore not governed by the Maplex engine, so none of the placement options or rankings (including the background label setting) have any effect.

When you convert labels to annotation in a database, they become another feature class and are stored separately from the mxd. If you convert labels to annotation stored in the map (and note if your mxd corrupts, your labels and all that placement work are gone), they are converted to graphics - essentially a text box in the data view. The text box is part of an annotation group which has some properties you can control from the Annotation Group tab on the dataframe properties dialog.

I believe (though I can't cite it at the moment) that labels draw on top of graphics and graphics draw on top of data layers. Annotations don't draw above labels, but labels try to avoid overlap with them (and other graphics) if not forced per the never remove option.

Probably the easiest solution to your problem is to:

  1. Either copy an existing annotation or create a new one using the text box tool on the Draw Toolbar (possibly with a new annotation group if not the default one - you have to pick on the Drawing drop-down button).
  2. Format it the size/color/etc you want it and move it into position.
  3. Right-click it, choose Order, and then Send to back.

It should then be behind all your other annotations but still on top of all your features.

  • I'm having trouble with step 3. The Order options don't seem to do anything at all. I have city/town names (as annotations) that I'd like to put under the annotations for points, but no luck. ArcGIS is amazingly frustrating. – Carl Raymond Jun 3 '14 at 20:03
  • I'm accepting this answer because of the good info about annotations. However, ArcGIS just isn't cooperating. – Carl Raymond Jun 3 '14 at 20:06
  • @CarlRaymond I was afraid of that. I got mixed results with data view draw order; some worked, others didn't. I noted that black went on top of everything, period. Other colors would respect ordering, but it also depended on which annotation group the text was in. To be fair, annotations in a map document was not intended to handle large numbers. If you convert the labels to annotations in a separate database, you should be able to more easily control layering by order in the ToC. You could also make your 'background' annotations partially transparent to achieve the effect I think you want. – Chris W Jun 3 '14 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.