4

I am having problems installing Qgis on Ubuntu 14.04 (Trusty).

I tried several approaches: installing from the Ubuntu standard repos, installing from http://qgis.org/debian and installing from http://qgis.org/debian-nightly, using both apt-get and aptitude.

Everytime, the installation fails because libnetcdf.so.6 cannot be found:

Setting up qgis-providers (2.3.0+git20140530+ca6d4d9~trusty1) ...
/usr/lib/qgis/crssync: error while loading shared libraries: libnetcdf.so.6: cannot open shared object file: No such file or directory

ls /usr/lib/libnet* gives:

/usr/lib/libnetcdf.a       /usr/lib/libnetcdf_c++.so.4      /usr/lib/libnetcdff.so        /usr/lib/libnetcdf.so        /usr/lib/libnetpbm.so.10
/usr/lib/libnetcdf_c++.a   /usr/lib/libnetcdf_c++.so.4.1.0  /usr/lib/libnetcdff.so.5      /usr/lib/libnetcdf.so.7      /usr/lib/libnetpbm.so.10.0
/usr/lib/libnetcdf_c++.so  /usr/lib/libnetcdff.a            /usr/lib/libnetcdff.so.5.1.0  /usr/lib/libnetcdf.so.7.1.1

So the library is indeed missing.

Any help is highly appreciated!

closed as off-topic by AndreJ, underdark Jul 5 '14 at 14:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – AndreJ, underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    It is a known bug hub.qgis.org/issues/10099 – Mapperz May 30 '14 at 15:54
  • I uninstalled python-pyspatialite by hand as suggested in the issue and retried the qgis installation, but I am still getting the same error when trying to install qgis via aptitude. With apt-get install, there is no error, installation just fails. This is driving me crazy. – user30816 Jun 2 '14 at 7:49
  • The reported bug ticket has been closed, so everything should be back to normal again. – AndreJ Jul 5 '14 at 11:51
2

If you open /etc/apt/sources.list (sudo nano /etc/apt/sources.list) and search for qgis you may find the repository commented out, something like:

# deb http://qgis.org/debian trusty main # disabled on upgrade to trusty
# deb-src http://qgis.org/debian trusty main # disabled on upgrade to trusty

just remove the proceeding '#'s

deb http://qgis.org/debian trusty main # disabled on upgrade to trusty
deb-src http://qgis.org/debian trusty main # disabled on upgrade to trusty

then:

sudo update
sudo apt-get install qgis
  • I tried this, and also qgis.org/debian-nightly. Everytime it complains that it cannot find libnetcdf.so.6. I added a symlink to a newer version of libnetcdf.so which made the error disappear, but then another library cannot be find while installing qgis-providers, so I strongly suspect something is going completely wrong. I am just not sure what it is. I installed qgis on two other Ubuntu 14.04 machines without any problems. – user30816 Jun 2 '14 at 7:54
1

I use the ubuntugis repositories and it works fine on my 14.04. Here are the commands i used.

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install qgis python-qgis qgis-plugin-grass
  • I used this exact approach, but it fails with the error described above – user30816 May 30 '14 at 15:37
  • The ubuntugis repository is not yet complete for trusty (14.04). So I suggest to remove all ubuntugis stuff, and install only from qgis.org. That worked for me. Or wait until they are finshed. – AndreJ May 30 '14 at 20:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.