I am trying to convert an OpenStreetMap file into a shapefile, but I am having problems with the "tags" field being cut-off after 80 characters. With QGIS 1.4, I use the OpenStreetMap plugin to 'Load OSM from file'. The file loads in QGIS. If I right-click on the 'lines' layer and select 'Save as shapefile', I end up with a shapefile but one that has an 80 char limit on "tags". How can I increase this 80 character limit?

  • 5
    The issue is with the field limitation with Shapefiles not QGIS. You can create a code (.txt) list and join that to the shapefile to get the full tag.
    – Mapperz
    May 18, 2011 at 18:19
  • The issue is not an 80 character limit in shapefiles, as @John correctly points out. The truncation is likely the fault of the conversion process.
    – whuber
    Aug 11, 2011 at 14:35

2 Answers 2


You can also import the data into a PostgreSQL/Postgis database and you will not have that limit. Use the osm2pgsql utility



Unless you have a specific need to use the shapefile format, Spatialite is a good option: its built-in to QGIS, has no limits on the length of fields and is supported by most of the open source tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.