1

I have set up geoserver and have it running well on my LAN. I finally set up a domain and want to host my own geoserver instance publicly. I have a jetty version of geoserver running on an OS X, Mavericks Server.

What do I have to do to point my geoserver instance publicly?

  • 1
    The points covered in this answer should help you: gis.stackexchange.com/a/85293/442 – Devdatta Tengshe Jun 2 '14 at 5:04
  • I am not 100% clear if you have a external domain set up? Do you have have a web server set up or are you serving from geoserver's built in web server? Tomcat is recommended over jetty for serving, but you can certainly use jetty. – Ralph Dell Jun 2 '14 at 12:38
2

By default the Jetty server that is installed with Geoserver is listening only localhost. What you need to do is to configure Jetty to listen to the IP address of your server. The place to do this is in file "jetty.xml" that is located in a directory like /geoserver-2.5/etc.

<Call name="addConnector">
      <Arg>
          <New class="org.mortbay.jetty.nio.SelectChannelConnector">
            <Set name="port"><SystemProperty name="jetty.port" default="8080"/></Set>
            <Set name="maxIdleTime">30000</Set>
            <Set name="Acceptors">2</Set>
            <Set name="confidentialPort">8443</Set>
          </New>
      </Arg>
    </Call>

As you can see, the host is not set which means that jetty is listening to the default one which is localhost. Add this line for example before the "port" line and your Jetty should begin to listen to IP address xx.yy.zzz.ww after restart.

<Set name="host"><SystemProperty name="jetty.host" default="xx.yy.zzz.ww"/></Set>
| improve this answer | |
  • Greetings, I've worked a bit with the jetty.host property but to no luck. When I add the host property geoserver won't start up correctly. Any ideas what I could be doing wrong? – user1303379 Jun 14 '14 at 14:41
  • when I set the jetty.host property I get the following startup error: 2014-06-14 11:18:30,615 ERROR [storage.DefaultStorageFinder] - Found Servlet context parameter GEOWEBCACHE_CACHE_DIR set to /opt/gwc , but this path does not exist – user1303379 Jun 14 '14 at 15:22
2

My recomendation is only one (or two :P ):

  • Download Geoserver in WAR format, and then use a J2EE server, like Jboss or a servlet server like Tomcat, for setup your Geoserver instance.
  • Use the Production Configuration for Geoserver.
  • Have to use GWC or tile cache to speed up WMS that will be serve. GWC is included in Geoserver, but there are alternatives like "Tilecache" or "MapProxy" (Mapproxy is awesome python script, I prefer it)

This scenario would be harder to configure, but much more stable and efficient.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.