1

I've just downloaded the CadTools plugin from QGIS Plugins page (can't do this through QGIS itself as I'm behind a proxy) and after installation I keep getting an error saying that it "Couldn't load plugin cadtools due an error when calling its classFactory() method".

Looking further into this there appears to be a problem with a line in the cadtools.py file relating to self.localPtah.pluginPath. pluginPath seems to be set to look in the i18n subfolder but I don't appear to have this subfolder in my installation.

Has anybody else had a similar issue with CadTools or have I just missed a step with the installation??

  • Are you sure you have downloaded the Qgis2 version of the plugin? – AndreJ Jun 3 '14 at 15:18
  • Hi Andre, I've downloaded version 0.6.2 from plugins.qgis.org/plugins and according to the metedata it should work with QGIS 2. – neoDaz Jun 3 '14 at 15:58
1

You are not the first with this problem:

https://github.com/geopython/CadTools/issues/5

My regular 0.6.2 installation also has no i18n folder, and I remember getting a similar error message without using the plugin at all. I then deactivated the plugin until I needed it again.

You can download the master zip with the i18n folder from https://github.com/geopython/CadTools and insert it manually into your CadTools folder.

Feel free to add your case to the issue.

  • Hi Andre, many thanks for that. Downloaded from github and everything seems ok :) – neoDaz Jun 4 '14 at 10:17
  • Well, it still is a bug of the plugin that the i18n folder is not included on the plugins.qgis.org site. – AndreJ Jun 4 '14 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.