0

When using gdaltranslate and gdalwarp I specify the following transfomation (in for GCP's and translate, out for warp)

+proj=lcc +lat_1=40.03333333333333 +lat_2=38.73333333333333 +lat_0=38 +lon_0=-82.5 +x_0=1968500 +y_0=0 +ellps=GRS80 +datum=NAD83 +units=us-ft +no_defs

This is intended to be the proj4 equivalent of Ohio South state plane US feet. If I open it in GlobalMapper it is placed exactly correctly (about -83 lon) though it isn't identified as Ohio South. However when I run listgeo the coordinates in feet are listed, but the lat long are not shown, and if I run gdalinfo the coordinates come back as

Upper Left  ( 1747866.344,  712518.960) ( 99d 6'46.00"W, 38d45'47.64"N)

with the longitude being completely off base. I also notice that the false_easting in gdalinfo come up as

"false_easting",6458320.416666666

which I also don't understand since I set it directly in the projection as 1968500'

In the end what I really want to do is digitize some coordinates in state plane, US survey foot, run them through translate to create a VRT file, then warp that and output Geotiff that has a recognized projection and will read directly into Global Mapper. I tried just using a prj or wkt file, but once I edit it to change the units to feet then the resulting Geotiff has the following tags either deleted or set wrong.

GTModelTypeGeoKey (Short,1): ModelTypeProjected (ends up user-defined)
ProjectedCSTypeGeoKey (Short,1): PCS_NAD83_Ohio_South (ends up missing)

Any thoughts on what I am doing wrong would be greatly appreciated.

1

Take a look at the SRS definitions at spatialreference.org.

I think that this is the SRS that you are working with:
http://spatialreference.org/ref/epsg/3729/

If I am correct, here is the .proj4 text for that SRS: http://spatialreference.org/ref/epsg/3729/proj4/

+proj=lcc +lat_1=40.03333333333333 +lat_2=38.73333333333333 +lat_0=38 +lon_0=-82.5 +x_0=600000 +y_0=0 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +to_meter=0.3048006096012192 +no_defs

  • Fantastic, just specifying a_srs "EPSG:3729" fixed it, though it still has one inconsistency in a Keyword that is being set to unknown. But that will be another question as it is the only thing stopping GlobalMapper from error free import and is easily fixed with geotifcp. – Dennis Aug 10 '10 at 2:05
1

It is an error with unit conversion.

1 968 500 meters = 6 458 333.33 feet (according to the Googles)

You've specified the false easting in feet but something thinks you really mean meters.

  • The number is correct for US Survey feet, but yes the real problem is why did it think it was in meters. Which I still am not sure of though DavidF at least nailed a solution. – Dennis Aug 10 '10 at 2:02
0

I'm not familiar with US projections and datums but maybe you have the same problem as friend of mine had recently. Look at the link. Maybe you are missing towgs parameters for you projection?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.