0

We just installed Service Pack 5 to our ArcMap 10 software. This allowed us to build a composite address locator based on the new streetfile and address pointfile built by our area 911 authority.

The new locator works very well, but when I am manually rematching a recently geocoded file and try to use the "Pick Address From Map" tool, the record shows as matched in the table, the XY data is added, but there is no point on the map.

I geocoded the same data set with both our old and the new locator, then tried using the "Pick Address From Map" tool on each of the resulting shapefiles. I attempted to place the same unmatched record in each instance. If I use our old locator to do the original geocoding the tool works just fine, which indicates that this is a locator-specific problem.

Again, in the shapefile resulting from our old locator the tool worked perfectly; in the shapefile resulting from the new locator the tool didn't work at all. I can't figure out why.

Does anyone have any suggestions as to why the tool would not work, or any idea how to repair it?

  • Just to cover the obvious, exactly how are you using Pick from Map? Are you using the Space bar or right-clicking and making sure to use match to click point? Or is it snapping to the nearest address and that's why you don't see a point where you expect it. I know you said it worked with a different locator, but like I said, just to cover the obvious. A screenshot of your matched but not plotted dialog might be helpful. – Chris W Jun 4 '14 at 17:43
  • I tried both methods of using the tool. I am using the "Match to Click Point" option, so there is no snapping, though I tried to snap it to a point just to see what would happen...it didn't work, though in every case the attribute table changed to indicate that it had indeed matched and it added XY coordinates that appear to be correct. THe only problem is that there is no point on the map. I have removed and re-added the layer, closed and opened the program, etc., there is no point displayed. – george Jun 4 '14 at 18:08
1

It appears there is an issue with rematching from composite locators.

http://support.esri.com/em/knowledgebase/techarticles/detail/27775

Seems you just have to repair the participating locators one by one and then you should be able to manually rematch.

  • That issue is stated as applying to Arc 9. I am unable to find any information about if or when it was addressed - do we know it still applies? Also, it indicates a crash or an error message which is not mentioned in the question. (As an aside, I can't figure out the difference between a CK and a NIM bug, but searching on the CK# got me nowhere except to the above link.) – Chris W Jun 4 '14 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.