I am trying to create a model to answer a question using a network analysis.


  • 10 possible fire station locations (shapefile)
  • Calls for demand points (shapefile)
  • Impedance is 5 minutes from facility to demand

Product: I need to make a model to select 1-3 stations from the list of 10 for the best locations to meet as many calls as possible with a 5 minute drive from the station.

Below is an image of what I have so far, but when I try and run it I get an Error saying:

  • Error 000735: Input Network Analysis Layer: Value is required
  • WARNING 030036: A layer with this name exists

Not sure how to fix these two items.

current model

  • Thanks for the response, Chris. I have been working with the actual tools for a while and haven't had an issue making the stand-alone tools work. My hope now is to create the model so that I can use it in a live action presentation. I updated the model that I have so far to take care of that unrelated service area solver that I had on there. This is for an actual site selection. Existing station locations are part of the "possible station locations" data layer.
    – acey37
    Commented Jun 5, 2014 at 13:30
  • Thanks for all the help! I will run the service area polygons and demand points idea by my boss and see if that would be okay. My guess is he'll want to stick with the location-allocation method if at all possible. Now it seems when I run the model it appears to be happy (I get the "completed" dialogue window) , but then I don't have any shapefile outputs that pop up in the table of contents, or on the map. I triple checked that I have clicked the "Add to Display" check box.
    – acey37
    Commented Jun 9, 2014 at 13:05
  • I've also set my current and scratch workspace to the folders I want. After a (seemingly) successful run, I go into that folder, but no new shapefiles have been created.
    – acey37
    Commented Jun 9, 2014 at 13:09
  • 1
    At this point we're diverging from the Stack Exchange format of one question and one answer since we're up to two, and more of a complete model troubleshoot. I suggest any further distinct issues (from the original errors and the lack of outputs) be asked as separate questions. Technically the lack of output should already be asked separately rather than in a follow-on comment, and I could move that part of my answer to the new question.
    – Chris W
    Commented Jun 9, 2014 at 22:29

1 Answer 1


In your original image you had an unused Service Area Layer tool which is a potential cause of error 735. If you still get 735 after removing that, it would indicate an unexposed, required parameter in the Make Layer tool isn't set (possibly impedence attribute based on your model screenshot). Just before the error number in the results it may give you more specific info.

Warning 030036 is just that, a warning that a layer name already exists and it will be overwritten. This will happen if you don't clear/delete stuff created by a run before running again (validate doesn't do this). It should not affect running the model unless you also get a write failure.

As for your lack of outputs, Network Analysis Layers (properly layer groups) are feature layers, not feature classes or shapefiles, which is what you load into them. They're constructs used to solve a problem, and it all takes place in memory/scratch. Results aren't permanent until you export them, much like a Create X,Y Event Layer. Your model currently selects lines, demand points, and facilities, but it doesn't do anything with that selection (there's also no reason to have those results as parameters). You need to add some sort of export tool, such as Copy Features after your select tools. It's there you would make a parameter of the output file to save permanent copy of the results.

Displaying the results is a different issue, as checking the Add to Display should add the results to a map. When I replicated your model, checking that box on your select outputs added them to the map with or without also adding the last version of the location allocation layer (you should try that to see if anything is being created) or anything already being in the map. If yours is not, that may indicate the solver isn't actually generating any results for some reason. It may also depend on how/where you are running the model from (ie, in Modelbuilder > Run Entire Model or just double-clicking it in ArcCatalog within toolbox).

I understand you want model the solution you have, however I want to offer an alternative method: run a 5 minute service area analysis to generate polys, then get counts of demand points per poly to find the three with the highest count. Location Allocation is more complex and has several variables (problem type, weighting) that I didn't fully explore in figuring out the modeling issue, but I did note they can change the results. You may already be familiar with them and have all the necessary details and decisions.

Also, it has you counting existing stations as possible locations. Unless they are considering abandoning existing stations and moving to 'optimal' locations, it seems the analysis would better find demand points not already served within five minutes and then pick proposed candidates that can reach the maximum number of those with minimal overlap of existing station service areas. But again, you obviously have more details and information about the problem and it may be a different one than I'm interpreting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.