Linked Questions

1
vote
0answers
155 views

QGIS dependency problem [duplicate]

I had QGIS version 2.18.14 installed on my ubuntu. Today I wanted to make an update, but some problems came up. So I deleted QGIS and wanted to reinstall it. But everytime I try to reinstall it, this ...
26
votes
6answers
22k views

Install QGIS 2.14 Essen on Ubuntu 16.04 Xenial

I'm having trouble installing QGIS on Xenial. `debian` release When I try using the debian release (i.e. without ubuntugis dependencies) I get the following errors (please note there is no xenial ...
7
votes
1answer
9k views

Geting and installing latest version of QGIS in Ubuntu? [duplicate]

I'd like to get the latest 64-bit dev build of QGIS on my Ubuntu setup. How exactly do I go about it? I assume it's some kind of arcane terminal command.
6
votes
2answers
2k views

Linux Mint: QGIS won't install

Linux Mint 17.2. After trying to reinstall QGIS through various processes referred to on SE, AskUbuntu & anywhere else*, I get various unmet dependency or held broken packages errors. Even with ...
12
votes
2answers
1k views

QGIS removed after updating to 2.18.5 on ubuntu

After updating to QGIS 2.18.5 using ubuntugis ppa my QGIS 2.18.4 installation was removed and I get an error about unmet dependencies when I try to install QGIS at the terminal: The following ...
4
votes
4answers
3k views

Installing QGIS on Ubuntu 14.04?

Following the QGIS installation guide I have tried both UbuntuGIS and QGIS stable, but both fail with the error message: The following packages have unmet dependencies: python-qgis : Depends: python-...
5
votes
1answer
3k views

QGIS installation fails under Ubuntu 16.04

I decided yesterday to upgrate QGIS from 2.16 to 2.18. This turned out to be a stupid idea, because the following happened: After removing, purging and autoremoving qgis, python-gis and grass I ...
6
votes
1answer
2k views

Where to find a version of libgeos-c1 compatible with libgeos-3.5.0?

This morning a number of Python scripts stopped functioning after a system upgrade. libgdal is no longer available, resulting in the following exception: ImportError: libgdal.so.1: cannot open shared ...
3
votes
1answer
1k views

libgdal1 and libgdal1h conflict

I am on Ubuntu 14.04. When I am installing PostGIS-2.1, it's asking for libgdal1 library. But when I am installing libgdal1, it's removing grass and gdal. Can someone please guide me how to install ...
2
votes
1answer
534 views

Different output of gdalinfo --version and gdal-config in Xenial

I have Ubuntu 16.04 with postgresql 9.6 postgis 2.3 QGIS 2.18 installed. I am trying to install mapview (R library) with no success because of sf defencency. I had this output: configure: ...
0
votes
2answers
207 views

Bonn 3.2.2 to buggy need to install older version of QGIS

I am having a lot of issues with Bonn 3.2.2 QGIS and would like to uninstall this version and install an older version that is more stable. What seems to be a stable version of version 3? What is ...
1
vote
0answers
181 views

Is it possible to have postgres9.6 and postgis 2.3 on ubuntu 14.04?

I want to upgrade/install postgres9.6 and postgis2.3 on trusty but I cannot find a way... Has someone succeed on that? Ps. this repo sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ $...