Questions tagged [anaconda]

A free collection of Python packages for large-scale data management, analysis, and visualization.

Filter by
Sorted by
Tagged with
0
votes
0answers
5 views

Is it possible to use ipyleaflet in a jupyter notebook running on an Anaconda Enterprise server?

This question is very similar to Ipyleaflet map object doesn't display in Jupyter Notebook but it gets created and uses the same example: https://ipyleaflet.readthedocs.io/en/latest/api_reference/...
0
votes
0answers
30 views

Set default version of Python in ArcGIS to 64-bit?

This is the output from Python terminal within ArcMap 10.6.1 for Windows 10: >>> import sys, numpy, matplotlib >>> print(sys.version, numpy.__version__, matplotlib.__version__) ('2....
0
votes
0answers
38 views

Fail to import gdal from conda environment?

I installed gdal from this link: http://www.gisinternals.com/query.html?content=filelist&file=release-1911-x64-gdal-3-0-0-mapserver-7-4-0.zip When I use the the following command from this ...
0
votes
0answers
36 views

gdal_translate not recognizing file format [duplicate]

I am trying to convert a .dat file to a .tif file using gdal_translate. The .dat file comes with an associated .Hdr file of the same name with the metadata (these are geospatial data from SNODAS). ...
0
votes
0answers
27 views

gdalinfo --formats return different values in python3 than in OSGeo4W

I am working whit geopdf to obtain the layers. When I use driver = ogr.GetDriverByName('PDF') it return None, and obviously I can't open it. I have checked with the command gdalinfo --formats and it ...
2
votes
1answer
722 views

TypeError: tuple indices must be integers or slices, not str after ingested data into the open data cube

I've ingested some landsat 5 images into a database using the open data cube. The problem is that when I try to run the continous change detection function following the jupyter notebook I get a ...
0
votes
0answers
495 views

DLL Load Failed: The specified module could not be found -Anaconda 3 on win10

I know that this question has been asked a lot (e.g., here, here, here, and here), but none of the solutions worked for me. I downloaded the latest Anaconda version (file name - Anaconda3-2018.12-...
1
vote
0answers
69 views

Importing gdal in Python with anaconda changes environment

I have installed gdal through anaconda. When I run a subprocess in Python before importing gdal I can get that gdal tools are located in my conda environment. For example subprocess.run(['which', '...
0
votes
0answers
107 views

MacOS error when installing GDAL in conda: pyopenssl and setuptools dependency

I was trying to install GDAL on MacOS Mojave 10.14.3 using these following methods: conda install -c conda-forge gdal conda install -c conda-forge/label/gcc7 gdal conda install -c conda-forge/label/...
2
votes
1answer
697 views

Access QGIS API from Anaconda python environment using Conda-Forge

I am trying to use QGIS in stand-alone python scripts (windows 10, python 3.6.6). After the following steps... 1) create new conda environment (geospatial) 2) install the qgis conda-forge package ...
3
votes
1answer
103 views

Using ogr2ogr on Anaconda

I am building a Choropleth map in D3.JS. In order to do that, I have downloaded a map from Eurostat. From the GeoJSON file, I want to extract the country for the visualization, in my case Portugal. ...
0
votes
2answers
191 views

skimulator - Python error message on Windows 10 - load_entry_point

I am running python code called skimulator on Windows 10 to model Arctic ice drift and sea/wave velocities for a satellite mission in 2025. Its installed using Anaconda navigator with a python 3, ...
0
votes
1answer
203 views

Error message, for “pip install /path/to/the/skimulator/directory” on Windows 10 Anaconda/python

I am trying to install skimulator on my windows 10 system. This is for simulating images of sea ice drift in the Arctic, for 2025 satellite mission. I have installed Anaconda/python and followed the ...
1
vote
0answers
59 views

Access ArcGIS Pro conda env in R

Environment: Windows 7, ESRI ArcGIS Pro 2.1, R 3.5.1 with reticulate v1.10. ArcGIS Pro comes with a pre-configured python 3 conda environment that I'm trying to access in R. Related questions here ...
3
votes
1answer
671 views

Installing Arcpy in an Anaconda enviroment.

I recently uninstalled Anaconda due to a conflict with my pandas packages. I use to have it configured with my ArcGIS Pro Python 3.65 environment. Now I want to reinstall it, but for my ArcGIS ...
0
votes
0answers
389 views

Will Anaconda with Python 3.7 work with Python 3.6.5 environment of ArcGIS Pro?

I just uninstalled my Anaconda with Python 3.6 and need to reinstall, but the current version is now with Python 3.7. Will that work for ArcGIS Pro (Python 3.6.5)? I'll have to copy the ArcGIS Pro ...
1
vote
1answer
4k views

Uninstalling and Reinstalling Anaconda

I had 2 versions of pandas (22 and 23) in my Anaconda environment for Python 3.6. One of the pandas looks like it was installed through Python 2.7 pip. Basically, I am unable to import pandas at all ...
2
votes
1answer
7k views

Installing GDAL with Anaconda

I just did a fresh install of Anaconda3 and am trying to add GDAL/OGR. I've tried installing with both conda install gdal and conda install -c conda-forge gdal. In both cases, the install completes ...
0
votes
0answers
113 views

Importing ArcPy in Python terminal?

I am getting a pretty interesting error in my attempt to import arcpy in my python command line. The end goal of this effort is to have a working Spyder IDE that can run arcpy. I've been able to get ...
1
vote
1answer
334 views

Installing Anaconda for Python 3.6 without wrecking Python 2.7

I have both Python 2.7 with ArcGIS 10.5 Desktop and Python 3.6 with ArcGIS Pro. A few weeks back, I tried to install Anaconda (w/ Conda, Spyder, Jupyter, etc..) and it somehow overwrote my system ...
5
votes
2answers
2k views

Cannot install a version of GDAL via Anaconda that permits reading BigTIFFs

I have some BigTiff files that I need to read into Python using gdal to do some analyses. According to GDAL's documentation: When built with internal libtiff or with libtiff >= 4.0, GDAL also ...
0
votes
0answers
3k views

Anaconda Navigator not launching, even from the prompt

Anaconda navigator not launching. I really don't want to re-install because I have a working install of TensorFlow that runs in Spyder, I'd rather not mess that up! Error log has a permission denied ...
0
votes
2answers
253 views

ArcGIS Pro 2.0 and Anaconda environments

I have had to reinstall ArcGIS Pro 2.0 and have attempted to recreate an Anaconda environment, but am running into some problems. When I create a new environment from the initial ArcGIS Pro ...
2
votes
2answers
2k views

Installing PCL module for Python 3.6 in Anaconda

I am using Python 3.6 in Anaconda3 for Windows10(64) and would like to install PCL module. I tried conda install -c sirokujira python-pcl from (https://anaconda.org/sirokujira/python-pcl) and ...
1
vote
0answers
74 views

Execution Error in Python when calling Clip tool

I have written a simple code in python for clipping. The code is : #Step 1 To clip the Study area import arcpy import os import sys from arcpy import env from arcpy....
1
vote
1answer
689 views

Anaconda (Python36) error after installing ArcGIS: No module named 'arcpy'

I have a Anaconda with Python 3.6, and I installed the ArcGIS with the command conda install -c esri arcgis but when I went to test it presented the error: No module named 'arcpy'. I saw the ...
2
votes
0answers
212 views

GDAL FileGDB Driver with Anaconda / ArcGIS Pro

I have installed GDAL using the ArcGIS Pro (2.1.2) Package Manager. This has installed GDAL 2.2.2, which runs fine, except that it didn't install the FileGDB driver which is what I need it for. It is ...
3
votes
2answers
3k views

Installing QGIS3 on a Mac with Python in Anaconda

I am trying to install QGIS3 via Kyngchaos installer. But as I install python 3.6 in anaconda, the installer cannot find it. I know I can install a new environment or use symlinks to connected to ...
0
votes
1answer
182 views

Managing multiple Python interpreters (ArcGIS, OSGeo, etc.)

I currently have several Python interpreters installed through ArcGIS, OSGeo and Anaconda. C:/OSGeo4W64/bin/python.exe C:/Python27/ArcGIS10.4/python.exe C:/Users/[UserName]/Anaconda3/python.exe ...
0
votes
0answers
3k views

Import osgeo/gdal fails with Anaconda / Spyder

I am trying to use osgeo/gdal with Anaconda, but am failing to import osgeo or gdal when attempting to use a custom Anaconda environment. I have created a new Anaconda environment that can utilize ...
0
votes
2answers
338 views

ArcPy importing error after setting path?

This questions has been asked before too and I did go through most of the suggestions. Things I have tried so far: setting up correct path variable environment, installing anaconda 32 bits, python 2....
5
votes
2answers
6k views

GDAL ImportError: DLL load failed: The specified module could not be found

I'm running Python 3.5.4 on Anaconda and i'm trying to install geopandas. I've followed the instructions to install geopandas here - http://geoffboeing.com/2014/09/using-geopandas-windows/ - but ...
0
votes
1answer
410 views

Installing virtualenv & pip to work with ArcPy?

I have a Windows machine with a ArcGIS 10.3.1 (w/ Python 2.7.8) install that the powers that be DO NOT want me to uninstall/reinstall. I would like to find a way to: set up some virtual ...
-1
votes
1answer
320 views

Installing SimpleCV for planet water change calcularion

I'm trying to instal SimpleCV using - pip install https://github.com/ingenuitas/SimpleCV (install using this fork to avoid an error in Step 8). Also already have installed NumPY and OpenCV. The ...
2
votes
1answer
626 views

GDAL conda install on Mac OS trouble

I'm trying to install gdal on my new computer in the anaconda environment using conda but having issues. All I've done so far is install Anaconda for python 3.6 and install gdal as described here + a ...
1
vote
1answer
116 views

Working with numba in QGIS

I am trying to install the python library numba with pip from the OSGeo4W shell, but I haven't been able to do it. The only way I could do this was through the anaconda installer. but since Anaconda ...
1
vote
2answers
552 views

Installing sen2cor on Anaconda 4.4.0

I would like to install sen2cor in Anaconda 4.4.0 virtual env. How to know the list of dependencies needed? Is there environment.yaml file for sen2cor?
2
votes
2answers
2k views

Using spyder as Python IDE with ArcGIS Pro?

I just installed ArcGIS Pro and would like to either import arcpy into anaconda, or use spyder as my IDE in GIS. I have tried two things: For ArcGIS Desktop you had to copy the .pth file from GIS to ...
0
votes
0answers
299 views

Importing GDAL in spyder from a local GUI in cygwin

I have installed anaconda on linux (python 2.7). Since gdal is not pre-loaded I load it with conda install gdal, which is fine. When I do: from osgeo import gdal I get the following error though: ...
1
vote
1answer
739 views

Opening Landsat-8 GEOTIFF in Python?

I've run into an error when trying to open a Landsat-8 geotiff file in python, it seems like I am missing some tiff libraries but I'm not sure how to install them or where they need to go. Has anyone ...
1
vote
1answer
651 views

GDAL code does not work on anaconda interpreter

I wrote a code that projects a raster to a new coordinate system. from osgeo import gdal filename = r"C:\Users\rsl\Desktop\New folder\SN228122015_mosaic.tif" input_raster = gdal.Open(filename) ...
3
votes
0answers
489 views

Anaconda UnsatisfiableError installing QGIS

If I run conda install -c conda-forge qgis=2.18.2 from my Ubuntu bash environment, I obtain the following error: UnsatisfiableError: The following specifications were found to be in conflict: - ...
5
votes
1answer
3k views

Installing jp2 driver for GDAL

I cannot open jp2-files with gdal: This works fine (the Sentinel2 metadata): ~/copernicus/S2A_MSIL2A_20170111T100351_N0204_R122_T33UWP_20170111T100351.SAFE$ gdalinfo MTD_MSIL2A.xml Driver: ...
3
votes
1answer
2k views

Getting QGIS to work with Python2.7 Anaconda Distribution?

I use Python 2.7 from Anaconda installed in a python environment on my computer (MacOS Sierra 10.12). QGIS is installed from the KyngChaos framework, and I know that there are problems with mixing ...
4
votes
1answer
847 views

Jupyter and ArcGIS error: arcpy needs to run within an active ArcGIS Conda environment

I have installed ArcGIS Pro 1.3 and Anaconda 4.2.0 (in that order). I then followed the instructions from ESRI on Adding the ArcPy Path to Anaconda which made Jupyter find the arcpy module but I get ...
3
votes
1answer
2k views

How to import qgis.core in spyder?

I used to use spyder as python IDE and was learning QGIS developing recently. But I cannot import qgis.core in spyder although the library can be imported in QGIS Desktop Console successfully. Here ...
4
votes
1answer
254 views

import anaconda-installed modules from arcgis's python

How can I import anaconda-installed modules from arcgis's python shell? I have tried the method described in https://sites.google.com/site/advancedgisprog/other-resources/arcgis-anaconda-packages. ...
4
votes
0answers
63 views

Configuring manual python library installations [closed]

Windows 7. My python path reads: C:\Python27\ArcGISx6410.4;C:\Python27\ArcGIS10.4;C:\Anaconda;C:\Anaconda\Scripts The end of my user path reads exactly the same thing. Yet, when I try to install ...
0
votes
1answer
481 views

Anaconda clashing with cgi scripting

I am using Mapnik v2.2.0 for Python 2.7 (32 bit - Anaconda distribution) at the moment and I wanted to use it in a rudimentary CGI script. The mapnik is definitely installed correctly as it runs ...
10
votes
1answer
7k views

GeoPandas to_file() saves GeoDataFrame without coordinate system

I have GeoPandas 0.2.1 py27_0 fiona 1.7.0 np110py27_1 Python 2.7.10 installed in Anaconda 2-4.1.1-Windows-x86 environment. I am able to construct GeoDataFrame by reading input datasets and ...