Questions tagged [apache]

Apache in this context implies the Apache HTTP open-source web server; it shouldn't be used for other software packages developed under the Apache Software Foundation.

Filter by
Sorted by
Tagged with
0
votes
1answer
20 views

Clients can't access maps from local offline tile server [closed]

I'm building an offline tile server using the instructions found for Ubuntu 12.04 on switch2osm.org. The server is working as intended and rendering maps from the downloaded content. When a client ...
0
votes
0answers
17 views

How to setup my Tileserver-php

I have downloaded "xampp-windows-x64-7.3.6-3-VC15-installer.exe" and installed only Apache and PHP. My Apache server is running. I have download "tileserver-php-master" and paste the folder in path ...
1
vote
1answer
51 views

Mapserver weird output of REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1.1.1

Once I use REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1.1.1 in my browser with the mapserv I get the following: $ cat ~/Downloads/ms ELF>�@@!@8 @@@@��888�� �� � �� �� � TTTDDP�tdLLQ�...
1
vote
0answers
67 views

mapcache + sqlite + http2 nginx

searching for the maximum speed I can get from our mapcache service, I'm going to make some test in a new server (AWS EC2) with Nginx as a reverse proxy and Apache before to update the live system. ...
0
votes
2answers
177 views

Displaying GeoJSON using Ajax and Leaflet?

I have been trying for days to load a GeoJSON file using Ajax and Leaflet. I can get the map & index.html to load using an Apache server and such but the GeoJSON itself does not show up. Here is ...
2
votes
0answers
96 views

How to tune the performance of Nominatim Reverse Geocoding Application

Running the query directly to the PostgreSQL takes 3-8ms. The PostgreSQL can handle 500 concurrent connections. The Apache server is running on 8 core CPUs. Analyzing the Apache access logs: There are ...
1
vote
0answers
111 views

PBF vector tiles reach the client through Apache HTTP Mod_rewrite, but not shown in Leaflet. How to show these PBF in Leaflet?

In short: This is about proxy-ing access to OpenMapTiles (OMT) by Apache Http. The proxy works hence the PBF tiles from OMT reach the client. However Leaflet fails to draw the PBF tiles in the map. ...
0
votes
0answers
955 views

http GET request encounters AH02429 (response contains invalid characters)

I installed zoo-project from sources (latest) on both a Ubuntu 16.04 VM and docker container. I also have a few python scripts that are already used on a production environnement, with no problem. A ...
1
vote
0answers
82 views

Cannot generate mapnik tiles on Fedora

I have gone through the following tutorial to start a map server on Fedora 28: https://wiki.openstreetmap.org/wiki/Mapnik/Installation_on_Fedora_18 Although the tutorial is a bit old, most of the ...
0
votes
2answers
312 views

How to make Mapserver URL shorter?

I got an Apache and MapServer bundle. On MapServer I made a WMS service and connect it to clients (Leaflet, QGIS etc.) with an URL like this: http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/...
4
votes
0answers
388 views

Secure OSM instance and prevent unwanted access [closed]

I just finished installing an OSM instance in a local VM. So far so good, tiles are being served just fine. This VM will be public on internet, so my clients can access the tiles from my web page. ...
1
vote
0answers
48 views

Using php_mapscript on WAMP? [closed]

I use WAMP in my Windows, and I want to use phpmapscript for programming. I've copied the phpmapscript.dll file to C: \ wamp64 \ bin \ php \ php5.6.25 \ ext and I added the "extension = php_mapscript....
4
votes
1answer
298 views

QGIS Web Client 2 connection time out?

I have recently installed QGIS Server and Web Client 2 in the hopes of being able to share my map, that I made in QGIS, with some clients. I've started my app with yarn and I'm now at a point where I ...
2
votes
2answers
1k views

405 Method not Allowed on uploading a shapefile via REST API on GeoServer

I'm using PHP cURL to upload a Shapefile to GeoServer. It works fine in a development server. But when I deploy to Stage server and I try the same I get: 405 Method Not Allowed The requested ...
3
votes
1answer
407 views

Adding a security layer to my tile server [closed]

I have a tile server (apache2 + mod_tile serving OpenStreetMap data) that I'm going to use via Leaflet. Everything's working fine but before putting this public, I have a big concern about the ...
2
votes
0answers
257 views

How to authenticate secured layer on Geoserver from javascript (leaflet/openlayers) requests [closed]

I have a Geoserver instance on a docker container that sits on an Ubuntu host. At the moment, requests to the Geoserver container are forwarded on through the host's Apache web server. I am making ...
0
votes
2answers
768 views

Unable to publish a GeoTiff file in GeoServer with curl tool

I have a workspace in GeoServer with many shapefiles and postgis tables. Now I'm writing a script that will publish GeoTiff files in that workspace using curl tool. I'm trying to succeed that in two ...
1
vote
2answers
796 views

mapserver: accessing mapfile with localhost instead of system path

Don't know if GIS SE is the right place to ask this question. Otherwise, please feel free to suggest me where should I migrate it. I need to access my mapfile with localhost to test my service via my ...
0
votes
0answers
223 views

Mapbender3 Fatal Error

I'm trying to get Mapbender3 to work with Apache2.4 and PHP5.6. I have Apache and PHP talking to each other and installed correctly. I have followed the instruction to install Mapbender3 found here: ...
0
votes
1answer
953 views

apache httpd mod_tile error: “Failed to create shared memory segment on file”

This question may seem out of place, but it appears it's coming from mod_tile, so thought I'd give it a shot here.. (I also haven't managed to get answers elsewhere..) Started getting this error once ...
1
vote
1answer
344 views

Calling Python ogr2ogr from PHP doesn't work as expected?

I have a HTML page that takes and uploaded zip file and then calls a PHP page as a form action. That PHP then calls two Python scripts in my Apache cgi-bin. The first Python script runs with no issue ...
1
vote
1answer
635 views

Installing gdal to geoserver running with apache tomcat

I have been following Mastering GeoServer pdf from Colin Henderson to install gdal but didn't succeed. Here is what I did: install Java, I've installed JRE windowsx64 (because my pc is x64) install ...
1
vote
0answers
136 views

Issue while configuring DNS with Portal for ArcGIS

Steps followed:- Portal for ArcGIS 10.4.1 (Linux SUSE) Installation ArcGIS Web Adaptor (Linux SUSE) Installation Configuration of Portal with Web Adaptor (Web adaptor is configured on Apache Tomcat ...
2
votes
1answer
136 views

GeoServer deployment

I've been trying to deploy GeoServer in a WAMP/Apache environment via a .war file. (GeoServer being downloaded as a web archive) When I try to enter the address in the web browser, I get this: Has ...
2
votes
0answers
513 views

Unable to access https enabled OGC WMS service in Portal for ArcGIS 10.4.1

OGC WMS service is published on WebLogic 10.3 (https enabled). We are able to access OGC WMS service deployed in web logic server through browser and secured connection was established successfully. ...
3
votes
2answers
4k views

How to change GeoServer port from 8082 to 80?

How can I change the port GeoServer is running on from 8082 (in OSGeo Live VMs) to 80? There is a related question here in GIS.SE., but the answers were about changing the underlying tomcat port from ...
1
vote
0answers
172 views

QGIS-Server Plugin Process per client (WMS) [closed]

I have a working infrastructure containing Apache2 with FCGI and QGIS-Server bundled in a Docker Container to deliver a WMS. My written Plugin (Python) for QGIS-Server is working like expected. It ...
3
votes
1answer
250 views

Problem with showing WFS layer with OpenLayers

I'm using OpenLayers and GeoServer in combination with Apache for creating GIS-based WEB application. I have created layers and styled them in GeoServer, but when I try to load those layers with ...
3
votes
0answers
203 views

QGIS server crashes with GetPrint request

I'm running QGIS server on Ubuntu 14.04 and until now it worked without problems. Now I want to create print composer output, GetProjectSettings request shows composer template "plantilla". I ...
5
votes
0answers
282 views

Unable to create multi-user system using GeoServer

I am unable to secure my GeoServer installation and grant read and/or write access to different roles. On the most basic level, I would like to have a VIEWER and an EDITOR role that I can apply to ...
1
vote
1answer
344 views

Configuring qgis map server to apache web server platform? [closed]

I installed Apache Web Server from OSGeo4W. here is the image shown below. But when i put URL http://localhost/cgibin/qgis_mapserv.fcgiSERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities i get ...
6
votes
1answer
2k views

QGis-Server 2.14 raises error reading project file on Ubuntu 16.04

I installed QGis-Server 2.14 on Ubuntu 16.04 following the instructions on this blog. The fgci on its own is responsive and correctly replying to a GetCapabilities request like: http://localhost/cgi-...
1
vote
1answer
1k views

QGIS-Server - 500 internal server error

QGIS-Version 2.14.5 LTR, QGIS Server running on Windows 2008 R2 I encounter a '500 Internal Server error' when using the url http://localhost/qgis-ltr/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1....
3
votes
2answers
1k views

What is an appropriate tileLayer source for tiles served on an apache localhost through leaflet?

--I found a solution. Please, see answers below.-- I've been trying for about about 25 hours to get a working, locally hosted, tile server running, using this guide from switch2osm. I have a ...
1
vote
0answers
287 views

how to run multiple instances of tile server on a single machine?

I installed OSM tile server on Ubuntu 14.04. I followed instruction given here https://switch2osm.org/serving-tiles/manually-building-a-tile-server-14-04/ . I want to perform "vertical load balancing" ...
1
vote
1answer
386 views

Installing QGIS-Server on Ubuntu 14 (64-Bit AWS EC2 Instance), /cgi-bin/ doesn't work

I've been trying to install qgis-server (2.14) on Ubuntu 14 (64-bit) using instructions from the the qgis-server installation instructions and tips from this question. All the packages install, I can ...
1
vote
2answers
1k views

“ QFSFileEngine::open: No file name specified ” installing QGIS Server on Windows 2012R2

I am attempting to get QGIS Server installed on a Windows 2012 R2 Server. After following the information at the https://anitagraser.com/2012/04/06/qgis-server-on-windows7-step-by-step/, and looking ...
-1
votes
1answer
618 views

Enabling CORS filter in Tomcat 7

I am trying to access a WMS layer from GeoServer installed locally and adding to my Cesium JavaScript application. WMS layer was not being added. I just found from search that it may be due to CORS ...
2
votes
1answer
2k views

How to add OpenSeaMap tiles as an overlay on top of osm base map with Leaflet?

After generating the OpenSeaMap tiles, I tried to add them as an overlay upon the openstreet basemap. The idea is after generating the OpenSeaMap tiles to serve them as "static" tiles to the client, ...
2
votes
1answer
135 views

Apache can not start

I installed the OsGeo4W-Installer and finally wanna open the link:localhost but at present, I tried to start apache, but failed. I checked the port 80, it was ok- I tried to find the error by cmd, ...
3
votes
1answer
761 views

GeoWebCache and Load Balancing

We have a setup that contains 4 geoserver instances being hosted in JBoss across 2 machines. We also have a load balancer machine which contains an Apache Server and a Tomcat Server. Our environment ...
3
votes
0answers
349 views

How to monitor geoserver map performance using jmeter? [closed]

I want to monitor the geoserver map performance using jmeter which is been load balanced in Apache http server, now I want to know how should I achieve this and what all changes I have to do in jmeter....
1
vote
1answer
202 views

Mapserver - hide error messages

Using mapserver 7.0, is there a way to suppress the error messages sent to the user, such as :- <?xml version='1.0' encoding="UTF-8" standalone="no" ?> <!DOCTYPE ServiceExceptionReport ...
1
vote
1answer
816 views

Change localhost:8080 to my domain name in Geoserver

I'm new in Geoserver and openlayers 3 and i want to publish my layers to be access from my subdomain (I want to change localhost:8080/geoserver to subdomain/geoserver) i'm using Windows 7 xampp ...
3
votes
1answer
781 views

Spatialite not loaded in PHP5 on Ubuntu

I'm trying to install Spatialite (4.3.0a) on Ubuntu (14.94.2 LTS) ..... I'd like to use it with PHP (5.5.9-1) .... Following this post https://faimsproject.atlassian.net/wiki/display/FAIMS/...
1
vote
0answers
170 views

Does Cassandra support GIS operations? [duplicate]

We are trying to build out stack on top of geo-spatial data, this means storing more than 10000records per a second. we are using Storm to accelerate receiving the data, but we would like to use some ...
0
votes
1answer
425 views

How configure Spatialite for PHP Version 5.6.14 (on Windows 7 and Apache 2.4)?

I'm on Windows 7, using PHP Version 5.6.14 on Apache 2.4 and I'm trying to access to a Spatialite database. All works fine when execute "no spatial" SQL query in my PHP procedure but when I try to ...
3
votes
1answer
396 views

Setting up Tile Map Service on Apache

I am trying to set up a tile map service on Apache. I tried following this: Setting Up a TMS Tile Map Service on a Web Server but when I go to load the page it's not loading the images in my /var/www/...
0
votes
2answers
613 views

error setting up QGIS server with apache 2.4

I keep getting the 403 error and I have followed the directions from here. Anyone know what's wrong? Adding QGIS Server to an existing Windows web server I set the httpd_gis.conf to require all ...
1
vote
0answers
734 views

Run mapserver under installed xampp

I'm running xampp in windows 7, apache is listening port 80. I downloaded MS4W and installed the bundle under c:\ms4w and configured apache to listen on port 8080. I'm running htt://localhost:8080/...