Questions tagged [centos]

CentOS (abbreviated from Community Enterprise Operating System) is a Linux distribution that attempts to provide a free, enterprise-class, community-supported computing platform which aims to be functionally compatible with its upstream source, Red Hat Enterprise Linux (RHEL).

Filter by
Sorted by
Tagged with
0
votes
0answers
11 views

Error with v.net

When running v.net on CentOS 7 I ran into the following error: GRASS 7.6.0 (srilanka2):/tmp/final > v.net input=roads points=bs output=network op=connect thresh=5000 Copying features... 100% ...
0
votes
0answers
8 views

Terminal connection error when running v.net.steiner

I am using GRASS 7.6.0 on a CentOS server. I've attempted to run the v.net.steiner function on the map layer with the following properties: Layer/table: 1/network type count min ...
2
votes
0answers
23 views

Resolution for different layers using Python GDAL

I'm extracting data from a GRIB file using GDAL in Python 3 on CentOS. The model is 40 km resolution, and is usually 151x93. When I try to extract data from band 195, I get the following error: ...
0
votes
0answers
36 views

Map Proxy Service in Linux

The MapProxy instance for an application I am working on runs as a local server behind an Apache Server which proxies requests. I am planning to create a custom service for running MapProxy instance ...
0
votes
1answer
42 views

MapProxy doesn't start with EPSG:28992 while it starts and works fine with EPSG:4326

We are moving from Debian to CentOS and in that process we discover that MapProxy installation is turning out tougher in CentOS than it was in Debian. One of the dependencies 'libproj' is not ...
0
votes
0answers
63 views

ERROR 1: gdal_translate was compiled against GDAL 2.0, but the current library version is 2.2

I have tried to uninstalled both version but failed. both version were installed from source. How can I remove both version or point to 2.0 version.
0
votes
0answers
67 views

Spatialite: command not found on CentOS 7

I've installed Spatialite on CentOS 7 using this procedure: 1) SQLite installation wget https://www.sqlite.org/2018/sqlite-autoconf-3240000.tar.gz tar -xzf sqlite-autoconf-3240000.tar.gz cd sqlite-...
1
vote
1answer
397 views

Installing Spatialite on Centos7: select mod_extension() doesn't work

I'm trying to install Spatialite on a CentOS 7 server. Sqlite (version 3.7.17 ...), works fine. Using the command yum list | grep spatial the result is the follow So I've installed Spatialite ...
0
votes
0answers
76 views

Clip raster with shapefile won't work without reprojection (Linux)

So as the title suggests, I am trying to clip an image (UTM) using the OSM land polygon shapefile (WGS 84). I use gdal_rasterize to do that and when I do it on a windows machine it works flawlessly ...
1
vote
1answer
50 views

Import Shapefile to GDB. OGR2OGR FGDB Driver bug(?) on CentOS 7

I used ogr2ogr to convert shapefiles to fgdb feature classes. I have like 10 of shapefiles so I imported the folder (input as a folder directory) and converted to FGDB This is the code I used ogr2ogr ...
1
vote
1answer
2k views

How to resolve postgis.control location error on centos 7

Yum installed postgrepsql 10 and postgis 2.0 on a centos 7 host. Got this error while creating the postgis extension on a DB: could not open extension control file "/usr/pgsql-10/share/extension/...
-1
votes
1answer
265 views

OSM - Nominatim - ERROR: Scripts must be run from build directory

i'm trying to setup my own nominatim server in a CentOS 7 VirtualMachine. I'm using this guide which is followed here for data import. This line gives me trouble when trying to import data: ./utils/...
5
votes
3answers
13k views

How to install GDAL on CentOS 7.4?

I'm trying to install GDAL 2.x on my CentOS 7.4 server. I looked at what is available, and it is still at v 1.11 of GDAL Since I need GDAL v 2.x along with libKML support, looks like I'll have to ...
2
votes
1answer
802 views

How to specify a password with shp2pgsql using CentOS?

I'm developing a python script that uses shp2sql via subprocess.call(). The string I'm using works fine on Linux Mint: shp2pgsql -s 4326 ../data/download.shp ccd_hoods_new | psql -h hostname -d ...
0
votes
1answer
967 views

apache httpd mod_tile error: “Failed to create shared memory segment on file”

This question may seem out of place, but it appears it's coming from mod_tile, so thought I'd give it a shot here.. (I also haven't managed to get answers elsewhere..) Started getting this error once ...
13
votes
2answers
10k views

How to install GDAL 2.x on CentOS 7 without building from source?

I'm trying to install GDAL 2.X on CentOS7 without building from source because I'll need configure it in another servers and installing by source code will be a very tiring and time-consuming task. I ...
3
votes
0answers
347 views

'ST_Subdivide' function (3.5.0+ required) GEOS

Im running a query with ST_SubDivide() and receiving the error bellow. ERROR: The GEOS version this PostGIS binary was compiled against (34) doesn't support 'ST_Subdivide' function (3.5.0+ required) ...
4
votes
1answer
1k views

Unable to install Python 3.4 gdal bindings on CentOS

I can easily install GDAL and Python bindings on a Windows machine, but I can not reproduce the same thing on a CentOS machine. The problem is I want to use Python 3.4 (Python 2.7 is too old and ...
3
votes
0answers
365 views

shp2pgsql-gui in PostgreSQL9.6 on Cent OS 7

Using Enterprise DB one click installer available at this link for Linux based systems, I have recently installed PostgreSQL 9.6 on my Cent OS 7 (x64) based machine by: su ./binary_file_name Both ...
0
votes
2answers
7k views

Yum install postgis on CentOS 7

I have been struggling to install PostGIS on my Redhat Linux based CentOS 7 (x64) machine and so far I am still running into problems. I used this step by step tutorial developed by Regina at ...
2
votes
1answer
181 views

Disappearing tiles depending on the zoom

I'm working on a CentOS 6.8 tiles server hosted in a VM and I observed some disappearing tiles depending on my zoom level in QGIS 2.16, I don't know where it comes from... Here are some pictures of ...
3
votes
1answer
205 views

How to add Tiles made from an OSM PostGIS Database to QGIS

Following this tutorial I was able to configure a tile server correctly using a PostGreSQL/PostGIS database, osm_tiles, renderd/mapnik and osm2pgsql in CentOS 6. The goal of this is to be able to ...
3
votes
2answers
1k views

Link between tile server and QGIS

I just installed a tiles server in a VM following this tutorial, everything seems to work. I can see the image exemple on http://localhost/osm_tiles/0/0/0.png like it's supposed to be... Now, I would ...
1
vote
2answers
2k views

installing GDAL on cent os7 setup.py egg_info failed

I saw this post here: Installing GDAL on CentOS? And got the EPEL 7 installed, then did a sudo yum install gdal and it did its thing without errors. However when trying to do a sudo pip install ...
1
vote
0answers
110 views

centos 6.7 ArcGIS for Server 10.3.1: publishingtools will not start?

We're experimenting with ArcGIS for Server (10.3.1) on CentOS (6.7) and I've run into a wall; specifically this: Service failed to start System.PublishingTools.GPServer: LOCALHOST Could ...
0
votes
1answer
127 views

installing grass71 on centos6

I am installing grass71 on centos6 , i have the following message after running grass71 [bachir@nexus ~]$ grass71 Starting GRASS GIS... g.gisenv: /lib64/libc.so.6: version `GLIBC_2.14' not found (...
2
votes
2answers
370 views

Geoserver and tomcat8 conflict of port numbers on cent os

I have installed geoserver binary and tomcat8 in /opt on centos 6.6. My problem is, I can run geoserver only when I stop the tomcat service. How do I resolve the issue and start both on booting the ...
2
votes
1answer
245 views

GRASS plugin for QGIS 2.10 missing [duplicate]

I have installed installed QGIS 2.10 from source on CentOS 6.6 however the issue I'm facing is that I am missing the GRASS plugin form the GUI. I have checked the plugin manager, its not listed there....
1
vote
1answer
193 views

Geoserver layer pyramids in googledrive

is it possible to create pyramid from large rasters and add them with folders to google drive and mount google drive as local drive to geoserver ? i tried to search in internet to find about it and ...
2
votes
1answer
2k views

QGIS Server not working on CentOS 7

I installed QGIS Server via yumex on my CentOS 7.1 System and I have an Apache 2.4.6 Server running. My Problem is, I can't show a QGIS project in my Chrome browser. Of cause, I read many ...
4
votes
1answer
1k views

Failed to create memory layers in QGIS application on Linux

I have written a python class which reads properties of map layers from an XML file and creates appropriate memory layers. I have developed and tested this code with QGIS 2.8.2 on a Windows 7 machine (...
1
vote
0answers
243 views

Settings for GeoServer: large WMS png request failing

We recently upgraded from GeoServer 2.1 to the 2.5-SNAPSHOT, both from official OsGeo Centos packages, git revision, c7886eb21885c88d40029432c3178f88931ed820 We are getting the dreaded: Rendering ...
7
votes
1answer
18k views

Installing GDAL on CentOS?

I'm having issues with installing GDAL on a fresh install of Centos7 using the ELGIS repo. Here's my commands and output: sudo rpm -Uvh http://elgis.argeo.org/repos/6/elgis-release-6-6_0.noarch.rpm ...
1
vote
0answers
247 views

CentOS 6.5 - After compiling gdal.so: Unable to load dynamic library

CentOS release 6.5 (Final) Linux version 2.6.18-028stab101.1 (root@rhel5-build-x64) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-46) I'm trying to Install Cartaro CMS (http://cartaro.org/). GeoServer, ...
4
votes
2answers
6k views

Installing QGIS on Centos 7?

I tried by following the instructions described here but they don't work. It looks like the repository mentioned in those instructions is actually not working: http://fedora.vitu.ch/QGIS/7/x86_64/...
1
vote
0answers
553 views

How to build QGIS on CentOS?

I'm trying to install QGIS, without success. I install all dependencies, but the compilation still sucks. My compilation log : [root@localhost build]# cmake .. -- QGIS version: 2.4.0 Chugiak (20400) ...
1
vote
1answer
996 views

Problem installing gdal - works in build directory, not in /usr/bin

I've been trying to install gdal with the FileGDB driver. I installed it fine on a linux mint machine. I am having problems installing on a CentOS machine though. It builds fine, I can run the apps in ...
1
vote
1answer
464 views

How to install wps geoserver extension to Centos6.5

I installed OpenGeo Suit on CentOS 6.5 and the version of geoserver is 2.5-SNAPSHOT. I made a yum update and the version of OpenGeo Suit is 4.1, geoserver version remain 2.5-SNAPSHOT. I would ...
4
votes
3answers
2k views

Installing gdal in CentOS without Root?

I have been struggling to get python setup to do some image processing, so I really need the http://www.gdal.org/ GDAL libraries installed on CentOS 6.5. I want to install the package in a local ...
0
votes
2answers
575 views

CartoDB: Import Error: host and port must be set

I have setup cartodb in one of the server (CentOS). Everything worked fine in development environment, but when I move to production environment I couldn't import any file. Getting the below error in ...
2
votes
1answer
632 views

Geoserver configuration for large layers

I'm having problem with geoserver configuration. Currently I'm running geoserver 2.4 on CentOS and Tomcat 6 with 24 cores CPU and 48 GB RAM. I have uploaded 4 layers to PostGIS (PostgreSQL 9.3/PostGIS ...
1
vote
2answers
5k views

Yum Install QGIS on CentOS 6

I was trying to install QGIS on centos 6.3 and follow the instruction here. However after running yum install qgis qgis-python qgis-grass qgis-mapserver I got below errors: ---> Package ...
0
votes
1answer
177 views

Install plugins for qgis in centos

I followed the instructions here: How to install QGIS on Centos 6? If I run: QgsVectorLayer * vpoly = new QgsVectorLayer("Polygon", "pointbuffer", "memory"); QgsVectorDataProvider * provider = ...
50
votes
12answers
108k views

Running Create Extension postgis gives ERROR could not open extension control file?

I have installed PostgreSQL 9.x and PostGIS 1.5/2.0 several times and have never had this problem. I just got a new CentOS 6.3 server up and running and and I have Postgres 9.3 functioning as ...
3
votes
1answer
2k views

How to debug QGIS Server WMS “Download of capabilities failed”?

Currently I am using a QGIS server with a Linux CentOS system. I am attempting the create a WMS in QGIS and upload it to my website. I have followed the instructions in the "Quantum GIS User Guide: ...
0
votes
0answers
334 views

Compilation of QGIS master branch under CentOS 6.3

I tried to compile QGIS master branch 1.9 (qgis-Quantum-GIS-b99ff61) under CentOS for many hours now as explained here and here / here Compilation: [ 7%] Generating ui_qgsmapserverexportbase.py ...
1
vote
0answers
155 views

How do I link an existing install of GDAL to FileGDB in Linux?

The distribution I use (CentOS) only has GDAL 1.8 available through elgis. I've downloaded the FileGDB API from ESRI and I'd like to be able to link it after an install. How can I do this?
1
vote
2answers
2k views

PROJ4 Library error in combination with MapServer 6 and CentOS 6

I have recently compiled MapServer 6.2 on a CentOS 6.3 machine. Since I compiled it --with-proj=/usr, all the PROJ4 related stuff resides in /usr/share/proj. I've also installed proj4 with yum ...
2
votes
1answer
5k views

What packages are needed on CentOS to compile MapServer from source

I'm trying to configure MapServer 6.2.0 for compilation on CentOS 6.3, but always run into the same problem, no matter what configure options I supply (also the same with no options at all, just plain ...
3
votes
2answers
618 views

How to install pgrouting from source on CentOS 6.3?

I'm running into a problem once I try [cmake_dir]/bin/cmake . I get these errors: Boost headers were found here: /usr/include Output directory for libraries is set to sh: /usr/bin/postgres/...