Skip to main content

Questions tagged [compile]

for questions relating to compiling GIS software and geospatial libraries.

Filter by
Sorted by
Tagged with
0 votes
0 answers
17 views

Maven error compiling GeoServer custom WPS [duplicate]

I'm attempting to build a custom GeoServer WPS plugin using Maven but I'm encountering issues during compilation. I've updated my POM file and added all the required dependencies, including GeoServer ...
Niko's user avatar
  • 1
0 votes
1 answer
30 views

Errors building GRASS

I am trying to build grass-8.3.0 on a Debian Linux system. The configuration portion has only one flag: --without-pdal because Debian 12 does not have that package. The compilation finishes with: ...
user3063547's user avatar
1 vote
0 answers
21 views

Connect different point layers to one layer

I have different projects, which all have a point layer. I would like to compile the data of these point layers into one layer automatically. So that everytime when I add information to the point ...
lesto's user avatar
  • 327
1 vote
1 answer
329 views

MapServer 8 How to compile with MVT support

I have compiled MapServer 8.0.0 and works well, except it will not generate an MVT tile, instead, it returns this message loadOutputFormat(): General error message. OUTPUTFORMAT (mvt) clause ...
Matt's user avatar
  • 53
0 votes
0 answers
179 views

Configuring mapserv with Oracle on Ubuntu 22.04

I am new for mapserv over Ubuntu 22.04. I had use ms4w and there are lots of things I don't know how to configure and use. And the first thing is compiling with Oracle I had Oracle Client installed ok,...
Silvia Gatti's user avatar
1 vote
0 answers
349 views

How to build shared library from spatialite as static library NDK

I want to build a shared library for android to link with JNI, all libraries on which it depends are static libraries. I used this to build spatialite and sqlite for android : https://github.com/...
VaK's user avatar
  • 11
1 vote
1 answer
197 views

When compiling PostGIS from source, how does PostGIS determine which components to install?

I am trying to compile the latest PostGIS 3.2.1 from source. The compilation/installation below was successful on Ubuntu 20.04 LTS (resulting in a usable PostGIS): ./autogen.sh ; ./configure ; make; ...
tinlyx's user avatar
  • 11.1k
9 votes
1 answer
2k views

Compiling resources.qrc with QGIS 3.20 (could not find qt5_env.bat)

To compile resources.qrc file with pyrcc5 we usually do qt5_env.bat py3_env.bat pyrcc5 -o pathtoplugin\resources.py pathtoplugin\resources.qrc using OSGeo4W Shell as described in many questions on ...
MrXsquared's user avatar
  • 34.9k
0 votes
1 answer
315 views

PostGIS compilation issue with PostgreSQL 14

I am trying to compile PostGIS 3.1.1 from source under the newly released PostgreSQL 14 beta1. I downloaded the latest PostGIS source and then compiled it under Ubuntu 20.04 LTS as follows: tar xf ...
tinlyx's user avatar
  • 11.1k
1 vote
0 answers
68 views

"Could NOT find Python" error when compiling QGIS source code

I tried to complile QGIS source code according to the method from QGIS's INSTALL.md on my windows computer and did't know why CMake couldn't find the proper Python version although I had added related ...
shchyan's user avatar
  • 113
2 votes
3 answers
1k views

Error compiling PostGIS 3.1 from source : "undefined reference to `GEOSIntersectionPrec'"

I am just trying to build the new PostGIS 3.1.0 (with GEOS 3.9.0). But I consistently get an error about "undefined reference to `GEOSIntersectionPrec'". The commands I used was (which was ...
tinlyx's user avatar
  • 11.1k
0 votes
1 answer
96 views

Compiling on CentOS fails due to ignored LIB flag

I need help with installing PostGIS. In general: I try to install it on a cluster (CentOS) and do not have admin rights. There is a sqlite3 installation (connected to the error), but this seems ...
jan's user avatar
  • 1
2 votes
1 answer
2k views

Building GDAL for iOS

I am interested in building GDAL for iOS. I have managed to build successfully for macOS by building from sources with: ./configure --with-python=python3 --with-proj=/usr/local/Cellar/proj/7.0.1 --...
atineoSE's user avatar
  • 123
8 votes
1 answer
1k views

Debugging QGIS from Visual Studio

I try setup a QGIS debug environment under Windows10 64bit. I followed the instrictions given at https://github.com/qgis/QGIS/blob/master/INSTALL#L423 I also had a look at https://www.shaeffer.co/...
Thomas B's user avatar
  • 8,876
15 votes
5 answers
25k views

Build gdal with proj version 6

Description of the issue: Building GDAL from sources after having build proj in its latest version is failing at the configure step because it's not finding proj 6. Details to reproduce: Work ...
swiss_knight's user avatar
  • 10.5k
0 votes
2 answers
1k views

Seeking pre-compiled QGIS to run from USB stick? [duplicate]

Is there a place I can find pre-compiled QGIS? I want to run it from my USB stick, without installation.
Adnan Makda's user avatar
3 votes
1 answer
2k views

How to compile/install php-mapscript with PHP7

So, this PR opens up mapscript support for PHP7. Since there is no ducomentation I gave it a try based on How compile/install php-mapscript on Ubuntu 16.04 (although I'm doing it in Debian 9 if that's ...
Sickboy's user avatar
  • 167
0 votes
1 answer
453 views

Enabling C++ standards when compiling GEOS using cmake/ccmake?

I read from RFC # 7 of GEOS that the old autoconf based build system may be removed in the future, in favor of using cmake. I sometimes need to customize geos and add functions that uses the newest C+...
tinlyx's user avatar
  • 11.1k
2 votes
1 answer
1k views

Compiling QGIS 3.x (master) on Ubuntu 16.04 with Python3.6 and the latest Qt 5 and PyQt5 familiy modules (PyQt5, sip, qscintilla, pyqtchart)

The problem: Now that the compilation issue is over (Unable to compile QGIS 3.x (master) on Ubuntu 16.04: PyQt5.pyqtconfig module does not exist), QGIS 3 (master) refuses to load Python at startup. I ...
swiss_knight's user avatar
  • 10.5k
3 votes
1 answer
3k views

Unable to compile QGIS 3.x (master) on Ubuntu 16.04: PyQt5.pyqtconfig module does not exist

From: http://pyqt.sourceforge.net/Docs/PyQt5/pyqt4_differences.html there seems to be no more pyqtconfig module in PyQt5: pyqtconfig Module PyQt4’s pyqtconfig module is not supported. The ...
swiss_knight's user avatar
  • 10.5k
1 vote
2 answers
639 views

Couldn't load PyQGIS...on Windows custom build

I have built QGIS 3.2.0 with the release code downloaded from GitHub, using CMake and Visual Studio 2017. Basically I followed the instructions in INSTALL file. When I run QGIS.exe, it shows: Couldn'...
Winfred Huang's user avatar
1 vote
1 answer
725 views

Missing pyrcc compiling QGIS item

I created a plugin using the QGIS Plugin Builder with QGIS 3.2 and tried to compile it afterwards with the OSGeo4W Shell. In the Shell I navigated to the directory my plugin is installed (C:\Users\...
gHupf's user avatar
  • 1,165
2 votes
0 answers
263 views

Problem using cmake QGIS 3.0 [closed]

I'm trying to compile QGIS 3.0 on Windows. I want to port it to Windows RT (Windows on Arm) I keep getting this error: Looking for gaiaStatisticsInvalidate in C:/OSGeo4W/lib/spatialite_i.lib Looking ...
Qiangong2's user avatar
  • 121
2 votes
0 answers
51 views

Building QGIS 3 undeclared identifiers and classes on macOS

Has anyone had any luck building QGIS 3 on macOS? I keep getting unkonwn type name errors when running it: /Users/user/Downloads/QGIS-master/src/core/qgspointlocator.cpp:62:39: error: unknown class ...
Micks Ketches's user avatar
10 votes
3 answers
39k views

How to install GDAL on CentOS 7.4?

I'm trying to install GDAL 2.x on my CentOS 7.4 server. I looked at what is available, and it is still at v 1.11 of GDAL Since I need GDAL v 2.x along with libKML support, looks like I'll have to ...
Devdatta Tengshe's user avatar
1 vote
0 answers
426 views

Building QGIS >= 2.18.12 on Linux Mint 18.2 Sonya - with Oracle provider

I need to use QGIS desktop, on a Linux box, to work with Oracle spatial. The past 2-3 QGIS versions (at least) for Windows came out of the box with Oracle support - unfortunately, this is not the case ...
GregStef's user avatar
  • 214
0 votes
0 answers
424 views

Error while compiling gdal 1.9.2 in Ubuntu16.04

I am trying to compile and build gdal 1.9.2 in Ubuntu 16.04.3. I am doing the below steps sudo wget http://download.osgeo.org/gdal/gdal192.zip unzip gdal192.zip -d gdal cd gdal cd gdal-1.9.2/ sudo ./...
User123's user avatar
  • 2,986
1 vote
1 answer
8k views

How to install shp2pgsql and raster2pgsql from source?

I just installed PostGIS 2.4.0alpha from source by following osgeo instructions on Ubuntu 16.04. After installation, PostGIS seems to work. However, command line tools that are supposed to come with ...
tinlyx's user avatar
  • 11.1k
1 vote
1 answer
301 views

Building QGIS master on Windows 7

I'm trying to build a debug version of QGIS on windows env for this I'm using the bat file package-nightly, I followed all steps presents in INSTALL file but without success. When I executed the bat ...
rbarbalho's user avatar
  • 131
2 votes
0 answers
500 views

How to compile GDAL with external libraries? (Rasterlite2)

I want to compile GDAL with Rasterlite2 Support, but I can't find any info on how to do this. I already downloaded librasterlite2, libspatialite and libsqlite3. When configuring with --with-...
DoktorMerlin's user avatar
2 votes
0 answers
171 views

Import error when compiling QGIS 2.18.3

I am getting the following error while compiling QGIS 2.18.3 in visual studio 2010. Apparently all is well when I compile QGIS 2.14. Is there something am missing? 277> Building Custom Rule D:/...
gath's user avatar
  • 121
1 vote
1 answer
191 views

Installing MCC-LIDAR on Mac

I'm trying to install mcc-lidar on Mac but get into problems when compiling. [ 3%] Building CXX object CMakeFiles/mcc-lidar.dir/LasDataFormat.cpp.o /Users/Oskar/Documents/mcclidar-code/src/...
oskarlin's user avatar
  • 1,941
3 votes
4 answers
4k views

How compile/install php-mapscript on Ubuntu 16.04

I need to upgrade from Ubuntu 14.04 to 16.04 but php5 is not officially supported on Ubuntu 16. I install php5.5 by ondrej repo https://askubuntu.com/a/756186/483814 but when I try to install php5-...
MSS's user avatar
  • 262
1 vote
2 answers
849 views

QGIS bat file for 64 bit build

I am trying to build QGIS on a 64 bit machine with Windows 7 SP1. My bat file is as follows: @echo off set VS90COMNTOOLS=%Program Files (x86)%\Microsoft Visual Studio 10.0\Common7\Tools\ call "%...
Nihcas's user avatar
  • 103
2 votes
1 answer
816 views

Compile QGIS / Can't find Qt Cryptographic Architecture

I'm trying to compile QGIS-master 2.12 for the first time following the INSTALL guide (https://github.com/qgis/QGIS/blob/master/INSTALL). I'm stucked while compiling with the "CMake Error at cmake/...
jbp's user avatar
  • 51
2 votes
1 answer
372 views

QGIS Plugin 'make' error on Windows

Creating QGIS plugin via PluginBuilder and compiling resources via simple 'make' works straightforward under Linux (SuSe 13.2). Under Windows 'make' (3.81) produces an error: C:\Users\Jochen\.qgis2\...
Jochen Schwarze's user avatar
1 vote
1 answer
2k views

undefined reference to `TIFFDefaultStripSize@LIBTIFF_4.0'

I am trying for the first time to use gdal in Ubuntu 15.10 with gcc. I call gdal.h in my program. At first I got the error "undefined reference to `GDALOpen'", so I check online and I found that I ...
Ilaria's user avatar
  • 83
1 vote
1 answer
231 views

Building QGIS 2.8.6 on Win 7 32bit?

I'm trying to build QGIS 2.8.6 on Windows 7 32 bit using MSVC Express 10. The build process completes without errors, but with a bunch of warnings. When I run the qgis.exe after installation, it only ...
redfrex's user avatar
  • 21
0 votes
2 answers
1k views

How to compile or find PHP MapScript (MapServer) latest version for Windows?

I had major performance difficulties with MapServer version 6.0.3 (MS4W 3.0.6) and need latest version of MapScript but I can't find it for Windows. Anybody can help me to find latest compiled (...
MSS's user avatar
  • 262
2 votes
0 answers
681 views

How to edit the GUI of a QGIS plugin not made with the plugin builder?

I edited a python plugin's code and had to change the UI a bit as well. However, unlike in the plugins I made from scratch with the plugin builder, the UI doesn't automatically update in QGIS when I ...
MapEngine's user avatar
  • 995
5 votes
1 answer
4k views

How to control QGIS from within Anaconda's Spyder (Continuum Analytics Python distribution) in Windows

I would like to control QGIS from within Anaconda's Spyder, in particular use the QGIS core modules. My config: Windows 7 Anaconda 64x for Python 2.7 Spyder 2.3 Postgresql 9.4 PostGIS 2.1 QGIS 2.8 (...
bendalf's user avatar
  • 61
3 votes
1 answer
1k views

Compiling custom plugins for QGIS on Windows

I've made my first plugin using plugin builder and I want to compile it. I read that I need two commands to do it under windows: pyuic4 and pyrcc4. But when I use any of these commands I get this: D:\...
Krzysztof Żuraw's user avatar
1 vote
0 answers
197 views

Compiling QGIS for Slackware (Slak 14)?

I use a Slak 14 box and tried to install QGIS on it. the compile process goes on for 30 minutes or so (dual Xeon 3.2 ghz) and then I get the errors below. Says the compiler doesn't work. Have had no ...
George Csahanin's user avatar
2 votes
4 answers
3k views

Can't compile python plugin in QGIS (Windows)

I'm just installed QGIS 2.2 and created a new plugin from Plugin Builder. When I try to compile the plugin using: C:\Program Files\QGIS Valmiera\bin>pyuic4 -o C:\Program Files\QGIS Valmiera\bin\ ...
mbonad's user avatar
  • 71
1 vote
1 answer
588 views

PostGIS 2.1.1 compilation issue

I tried to compile postgis-2.1.1 in RedHat 6.3 with: # ./configure --with-pgconfig=/usr/local/pgsql/bin/pg_config --with-gdalconfig=/usr/local/bin/gdal-config --with-geosconfig=/usr/local/bin/geos-...
alceste's user avatar
  • 11
2 votes
1 answer
947 views

Building GDAL with ECW SDK on Windows

I'm using Visual Studio 2010 to open and build the GDAL 1.10 source (using the "makegdal10.sln"). This builds without an issue. Now I want to include the ECW support by including the ECW v5.0 SDK (...
Will S's user avatar
  • 41
2 votes
1 answer
562 views

Installing QGIS 2.0 with the newest gdal and geos libraries

I want to install QGIS 2.0 on Ubuntu 12.04 LTS. I followed these steps until the final installation command. Before I compiled gdal 1.10, geos 3.4.2 and grass 6.4.3 on my own. In the synaptic ...
Stefan's user avatar
  • 4,434
1 vote
0 answers
531 views

Trying to build GDAL's ECW plugin in 64 bit Linux

I'm trying to build the GDAL's ECW plugin in Linux. I'm using the latest version of the SDK from Intergraph's site (5.0). It fails because it tries to compile against the 32 bit version of the ...
HeyOverThere's user avatar
  • 7,871
1 vote
1 answer
361 views

Getting fatal error LNK1104 qgis build

I try to build qgis1.8.0 using Microsoft Visual c++ 2010 in a Windows 7 64bit. all the dependency are installed and the solution qgis1.8.0.sln was generated succesfully. but my problem is the ...
fkili mohamed's user avatar
1 vote
0 answers
646 views

Does qgis_mapserv.fcgi segfault because ECW data is used?

I've compiled qgis from source, and when I call qgis_mapserv.fcgi in my browser with REQUEST=GetProjectSettings (and my map file set via map=) is returns the XML correctly. But if I then try to ...
Stef's user avatar
  • 43