Questions tagged [conda]

With conda, you can create, export, list, remove, and update environments that have different versions of Python and/or packages installed in them.

Filter by
Sorted by
Tagged with
0
votes
1answer
60 views

Trouble importing Fiona in Python

I am trying to use the Fiona module in Python, but am having trouble getting it to work. After issuing conda install fiona, the installation using conda seems fine, but when I issue import fiona, I ...
0
votes
0answers
56 views

Using conda and ArcPy with ArcMap

Is there a way to use ArcPy without having ArcGIS Pro? I am currently using ArcMap 10.8 and am trying to set up a conda environment that is compatible. However, I'm having trouble finding the esri ...
1
vote
0answers
35 views

Using QGIS in a Conda environment

I have installed QGIS in a Conda virtual environment called qgis_stable. When I open Python in the terminal and try to run: import gqis.core I get the error message: ImportError: libGL.so.1: cannot ...
2
votes
1answer
34 views

Activating a conda environment from within QGIS — cannot be done due to inherited environmental variables?

Background I've been working on a small QGIS Python plugin. Part of the functionality requires a number of packages that have complex dependencies. In my regular Python use, I use conda to manage it. ...
0
votes
1answer
47 views

Can't install Packages with Cloned ArcGIS Pro Python

I have a new installation of ArcGIS Pro 2.6 on a Windows 10 computer. I have successfully cloned Python because I want to install third-party packages to this cloned environment and still use arcpy. ...
0
votes
1answer
72 views

ArcPy import arcgiscripting

I created a new environment in Conda and installed Python 3.6.9 along with certain modules including ArcPy in that new environment. Now, when the script in Spyder tries to import arcpy, I get the ...
0
votes
0answers
24 views

Open Data Cube: Unable to connect to database within opendatacube Conda environment [duplicate]

I followed the steps listed at https://cubes.readthedocs.io/en/v1.0.1/install.html and did the following: Installed Python Installed PostgreSQL ssudo sh -c 'echo "deb http://apt.postgresql.org/...
1
vote
0answers
48 views

Unable to connect to database within Conda Data Cube environment [closed]

I followed the steps listed at https://cubes.readthedocs.io/en/v1.0.1/install.html and did the following: Installed Python Installed PostgreSQL ssudo sh -c 'echo "deb http://apt.postgresql.org/...
1
vote
0answers
34 views

Using gdal_proximity inside conda environment

I want to batch gdal_proximity using python. The following command is working inside OSGeo4W Shell: C:\python ./gdal_proximity.py -srcband 1 -distunits PIXEL -values 1 -ot Float32 -of GTiff "[...
0
votes
0answers
98 views

Why doesn't installing GDAL from `pip` work on Ubuntu 18.04x64

Does anyone know why the pip install of gdal never seems to work? I am asking out of genuine curiosity and don't intend to sound negative. I have a related downstream packaging issue with GDAL as a ...
1
vote
0answers
47 views

What's the role Qwidget and Qlayout in the QGIS interface?

I use miniconda3 to manage my software installations, including QGIS, so I can use packages like geopandas easily in the QGIS python console. Lately however, when I open qgis from the command line ...
3
votes
2answers
265 views

Installing Fiona into cloned conda environment in ArcGIS Pro gives ImportError

I am trying to install Fiona into a cloned conda environment in ArcGIS Pro. I have cloned the default environment and tried to install it both through ArcGIS and through the conda prompt (through ...
2
votes
0answers
948 views

Problems installing rasterio from conda

I'm trying to install the rasterio python package using the conda package manager. But when I try to do this in a new clean conda environment, I get an "Found conflicts!" error with no information on ...
0
votes
1answer
148 views

ipyleaflet with GEE in JupyterLab doesn't show layer

I'm trying to run the interactive map example for GEE community - Python API on JupyterLab (https://github.com/gee-community/ee-jupyter-contrib/blob/master/examples/getting-started/display-interactive-...
0
votes
0answers
186 views

earthpy.spatial stack() -function and data type

I have Landsat-8 OLI images in directories named after image WRS-2 scenes. I tried to compose script that would iterate these directories and stack rasters within each directory - using earthpy python ...
1
vote
0answers
31 views

GDAL python package with Anaconda and ElasticSearch 7 [closed]

I'm trying to import feature data into elasticsearch v7.4 using GDAL to convert from an ArcGIS feature service layer into geoJSON for indexing. We use anaconda 3 (latest version 2019.10) for our ...
3
votes
1answer
138 views

Creating a subclass that inherits from an ArcPy superclass?

I would like to create a subclass that inherits methods from the arcpy Describe class, as in: import arcpy class my_sublass(arcpy.Describe): pass However, arcpy.Describe is a function (that ...
1
vote
2answers
266 views

`pyproj` initialization error in PyCharm but not in cmd?

I am currently struggling to get pyproj to initialize when running in PyCharm. Oddly enough, I am able to get it to work in cmd. The version of pyproj I am using is 1.9.6, and the version of proj4 I ...
7
votes
5answers
14k views

Ogr2ogr: ERROR 1: PROJ: pj_obj_create: Cannot find proj.db

I start using GDAL 3.0.0 using conda build. I successfully installed GDAL on my laptop (Windows 10) and I am trying to ingest MapInfo tab file into Elasticsearch index. I understood that I have to ...
1
vote
1answer
716 views

GDAL installation on MAC OSX via conda fails, linked due to Libpoppler and font configuration

When installing GDAL via Conda, install fails, on OSX Mojave and Python 3.7: dlopen(/Users/tomkom/anaconda3/lib/python3.7/site-packages/osgeo/_gdal.cpython-37m-darwin.so, 2): Library not loaded: @...
6
votes
3answers
4k views

Access QGIS API from Anaconda python environment using Conda-Forge

I am trying to use QGIS in stand-alone python scripts (windows 10, python 3.6.6). After the following steps... 1) create new conda environment (geospatial) 2) install the qgis conda-forge package ...
1
vote
1answer
572 views

Error while installing QGIS with conda

I'm trying to install QGIS through conda $conda install -c conda-forge qgis but got the following error Solving environment: failed UnsatisfiableError: The following specifications were found to be ...
0
votes
1answer
175 views

import ARCSI as module in python

Any way to work with ARCSI (Atmospheric and Radiometric Correction of Satellite Imagery) like any other python package? Can it be imported in a jupyter notebook? >>>import arcsi or is ...
3
votes
0answers
226 views

QGIS 3.0.3 (and 3.2.0) crashes on start. Ubuntu 16.04, conda environment

I am trying to QGIS in a conda environment, python 3.6.5, conda 4.5.8, Ubuntu 16.04 Xenial. It crashes upon start-up without even loading all the way. I have tried both QGIS 3.0.3 and 3.2.0 (3.2.0 is ...
5
votes
0answers
1k views

Getting Spyder IDE to work with QGIS?

I was hoping someone could help me get Spyder working with QGIS. I am finding the python editor limiting within QGIS as I would like to debug my code, use the variable explorer, and be able to run ...
0
votes
1answer
317 views

Conda Forge or Conda Channel for GDAL on python2.7 and python3.x [closed]

I have two conda environments: One based on python 2.7 and the other based on python 3.5. I want to create a codebase (frequently used functions) that works with both Python versions. There is one ...
0
votes
2answers
558 views

ArcPy importing error after setting path?

This questions has been asked before too and I did go through most of the suggestions. Things I have tried so far: setting up correct path variable environment, installing anaconda 32 bits, python 2....
4
votes
1answer
992 views

GDAL conda install on Mac OS trouble

I'm trying to install gdal on my new computer in the anaconda environment using conda but having issues. All I've done so far is install Anaconda for python 3.6 and install gdal as described here + a ...
2
votes
0answers
424 views

How do I import the qgis module installed by QGIS into other Python Environments?

I have a QGIS install and a Miniconda install. I want to use the qgis module installed by QGIS in my other python installation, but I get this error: >>> import qgis Traceback (most recent ...