Questions tagged [conda]

With conda, you can create, export, list, remove, and update environments that have different versions of Python and/or packages installed in them.

Filter by
Sorted by
Tagged with
0
votes
1answer
14 views

`pyproj` initialization error in PyCharm but not in cmd?

I am currently struggling to get pyproj to initialize when running in PyCharm. Oddly enough, I am able to get it to work in cmd. The version of pyproj I am using is 1.9.6, and the version of proj4 I ...
0
votes
2answers
272 views

GDAL installation on MAC OSX via conda fails, linked due to Libpoppler and font configuration

When installing GDAL via Conda, install fails, on OSX Mojave and Python 3.7: dlopen(/Users/tomkom/anaconda3/lib/python3.7/site-packages/osgeo/_gdal.cpython-37m-darwin.so, 2): Library not loaded: @...
0
votes
0answers
112 views

MacOS error when installing GDAL in conda: pyopenssl and setuptools dependency

I was trying to install GDAL on MacOS Mojave 10.14.3 using these following methods: conda install -c conda-forge gdal conda install -c conda-forge/label/gcc7 gdal conda install -c conda-forge/label/...
2
votes
1answer
924 views

Access QGIS API from Anaconda python environment using Conda-Forge

I am trying to use QGIS in stand-alone python scripts (windows 10, python 3.6.6). After the following steps... 1) create new conda environment (geospatial) 2) install the qgis conda-forge package ...
1
vote
1answer
382 views

Error while installing QGIS with conda

I'm trying to install QGIS through conda $conda install -c conda-forge qgis but got the following error Solving environment: failed UnsatisfiableError: The following specifications were found to be ...
0
votes
1answer
95 views

import ARCSI as module in python

Any way to work with ARCSI (Atmospheric and Radiometric Correction of Satellite Imagery) like any other python package? Can it be imported in a jupyter notebook? >>>import arcsi or is ...
3
votes
0answers
198 views

QGIS 3.0.3 (and 3.2.0) crashes on start. Ubuntu 16.04, conda environment

I am trying to QGIS in a conda environment, python 3.6.5, conda 4.5.8, Ubuntu 16.04 Xenial. It crashes upon start-up without even loading all the way. I have tried both QGIS 3.0.3 and 3.2.0 (3.2.0 is ...
3
votes
0answers
503 views

Getting Spyder IDE to work with QGIS?

I was hoping someone could help me get Spyder working with QGIS. I am finding the python editor limiting within QGIS as I would like to debug my code, use the variable explorer, and be able to run ...
0
votes
1answer
260 views

Conda Forge or Conda Channel for GDAL on python2.7 and python3.x [closed]

I have two conda environments: One based on python 2.7 and the other based on python 3.5. I want to create a codebase (frequently used functions) that works with both Python versions. There is one ...
0
votes
2answers
367 views

ArcPy importing error after setting path?

This questions has been asked before too and I did go through most of the suggestions. Things I have tried so far: setting up correct path variable environment, installing anaconda 32 bits, python 2....
2
votes
1answer
651 views

GDAL conda install on Mac OS trouble

I'm trying to install gdal on my new computer in the anaconda environment using conda but having issues. All I've done so far is install Anaconda for python 3.6 and install gdal as described here + a ...
2
votes
0answers
388 views

How do I import the qgis module installed by QGIS into other Python Environments?

I have a QGIS install and a Miniconda install. I want to use the qgis module installed by QGIS in my other python installation, but I get this error: >>> import qgis Traceback (most recent ...