Questions tagged [debian]

A GNU/Linux operating system built for many computing architectures (AMD64, i686, ARM, etc.). Debian is the basis for the Ubuntu and Elementary Linux distributions.

0
votes
1answer
83 views

Raspbian QGIS 3.x Install

I'm trying to install QGIS 3.x on Raspbian Stretch with Desktop - I successfully installed QGIS 2.x using the QGIS sources as described in their install instructions. I found this build-from-source ...
1
vote
0answers
159 views

Cache lookup failed for function 1 while activating PostGIS

I'm using PostgreSQL 10.5 on a remote server (Debian). I created a database inside then I attempted to enable PostGIS but it wasn't successful. I had this error : cache lookup failed for function 1
0
votes
0answers
97 views

Problem with repo qgis.org/debian “does not have a Release file”

When I include deb https://qgis.org/debian/ buster main deb-src https:://qgis.org/debian/ buster main in my /etc/apt/sources.list file, and run sudo apt uptdate I get: E: The repository 'https://...
0
votes
0answers
18 views

Is it possible to upgrade gdal-bin 1.10 to 2.x.x in debian Jessie?

I tried backports-jessie, I tried using the debian-gis repository but unsuccessfully. Does someone succeed in such task avoiding compiling sources?
3
votes
1answer
400 views

How to compile/install php-mapscript with PHP7

So, this PR opens up mapscript support for PHP7. Since there is no ducomentation I gave it a try based on How compile/install php-mapscript on Ubuntu 16.04 (although I'm doing it in Debian 9 if that's ...
0
votes
1answer
169 views

QGIS server 3 failed on debian 9

I have install on a Debian 9 a qgis-server, python-qgis, apache2 and libapache2-mod-fcgid. Apache service is runnning. I have a folder uder usr/lib/cgi-bin/ but when I request http://localhost//cgi-...
1
vote
0answers
122 views

QGIS (2.18.x) crashes after changing symbology / style of vector files

All of a sudden, I face the issue of QGIS (2.18.15, and 2.14.21 as well) crashing when: - activating layers in the map view from previously saved files. - changing the styles / symbology of vector ...
1
vote
0answers
65 views

QgsComposerItem error when runnning on Debian instead of windows

I have the following script which has worked on Ubuntu 16.04 and Windows but not on Debian. from PyQt4.QtCore import * from PyQt4.QtGui import * from PyQt4.QtSql import * from PyQt4.QtXml import ...
2
votes
1answer
100 views

FCC Database in PostGIS, display in ArcMap

I used a modified version of the scripts at: https://bitbucket.org/dirkcgrunwald/fcc-uls to pull the FCC databases down and put them into a PostGIS environment. I created a view so I didn't have to ...
5
votes
1answer
3k views

QGIS installation fails under Ubuntu 16.04

I decided yesterday to upgrate QGIS from 2.16 to 2.18. This turned out to be a stupid idea, because the following happened: After removing, purging and autoremoving qgis, python-gis and grass I ...
5
votes
0answers
1k views

QGIS depends on gdal-abi-2.1.1 not installable [closed]

I tried to install QGIS on debian sid but it depends on gdal-abi-2-1-1 that should be contained in libgdal20. But libgdal20 is already on gdal-abi-2-1-2. Is there a solution for this? Installing gdal-...
7
votes
3answers
4k views

Cannot install QGIS 2.18 from repository on Debian Stretch; package “gdal-abi-2-1-1” not installable

I've been using QGIS from the repository (http://qgis.org/debian/ stretch main). I tried to do an update today (it had been a while) but it could not be updated because qgis : Depends: gdal-abi-2-1-1 ...
3
votes
2answers
765 views

How to force QGIS to use GDAL version?

I'm using QGIS LTR 2.14.7 running on debian. 2 versions of GDAL are installed on my computer (1.10 and 2.0). 1.10 is out of box GDAL version (doesn't support ECW). 2.0 is compiled (by me) to support ...
1
vote
0answers
315 views

QGIS Server dosen't answer a GetCapabilities request on Debian 8.3

Following the server install steps from Q-website and others mentioned, after I install qgis-server & libapache2-mod-fcgid (and mod enabled), QGIS Server should answer a GetCapabilities request: ...
1
vote
1answer
88 views

Cannot install qgis-mapserver, on Deb8.3,' Dependencies issue'

I am trying to install qgis-mapserver. I started at Qgis org Installers website - Latest Release 2.12.x Lyon, with a fresh Debian 8.3 jessie install. The repos's are as instructed, which gives me: ...
3
votes
1answer
4k views

How to install the latest PostGIS in Ubuntu

I am wondering how can I install the latest PostGIS 2.2 (testing) from the Debian GIS project here: https://launchpad.net/ubuntu/+source/postgis/2.2.0+dfsg-3 I tried apt-get install -s postgis after ...
2
votes
1answer
629 views

How to install OSM .pbf support in GDAL on Debian?

I'm trying to use Anita Graser's post on loading OSM data from .PBF files into a SQLite .db file using ogr2ogr but it stopped working. I'm trying to run the following command: ogr2ogr -f "SQLite" -...
1
vote
1answer
354 views

Unable to start modules in QGIS GRASS plugin (GNU/Linux Debian)

Recently, the Toolbox of QGIS GRASS plugin can't find modules in my GNU/Linux Debian. When I click on any module, the toolbox reports the message: Cannot find module x.xxx and, after, I have the ...
3
votes
2answers
353 views

Asking QGIS to provide upgrade for particular distro?

I effortlessly installed QGIS 2.4 and upgraded to 2.6, for my Linux Mint 16, because I just had to put http://qgis.org/debian in my repositories list and note that my distro was saucy. 2.8 has been ...
1
vote
0answers
1k views

PostGIS extension on Debian not found: could not open extension control file

I'm trying to set up the PostGIS extensions on a Postgres 9.1 database on Debian Wheezy, but getting an error: =# create extension postgis; ERROR: could not open extension control file "/usr/share/...
3
votes
3answers
1k views

SAGA installation in QGIS 2.8 on debian linux

I install QGIS 2.8 in debian (linux) through nightly jessie (qgis testing) and I see that SAGA is not in processing toolbox, so I install saga gis software but still it doesn't appear in processing. ...
1
vote
0answers
763 views

Upgrading qgis in debian jessie (linux)? [closed]

I want to upgrade qgis 2.6 to qgis 2.8 in linux (debian jessie). I did: sudo apt-get update sudo aptitude full-upgrade And I get this error: Até aqui tudo bem... Processing triggers for hicolor-...
1
vote
1answer
197 views

Seeking LAG LiDAR Analysis GUI installation guide?

Does anyone know how do I install LAG lidar Analysis Gui? LAG by arsf This is my situation: I'm using debian 8 test. I installed this library: boost (yes) * GTKmm (yes) * GTKGLextmm (yes) * GThread (...
2
votes
3answers
7k views

Postgis installation

I am installing Postgis on my Debian server, following these instructions: http://postgis.net/install/ (Ubuntu / Debian) https://wiki.postgresql.org/wiki/Apt However, after following the ...
0
votes
1answer
370 views

How to use shapefile in QGIS on Debian?

I am extremely new to GIS and I just received a shapefile, as a zip file that includes the following files: filename.SHX filename.SHP filename.prj filename.dbf filename.cpg but I am not sure how I ...