Skip to main content

Questions tagged [debugging]

A methodical process of finding and reducing the number of bugs, or defects, in a computer program or a piece of electronic hardware, thereby making it more reliable

Filter by
Sorted by
Tagged with
0 votes
0 answers
3 views

Could not load file or assembly ArcGIS.Desktop.Core.XmlSerializers

I've upgraded ArcGIS Pro from 3.2 to 3.3. To adjust the AddIn I develop, I've upgraded it from .NET 6 to 8, and I made all necessary updates. Now, while running it, before ArcGIS Pro opens, I get the ...
Pavel V.'s user avatar
  • 1,517
0 votes
0 answers
26 views

Model designer crashes when applying layer styles

I have a problem with the designer model. I'm looking to automate the application of layer styles via the model designer. I have several layers over several years using the same style that I saved. So ...
CARA Guillaume's user avatar
0 votes
0 answers
27 views

Pydev Remote Debug Breakpoints with QGIS Stops in _string_ instead of the python file

I tried to use the remote debugger with PyDev but when I reach the breakpoint, I end up in a file name "string" that seems to be internal commands: To set up the remote debuger, I followed ...
Biorix's user avatar
  • 31
0 votes
1 answer
59 views

QGIS incorrectly says a raster's max value is 0

This raster, 25.5mb uncompressed, 4.4kb compressed as 7z, has a min & max value both of 0: However R says it has a max of 1: And if I remove all the 0 values, there are 25 remaining values: ...
dez93_2000's user avatar
  • 1,079
5 votes
1 answer
98 views

Print entire object in PyQGIS without being cut off with ellipsis

I am working in QGIS Python console (the editor to be more specific) and want to print an entire object using PyQGIS for debugging purposes. In my case it is a QgsGeometry, but I assume its the same ...
MrXsquared's user avatar
  • 34.9k
2 votes
1 answer
382 views

NNJoin plugin crash

I'm trying to run NNjoin plugin to compute nearest distance between my plot and buildings (urban) but I'm having this error : Here are my files (maybe not projected yet but it should be in ESPG 23839) ...
Germain Vital's user avatar
0 votes
0 answers
16 views

QGIS Crashreport is not generating since I updated to 3.22.16

I'm creating plugins for QGIS and one of my biggest problems is to debug a QGIS crash. When we worked with QGIS 3.10 the stack was saved to "C:\Users\User\AppData\Local\QGIS\QGIS3\crashes" ...
Tim_Tries_PY's user avatar
0 votes
0 answers
14 views

Displayed entities toggle at each zoom level on OpenLayers map [duplicate]

I have a PostGIS table connected to my GeoServer in which I have published a layer of 80 multipolygon features. The multipolygons have very different sizes and are displayed correctly in the ...
GisUser's user avatar
  • 649
0 votes
0 answers
147 views

How to preview PBF query results in the browser debugger?

Working with ArcGIS Maps SDK for JavaScript, I want a quick preview (in the browser debugger) of the results of a query. For example, when clicking on a polygon in the PopupTemplate sample, the ...
Stephen Lead's user avatar
  • 21.2k
2 votes
0 answers
178 views

Mininum cluster size in QGIS ST-DBSCAN sometimes not applied correctly

I have 7 point vector layers which I am clustering as a batch in QGIS using the standard ST-DBSCAN tool. On one instance, I formed two groups based on different minimum cluster sizes: 7 or 10. The ...
Barbara Perez de Araújo's user avatar
1 vote
1 answer
66 views

QGIS 3 incorrect rounding with QgsCoordinateFormatter.format()

I use QGIS 3.30.1 to format geographic coordinates. At some precision values, the formatting result is not what I expected (it is wrong!). Before writing a bug report, I would like to get a ...
Comrade Che's user avatar
  • 7,261
0 votes
0 answers
72 views

Error exporting CSV file to drive from GEE

I am working on a project where I cross-classify several regions with each other. In other words: I train several classifiers on imagery from different regions and classify all images of all regions ...
pottsbill's user avatar
0 votes
0 answers
33 views

Not getting any runtime errors from QGIS Plugin

I am working on developing QGIS plugin, but I don't get any errors (beside initial, for example when I try to import non existing class). My colleague gets window with error and message in Log Panel, ...
Kubson's user avatar
  • 614
0 votes
1 answer
477 views

PyQGIS QgsMessageLog "NameError: name 'Qgis' is not defined"

I'm trying to debug a pyQGIS plugin, but can't get one of the Qthread working. I was told QgsMessageLog was the best way; QgsMessageLog.logMessage("before simplify", "plugin", ...
S.E.'s user avatar
  • 336
1 vote
0 answers
56 views

"no data" result from raster calculator

Am trying to implement the following line in QGIS raster calculator: ("L@1" < 0) * ((1 - 16 * 200 / "L@1")^0.25) + ("L@1" >= 0) * 1 Basically, when L is less than ...
Apeny's user avatar
  • 11
1 vote
0 answers
160 views

Deleting features in one layer causes changes to another in QGIS

I had two identical layers in a map (one original and one copy). I noticed two features in the attribute table of the copy layer not related to any polygons on the map, which I deleted. This caused 3 ...
Lindsay's user avatar
  • 41
2 votes
0 answers
145 views

Debugging QGIS plugin using pdb

I typically use pdb for debugging. However, when I follow the docs for debugging with pdb, I get the error: input(): lost sys.stdin I'm developing my plugin straight out of the load directory: %...
Lorem Ipsum's user avatar
0 votes
1 answer
603 views

Unable to apply symbology in ArcPy script tool

I am having a strange issue that I can't seem to figure out. I am writing a simple script that will automate a map production workflow. In part of the script, I import a new feature class as a layer, ...
Eli Simonson's user avatar
2 votes
2 answers
2k views

Backed up shapefile is no longer a "valid or recognized data source"

I'm working on a project regarding the coastline of Tampa Bay and over a long period I've edited a 2004 snapshot of the coastline from a line shapefile into a polygon shapefile representing the ...
qu4ntumrush's user avatar
1 vote
0 answers
43 views

Vertex marker in Edit Vertices not appearing on half screen

I'm using ArcMap on ArcGIS Desktop 10.5 and when I enter the Edit Vertices context, the vertex markers on the left side of the screen are hidden. You can click on them, but the marker does not appear. ...
stanleykubrick's user avatar
8 votes
1 answer
1k views

Debugging QGIS from Visual Studio

I try setup a QGIS debug environment under Windows10 64bit. I followed the instrictions given at https://github.com/qgis/QGIS/blob/master/INSTALL#L423 I also had a look at https://www.shaeffer.co/...
Thomas B's user avatar
  • 8,876
0 votes
2 answers
970 views

ArcPy script causes Python crash when run outside of ArcGIS Python window

I have a Python script that will successfully complete when run from the Python window in ArcMap or ArcCatalog, however, when I run as a standalone it will cause python.exe stopped working crash once ...
ampm's user avatar
  • 1
1 vote
2 answers
4k views

QGIS 3.8 could not start ''Qgis_app.dll is missing'' check runtime environment check C:\OSGEO4W64\bin\qgis-dev-bin-g.exe

I had Qgis 3.4 running well on my PC Windows 10, 64 bit. I tried to upgrade to Qgis 3.8 Zanzibar and I had the error message: ''Qgis_app.dll is missing check runtime environment check C:\OSGEO4W64\bin\...
Mel's user avatar
  • 17
3 votes
2 answers
3k views

Debug QGIS3 plugin with Visual Studio Code

I would like debug QGIS plugin using Visual Studio Code. I have Win10 and QGIS 3.4.4. I followed the instructions written in these two sites: How to setup QGIS 3 and Visual Studio Code plugin ...
PaolaB's user avatar
  • 287
1 vote
1 answer
92 views

Measure loading time of layers in Mapserver

I use mapserver to generate one single tile per request. The mapfile contains several layers and I would like to know which of them is the bottleneck that needs too much time to render. WIth shp2img I ...
Thomas B's user avatar
  • 8,876
1 vote
1 answer
270 views

Number converted to dictionary in Earth Engine

When reducing an image to number on it's geographical coordinates, the code does return a number, which is what should happen. var accum = ETo.reduce(ee.Reducer.sum()); var accumNum = accum....
Dante's user avatar
  • 13
3 votes
1 answer
366 views

Update QGIS Canvas while debugging

I am upgrading some QGIS 2 plugins to QGIS 3 and need to do some debugging. It appears that the canvas does not update until the code stops running, regardless of any calls to self.iface.mapCanvas()....
CNIDog's user avatar
  • 479
1 vote
2 answers
51 views

ArcPy error handling within a C# wrapper

I'm running arcPy commands from a C# script i.e. RunPythonScript("arcpy.Delete_management(\"C:\\\\Temp\\\\NW\\\\land.gdb\", \"Table\")"); private static void RunPythonScript(string script) { ...
Silverfin's user avatar
  • 165
0 votes
1 answer
306 views

How to call GEOS error handlers provided during initialization (initGEOS)?

From what I learned, when using GEOS in C/C++, it should be initialized first using initGEOS : extern void GEOS_DLL initGEOS(GEOSMessageHandler notice_function, GEOSMessageHandler ...
tinlyx's user avatar
  • 11.1k
2 votes
1 answer
641 views

ERDAS Imagine signature picker colour changing RGB numbers?

I've noticed something with the signature picker in ERDAS and I was wondering if it is a bug or a feature. When I create classes I assign a colour to make them easily readable in the classified ...
Dakan_GIS's user avatar
2 votes
0 answers
98 views

QGIS expressions don't evaluate as expected

I am using QGIS with a vector layer and the attribute table stored at this link: https://docs.google.com/spreadsheets/d/1K7rRdlcSheclJ6MqzpBNwSZei911WDV1Bl2zBGV38-s/edit?usp=sharing I then have the ...
evank28's user avatar
  • 21
2 votes
0 answers
140 views

qgis: can't find eclipse pydev path using remote debugger in linux enviroment

I'm trying to configure pydev and eclipse with qgis for remote debug. Everything worked fine in eclipse and i can start the debug server. The problem is that Remote debugger plugin requires a pydev ...
Marcelo Fonseca's user avatar
15 votes
3 answers
6k views

Easy way to see the requests QGIS makes to a remote server?

I'm attempting to debug an issue with a remote ArcGis Server's WMTS as seen from GeoServer. I can see the requests GeoTools is making (because they throw an error and get logged). However the service ...
Ian Turton's user avatar
  • 82.2k
3 votes
0 answers
501 views

Autocompletion for VS and Eclipse when debugging QGIS plugins

I have been trying to get autocompletion to work in first Eclipse and afterwards tried with Visual Studio. I have been following these guidelines / Stack Questions IDE settings for writing and ...
William's user avatar
  • 249
5 votes
1 answer
148 views

Labels displaying with multiple bounding rectangles

While setting up labeling of a line (road) layer, the labels started displaying with multiple bounding rectangles along with the text. After trying many different labeling configurations without ...
ZanStrausz's user avatar
1 vote
1 answer
301 views

Building QGIS master on Windows 7

I'm trying to build a debug version of QGIS on windows env for this I'm using the bat file package-nightly, I followed all steps presents in INSTALL file but without success. When I executed the bat ...
rbarbalho's user avatar
  • 131
5 votes
2 answers
3k views

Enable LOG Messages in QGIS

How to enable log message in QGIS? debug mode or verbose mode. I put variable in my env but without success. More informations to complete this question: I would like to see messages of detail the ...
rbarbalho's user avatar
  • 131
2 votes
1 answer
363 views

Add custom base-map in Carto.com

PROBLEM: The functionality 'Insert your WMS/WMTS URL' in the 'Add a custom base-map' menu does not work and cannot be debugged properly. BACKGROUND: Following the instructions at CARTODB MAKES IT ...
Dimitris's user avatar
  • 183
2 votes
2 answers
150 views

Issue reporting in QGIS

I've had an issue with the Processing plugin over that last few days. QGIS has been really slow to start (about 15 minutes in some cases) and I then get a message that says "Plugin Processing: the ...
Johanna's user avatar
  • 1,225
1 vote
1 answer
2k views

How to trace SQL queries sent by geo Server to Oracle database?

When I open GML view of WFS layer in geoserver, it throws this exception: "java.io.IOExceptionORA-00918: column ambiguously defined" I am unable to trace SQL queries sent by geo Server to Oracle ...
gcu mscs016's user avatar
6 votes
2 answers
531 views

Investigating PostGIS functions to see what they are doing?

Let's say you have a function like ST_Distance and I want to know how it works. The docs don't say much at all, how do I go about debugging this or figuring out how it ticks.
Evan Carroll's user avatar
  • 7,091
1 vote
0 answers
344 views

Where I can find QGIS debug libraries?

I use QGIS 2.12 in my standalone application. Now I want to upgrade my application to the lastest QGIS version (2.16). I use OSGeo4W installer to download all headers, libs and other files. I have ...
Egor Krylov's user avatar
0 votes
2 answers
230 views

Python code execution error in QGIS WIEN

I have tried to make several different actions in QGIS but keep getting similar error messages when I try to select the output filename. The error message reads as follows: An error has occurred ...
Archie Fisher's user avatar
3 votes
0 answers
109 views

QGIS crashes when selecting symbols

I am using QGIS version 2.14.1 (Essen). I can open it no problem and load shapefiles correctly. However, when I go in the file properties and select "style"/ "unique symbols", the system crashes and ...
philippe's user avatar
  • 475
1 vote
1 answer
985 views

How to debug settings page of custom widgets?

I'm developing a setting page for my widget. To debug it, I consulted the guide again and found this advice: During development, use http://your host/webappbuilder/?appid=stemapp to directly ...
Pavel V.'s user avatar
  • 1,517
3 votes
0 answers
382 views

QGIS 2.14 Processing plugin crashes - TypeError: must be string, not None

I've recently installed 2.14, and it worked fine for the first couple of days (Appart from Grass tools), including several program and computer reboots. Today I had this error show up Couldn't load ...
HDunn's user avatar
  • 8,666
1 vote
1 answer
2k views

Syntax error at or near "1" -- PostGIS in Action -- Chapter 11 SQL data dump

I'm following along with PostGIS in Action, 2nd ed., chapter 11, while attempting the SQL dump from the data files and I'm getting the following error: ERROR: syntax error at or near "1" LINE 189: 1 ...
PDX's user avatar
  • 307
8 votes
6 answers
2k views

Unable to debug Esri Addin for ArcCatalog

It was a toss of a coin whether this question is a GIS.SE or StackOverflow question... I'm going with GIS.SE because the problem seems to lie with ArcCatalog. I have several addins that have been ...
Michael Stimson's user avatar
2 votes
0 answers
408 views

When debugging ArcGIS add-in, can't use "Edit and Continue"

I've been working on this add-in for years, and just today set up a new computer with VS 2013 and ArcGIS 10.3. When I run my add-in from the debugger, breakpoints can be hit, but I can't edit when ...
kev_gis's user avatar
  • 39
2 votes
1 answer
2k views

Trouble shooting freezing/stalling issues in QGIS

I've been using QGIS for more than a year now (currently using 2.8.2 on MacOS 10.10.3, but also in Windows XP via VirtualBox for troubleshooting) and the application has been freezing and stalling ...
Jeremy Kidwell's user avatar