Questions tagged [error-000464]

000464: Cannot get exclusive schema lock. Either being edited or in use by another application, is an ESRI software code.

Filter by
Sorted by
Tagged with
0 votes
0 answers

How to Fix ArcGIS Pro error Cannot get exclusive schema lock. Either being edited or in use by another application or service

I am trying to complete an Add Join between a shapefile and a .csv table in ArcGIS Pro. I downloaded the shapefile from a government website, and I created the CSV with my own data. I want to join ...
galaxy-friday1017's user avatar
0 votes
1 answer

Cannot overwrite feature class file in gdb while occupied by ArcGIS Pro (Python script and ArcPy package)

I wrote the following piece of code that loops over a map features and buffer them. new buffer layers are saved to a different gdb with in this project. If I run the code from IDLE while that project ...
Barak Garty's user avatar
0 votes
1 answer

ERROR 000464 when trying to update domains

I have a python script which runs nightly to update a few domains in an Enterprise Geodatabase (Oracle). I'm using the arcpy.TableToDomain_management tool. The script works fine unless there are ...
Fezter's user avatar
  • 21.8k
1 vote
1 answer

Schema Lock ERROR 000464 when ArcMap is open

I am having an issue with schema locks while working on feature classes within a file geodatabase in ArcMap. There have been similar posts to mine (Avoiding exclusive schema lock error with ArcPy?). ...
NW_Photo_Laureate's user avatar
0 votes
0 answers

Negotiating ArcPy schema locks in script

How do I avoid the 000464 (Cannot get exclusive schema lock) error in this code caused by the last line? import arcpy import os geodatabase = 'C:/Data/testgdb.gdb' fc_name = 'test_feature_class' ...
auslander's user avatar
  • 1,455
1 vote
1 answer

ArcGIS Pro removes layer from project if data source is deleted

I have a script that deletes a feature class and then recreates it. I've noticed that in ArcGIS Pro 2.0, as soon as a feature class is deleted, if there are any map layers that have that feature ...
spaine's user avatar
  • 490
2 votes
0 answers

Adding Spatial Index for Geometric Network?

I am trying to create Spatial Indexes on all the feature classes in one of my databases. It has worked fine on most feature classes so far, but when I started on feature classes in a feature dataset ...
Midavalo's user avatar
  • 29.6k
1 vote
1 answer

arcpy.SpatialJoin_analysis() not overwriting existing featureclass, not returning all features

I'm calling a python script from a custom very high level macro language script. Within the python script there is an arcpy.SpatialJoin_analysis() command. For some reason if the output from this ...
geoJshaun's user avatar
  • 1,525
1 vote
1 answer

Add Field giving ERROR 000464: Cannot get exclusive schema lock

I'm doing an interface using ArcMap 10.2 and Python scripts that run at Python window. For each time that my script run, I need to update information, so I think that I need to delete originals tables ...
S.Rai's user avatar
  • 309
1 vote
1 answer

Deleting ArcGIS Project created using ArcGIS Pro?

I have deleted a few ArcGIS Projects, created using ArcGIS Pro, by using Windows Explorer to delete the folder that contains them. However, I thought that, as long as the project (not the current ...
PolyGeo's user avatar
  • 65k
6 votes
1 answer

Debugging ERROR 000464: Cannot get exclusive schema lock?

I am trying to run the "Near" tool in Arcmap. Both my layers involved are on a SDE database. When I run the tool I get the following error... ERROR 000464: Cannot get exclusive schema lock. ...
Tristan Forward's user avatar
3 votes
1 answer

Splitting street in Address table which participates in Relationship Class (1-M)?

I have a table "Addresses" and the Feature "streets". The feature "Streets" are lines. I need to do a relation with this table with this feature. What I do? I tried built a "relationship class". The ...
ChristianAbreu's user avatar
11 votes
4 answers

Avoiding exclusive schema lock error with ArcPy?

I have a script for updating some features on my database every night (just for copying and replacing some features). This features are "read-only". My problem is that I can't avoid that these ...
avrechi's user avatar
  • 165
3 votes
1 answer

Geocoding failure on concurrent requests with arcgis-10.0

I've created a small python synchronous geoprocessing script (ctagc) that runs on AGS. The script accepts a table (GPRecordSet) as an input parameter. The script then calls arcpy....
awesomo's user avatar
  • 3,421
1 vote
1 answer

Opening ArcCatalog to FGDB causes application to fall over

I have some python scripts I have written to create a lot of objects. I write these, in code, to a couple of FGDB's. If I happen to open ArcCatalog in one of these FGDB's, the application falls over,...
Hairy's user avatar
  • 4,823