Questions tagged [getfeatureinfo]

A WMS (Web Map Service) request that retrieves data, for a pixel location on a map.

Filter by
Sorted by
Tagged with
0 votes
0 answers
35 views

Get multiple features from WMS

I am trying to retrieve more than one feature from a WMS service. I had success on some by using a combination of feature_count and setting the width and height to 1 with a x/y value of 0. But on some,...
user avatar
1 vote
1 answer
20 views

Change layer popup style of KML served by GeoServer WMS service?

I need to change the style of the popup page in the KML (network) file sent by the WMS server. I looked at the GeoServer documents for this, but I couldn't find a .ftl file on my Linux server. There ...
user avatar
0 votes
1 answer
26 views

GetFeatureInfo in OpenLayers only if the layer is visible

I'm using the following code in Open Layers 6, and it shows the feature info, even if the layer is not visible map.on('singleclick', function(evt){ document.getElementById('info').innerHTML = '...
user avatar
  • 2,271
2 votes
2 answers
36 views

Expose only selective features/attributes of a shapefile while publishing on GeoServer as WMS

I am trying to use WMS GetFeatureInfo request to popup display the feature/attributes of multiple WMS layers in OpenLayers. The problem is there too many attributes in each layer. Is these any ...
user avatar
  • 41
3 votes
1 answer
51 views

How to define propertynames for GetFeatureInfo

We make a GetFeatureInfo call to a GeoServer and expect a geojson return. Is it possible to define human-readable property names? something like: baujahr -> Baujahr or eigentuemer_organisationstyp -...
user avatar
0 votes
1 answer
57 views

GetFeatureInfo request from GeoServer responds with empty array

I am using the vue-leaflet and axios plugin in vue.js to make a GetFeatureInfo request to WMS tile layers served by Geoserver/Geowebcache for a certain point on the map, defined as marker. I am ...
user avatar
  • 21
2 votes
1 answer
74 views

Failed to run GetFeatureInfo: precision cannot be greater than 7 or less than -7

I have an environment consisting in Geoserver 2.20 + Postgresql 14 + Postgis 3.1.4, in which I'm trying to run the following GetFeatureInfo request on a database containing geographic information: ...
user avatar
  • 23
1 vote
1 answer
32 views

GeoServer - GetFeatureInfo GeoJSON - different precision in different workspaces

I've just set up my GeoServer and app to work with application/json GetFeatureInfo requests. One of the advantages of this is that it returns the feature in GeoJSON format along with the attributes. ...
user avatar
2 votes
1 answer
65 views

GetMap Request WMS

I formulate a GetFeatureInfo request that returns the feature information of the centre point of the map. The GetFeatureInfo request for WMS is: http://geoservices-inspire.irisnet.be/geoserver/...
user avatar
  • 69
0 votes
2 answers
146 views

Get info for all features upon click with betterWms Leaflet plugin?

var layer = L.tileLayer.betterWms("http://localhost:8080/geoserver/wms", { layers: 'data', format: 'image/png', transparent: true, }).addTo(map); When adding this GROUP WMS ...
user avatar
2 votes
1 answer
45 views

GeoServer 2.20.1 doesn't respect multiple styles with query layers

I'm having a minor issue with GetFeatureInfo and I quite frankly don't know how to solve it. It's a bit of a long story but here goes: When I make the following request to our GeoServer it'll return ...
user avatar
0 votes
1 answer
51 views

GeoServer GetFeatureInfo request property ordering

I am attempting to transition from text/HTML to application/JSON info_format in my GetFeatureInfo requests. The issue I'm running into is that when I use a GetFeatureInfo request with a PostgreSQL ...
user avatar
0 votes
0 answers
61 views

HTTP 404 on a GetFeatureInfo request on a GeoServer WMS

I am trying to make a WMS GetFeatureInfo request to GeoServer for an OpenLayers map. This is done with a proxy. Everything seems to be going fine but the place where the information should show up ...
user avatar
1 vote
0 answers
79 views

MapServer Template

I have a wms mapfile to publish routing data line. Some of the lines have the same position and lie on top of each other, but have different values. I filter the objects with the attribute "...
user avatar
1 vote
2 answers
112 views

GeoServer GetFeatureInfo Results Format - Without Geometries

In GeoServer, is there a way to only retrieve the attributes/properties of features, without geometries, using the GetFeatureInfo request? I need to use the GetFeatureInfo request to retrieve features'...
user avatar
1 vote
1 answer
127 views

How do I set the root-layer of a MapServer WMS to queryable="0"?

Problem Problem Summary I want the response of all the MapServer WMS GetCapabilities requests to not show queryable="1" in the root layers XML node. Status Quo The GetCapabilities response ...
user avatar
  • 149
3 votes
2 answers
92 views

Prevent WMS GetFeatureInfo returning geometry in MapServer 6.4

When I send a GetFeatureInfo request to my Mapserver 6.4 WMS, the response contains the geometry. I want to disable this, as it is far too large in size. However, I am serving the same data as a WFS ...
user avatar
  • 5,562
1 vote
1 answer
146 views

PyQGIS WMS GetFeatureInfo

How does QGIS do the GetFeatureInfo Requests when I select a raster layer (WMS Layer) and use the Identify tool on the map? And how do I implement this in my PyQGIS Plugin, so I can send ...
user avatar
0 votes
0 answers
29 views

GetFeatureInfo WMS in viewer

I have a problem: when I load certain WMS services in the Viewer, and click on the map for the identify, I don't see results as if the data had no information in the clicked point. But in reality the ...
user avatar
  • 11
1 vote
1 answer
143 views

Struggling to return GetFeatureInfo over QGIS Server and MapServer WMS layers [duplicate]

I have a HTML/Leaflet page utilising BetterWMS script (https://gist.github.com/rclark/6908938). The script returns GetFeatureInfo over WMS layers. Unfortunately it is not working with WMSs published ...
user avatar
  • 41
0 votes
0 answers
24 views

How to properly style and format the box that pops when you click a point on map?

I am new with Geonode and in general with GIS systems. I have a layer loaded on GeoServer and imported on Geonode that contains a point on the map. When I click on the point a box pops-up that ...
user avatar
  • 11
2 votes
1 answer
132 views

BetterWMS script doesn't work with QGIS Server and MapServer WMSs

I have a HTML/Leaflet page utilising BetterWMS script below. The script returns GetFeatureInfo over WMS layer. Unfortunately it is not working with WMSs published by Qgis Server and MapServer, ...
user avatar
  • 41
1 vote
1 answer
434 views

Extract attribute data from features on a WMS source

I need to extract attribute data from all features from a WMS source. So far I've managed to get them "manually" specifying coordinates for each feature using Python and OWSlib like this: ...
user avatar
1 vote
1 answer
111 views

Fetch point data from image WMS

Based on the previous questions I asked, I got a way to fetch the clicked point information, but I want the exact value of gray_index, but as you can see the answer is text or HTML. In the image below,...
user avatar
  • 67
0 votes
0 answers
34 views

I have these variables in Leaflet map .. my difficulty is in visualizing the information using a popup in the Leaflet [duplicate]

var ProvinciasWMS = L.tileLayer.wms('http://localhost:8080/geoserver/Mocambique/wms?',{ layers:'Mocambique:Provincias_Moz', version: '1.1.0', transparent:'true', format: 'image/png', ...
user avatar
0 votes
1 answer
281 views

Show WMS information in popup on Leaflet map?

I need to view WMS information through a popup in Leaflet map. I tried with the code below, but the popup doesn't come out with information, but automatically downloads a file. map = L.map(document....
user avatar
0 votes
0 answers
162 views

WMS tile layer getfeatureinfo OpenLayers

I'm using this link to try and add the WMS GetFeatureInfo Tile Layer functionality to my OpenLayers map http://astuntechnology.github.io/osgis-ol3-leaflet/ol3/05-WMS-INFO.html My code is currently as ...
user avatar
0 votes
0 answers
43 views

GeoServer GetFeatureInfo on RGBA 70GB raster returns empty feature response

I have trouble getting feature response from GetFeatureInfo (to get raster values at a point) from GeoServer on very big raster - approx 70GB TIFF. Wierdly enough, the WMS service itself (GetMap) ...
user avatar
  • 101
0 votes
0 answers
194 views

Get feature of point shapefile for WMS created in GeoServer?

I created a WMS from a polygon shapefile in GeoServer and next I created a WMS from a point shapefile. Then I wrote HTML code that add WMS polygon and shapefile on a base map and that is done, but I ...
user avatar
3 votes
0 answers
193 views

GetFeatureInfo of a specific GeoServer layer by selecting it from a set of GeoServer layergroup

I have multiple Geoserver layers, suppose 2 here (Rainfall and Maximum Temperature) and I want to extract the feature of that layer which I check/switch in the sidebar, But for now I just get the ...
user avatar
0 votes
1 answer
136 views

Issues with GeoServer GetFeatureInfo request parameters

I managed to make GetFeatureInfo request but it has some issues still. This is code: function request(e) { var BBOX = that.mymap.getBounds().toBBoxString(); var WIDTH = 101; var HEIGHT = 101; /...
user avatar
0 votes
0 answers
242 views

GeoServer GetFeatureInfo parameters

I have a Leaflet map where on click I send GetFeatureInfo request to GeoServer, but the content of the HTML it returns is empty. I suppose I am computing parameters that I pass incorrectly, this is my ...
user avatar
  • 1
1 vote
0 answers
83 views

WMS GetFeatureInfo not working

I created a WMS in a QGIS project and serve it with QGIS Server. When I click on a feature on the WMS map, no attribute information is displayed. I guess, the attributes are not exposed to the WMS but ...
user avatar
  • 481
2 votes
2 answers
850 views

Showing WMS layer data and marker popup simultaneously in Leaflet

I need to show WMS layer information and if there are some marker or other layers at the same coordinate, it should show both data of WMS layer and marker information. But when marker covers wms layer,...
user avatar
0 votes
0 answers
108 views

GetFeatureInfo works over HTTP but not HTTPS

I have GeoServer up and running with ProxyPass allowing access over HTTPS and I have the proxy base URL set to https://maps.tellus-toolkit.com/geoserver/ Everything is working as expected apart from a ...
user avatar
1 vote
1 answer
816 views

Show all data of the WMS GeoServer layer on single click at web page using OpenLayers 6 WMS GetFeatureInfo (Tile Layer)

I have a vector layer in my GeoServer, which I want to publish on the web page. When I open this layer manually from GeoServer, it shows the attribute table of the place/polygon, while clicking on ...
user avatar
0 votes
1 answer
259 views

GetFeatureInfo is not working on multiple layer

This is my map URL: http://34.84.56.42:8080/app/ When I click on the map, I'm able not to get the information (GetFeatureInfo) of the overlay layers. I can get only GetFeatureInfo of the top layer. I ...
user avatar
0 votes
0 answers
32 views

Unable to get output for WMSGetFeatureInfo in OpenLayers

Can anyone please help me on using the WMSGetFeatureInfo in OpenLayers. I am able to add WMS Layers on top of OpenStreetMap. But while using the FeatureInfo functionality I am not getting the results. ...
user avatar
  • 1
1 vote
0 answers
98 views

Read the attributes of a WMS layer by clicking on the map

I'm trying to display a popup (containing the attribute data) by clicking on an entity in my layer with the WMSGetFeatureInfo control from OpenLayers. It's turning but without displaying the popup ...
user avatar
  • 53
1 vote
1 answer
34 views

Getinfo only returns the first cover inserted

I'm using GetInfo to view the cover information and my problem using this command is: The information displayed is not from the cover seen on the map, but from the first cover inserted in the code. I ...
user avatar
  • 11
0 votes
1 answer
421 views

Trouble with using Freemarker to formate Date for GeoServer GetFeatureInfo

I'm having some trouble while trying to use the Freemarker Template to display dates in the desired format. I store points with a date information in a PostGIS database written through an FME-process ...
user avatar
2 votes
2 answers
667 views

Get attribute table from WMS GeoServer in OpenLayers

I have WMS so I can easily display it in the map, but I want to get the attribute table of the layer from WMS. All solutions I found are about getFeatureInfo which is giving properties when clicking ...
user avatar
2 votes
0 answers
113 views

GetFeatureInfo with leaflet.extras2 and Shiny

I am building an R Shiny App that utilizes the following WMS. However, the GetFeatureInfo capabilities for click-enabled popup (leaflet.extras2 functionality) returns a summary of the GetCapabilities. ...
user avatar
  • 21
1 vote
0 answers
159 views

Using WMS getFeatureInfo() in shiny and leaflet

I like to get the getFeatureInfo by a click like it is mentioned in this post so that the information is shown in a popup window. I tried trevis solution but it is not working for me. If I use addWMS()...
user avatar
  • 11
1 vote
1 answer
845 views

QGIS Server: GetFeatureInfo over WMS layer returns empty sets

I am developing a webmap application using Leaflet + QGIS Server 3.4 on a Debian platform. I have my HTML/Leaflet page ready, based on this code. Basically, the user has the choice between several ...
user avatar
1 vote
0 answers
116 views

Using alias name instead of field name in GetFeatureInfo in GeoServer

I've created a Leaflet map and use GetFeatureInfo to send request to GeoServer. Everything is ok but I want to use Alias field name instead of field name. Indeed I want to replace real field with ...
user avatar
  • 91
1 vote
1 answer
286 views

OpenLayers getGetFeatureInfoUrl with dragBox in CQL

I tried to request Geoserver (2.16) WMS with the function getGetFeatureInfoUrl (From openlayers 6+) I tried this by passing the dragBox extent as a CQL filter. dragBox.on("boxend", () => { ...
user avatar
  • 177
0 votes
0 answers
61 views

featureInfo limited to first match after qgis2web WMS export

Here's my problem: I created a WMS using PostGIS and GeoServer and integrated it into QGis. So far everything worked fine. Then I wanted to display the WMS as a webpage and exported it using qgis2web....
user avatar
  • 316
5 votes
2 answers
1k views

How to view URL of GetFeatureInfo request in QGIS?

I have a WMS layer in QGIS. I am using the Identify Features tool to perform a GetFeatureInfo request. It retrieves the expected attribute data in the Identify Results panel. However I would like to ...
user avatar
  • 520
0 votes
0 answers
705 views

Failed to run GetFeatureInfo and rendering coverage on the fast path error in Geoserver

My layer in geoserver was working fine before 20 days. When I used my system after 20 days for a specific layer Geoserver gave an error : Failed to run GetFeatureInfo on layer [Layer Name]. The layer ...
user avatar

1
2 3 4 5
7