Questions tagged [grass-7.4]

when GRASS 7.4 is the version you are using from the GRASS platform

Filter by
Sorted by
Tagged with
1 vote
1 answer
116 views

v.out.ogr to PGDUMP using COPY

I am exporting a grass vectior dataset to a Postgis dump file using v.out.ogr (reformatted for clarity) v.out.ogr -a -n input=my_layer@mapset\ output=my_sql_file.sql format=PGDUMP It ...
vinh's user avatar
  • 355
1 vote
1 answer
476 views

Error when importing shapefile as vector layer into GRASS GIS

I'm tried to importing an Esri shapefile into GRASS GIS using both v.in.ogr and v.in.import however methods fail with the following error message: WARNING: Table <roadsSriLanka> linked to ...
Nandula's user avatar
  • 783
1 vote
0 answers
28 views

SQL Error while using v.distance through simple python editor in grass

I try to execute the following code: grass.run_command('v.distance', from='tramstop', to='iso_tram', upload='cat',column='first_tram_distance', overwrite=True) but i get the "SyntaxError: invalid ...
user136194's user avatar
3 votes
1 answer
266 views

Adding extra parameter in QGIS processing in grass to close files after processing

The code below works but as this involves averaging thousands of files, grass shows an error message: Too many open files The code: ymax=31.4648437503 ymin=17.4068080185 xmax=-80.4330407378 xmin=-...
wondim's user avatar
  • 1,383
2 votes
1 answer
1k views

Getting GRASS 7.4.4 Working in Python 3

I'm trying to get some GRASS functionality in a Python Script, specification r.series, but I'm struggling to import GRASS. I'm trying to uses the method outline on the GRASS Wiki, Working with GRASS ...
Bradley_Burrell's user avatar
0 votes
1 answer
113 views

v.net.allpairs - Missing parameter value: WHERE condition SQL statement without where keyword

v.net.allpairs is not running in QGIS 2.18.27 (but runs in QGIS 2.14). QGIS 2.18.27 has responded: Missing parameter value: WHERE condition SQL statement without where keyword. How to fix that?
Sergio's user avatar
  • 233
0 votes
0 answers
86 views

Recommended resources for viewshed generation using Grass GIS 7.4

I am working on a project where I need to create viewshed areas around towers with a radius of 5000 meters. The underlying DEM I created using free Lidar data. Uptill now I did all this on a laptop ...
EZMapdesign's user avatar
0 votes
1 answer
91 views

TypeError during compilation of extensions in GRASS GIS using g.extension

I am using GRASS 7.4.0 on Ubuntu 18.04. I installed grass-dev using sudo apt-get install grass-dev, and then used g.extension v.centerpoint to try to install v.centerpoint. The output is below: $g....
c14369's user avatar
  • 3
0 votes
1 answer
103 views

Erasing part of line vector outside raster region using GRASS?

I need to delete all the vector 'part' that it's outside the yellow raster region. How can I do it?
Alberto's user avatar
1 vote
2 answers
568 views

GRASS v.net.iso tool produces empty output - QGIS 3.2.2

I want to split a network shapefile by cost isolines. I have two layers a point layer (with 297 records) a road network layer Every time I run the GRASS v.net.iso module in QGIS 3.2.2 on the road ...
Curious Girl's user avatar
3 votes
1 answer
190 views

warning message when runing GRASS 7.4 in QGIS 3.0 for Mac 10.13.4

I'm trying to run r.reclass (GRASS 7.4) in QGIS 3.0 GIRONA in a Mac iOS HIGH SIERRA. Neverteheless, when I run the comand there is noresults at all but a warning message: WARNING: Default locale ...
Sergio Guerrero Sanchez's user avatar
2 votes
0 answers
154 views

Installed GRASS Addons not appearing under modules [windows 10, grass 7.4.0]

I have installed GRASS 7.4.0 and then use the console to install the addons, r.denoise and r.patch.smooth. However, when I want to run these tools there is nothing under the addons section in the ...
Michael Alan Cohen's user avatar
4 votes
2 answers
3k views

GRASS GIS 7.4 in Linux for command line usage - setting up environment (.bashrc file)

I need to use GGRAS GIS 7.4.0 on Linux server (Debian 8.10 Jessie) via command line (with flag --exec) and I'm still having troubles with it. Description: I compile and install GRASS GIS 7.4.0 with ...
david_p's user avatar
  • 1,783