Questions tagged [http]

HTTP is the "hypertext transfer procotol." HTTP/1.1 is defined in https://tools.ietf.org/html/rfc2616 and is the transfer protocol used by the web and by every "REST API" in the GIS software field.

Filter by
Sorted by
Tagged with
0
votes
0answers
25 views

Getting GeoNetwork HTTP 503 error [closed]

I used Geonetwork two days ago without any problems, I even created some layers, but today I'm receiving the following error : Http 503 error, service unavailable. I tried in different computers and ...
0
votes
0answers
9 views

Retrieving an Asset ID using HTTPCaller

I have been asked to create a workflow that can create an asset tag for each feature class. The company who we hold a contract for have set up Web Services that provide the asset ID, called AIMS (...
1
vote
2answers
82 views

Issue with FEMA OGC Web Feature Service returning HTTP 400 error when attempting to download GML file

I'm trying to use an OGC web feature service in some software I am involved in developing. The service is described at the bottom of this page: https://hazards.fema.gov/femaportal/wps/portal/NFHLWMS ...
0
votes
1answer
478 views

openlayers 3 and geolocation without HTTPS

I am creating an application where user can locate himself on map. the code is working fine in local development environment, but when i deploy it over server(IIS) the code won't work. here is code : ...
0
votes
1answer
98 views

ESRI web scene does not load in Story Map Journal

The web scene I'm trying to embed into my Journal will only load when I'm logged in (be it while I'm in editing mode or if viewing it from another tab). If opening the story in another web-browser or ...
3
votes
0answers
70 views

Why is OGC error “NoApplicableCode” mapped to HTTP 400?

The "OGC Web Feature Service 2.0 Interface Standard" says that the OGC Error "NoApplicableCode" should be mapped to an HTTP 400 Error with the reason phrase "Internal Server Error" [1]. This is weird, ...
2
votes
0answers
295 views

Using Web AppBuilder Developer Edition with HTTP/HTTPS?

I am using; ArcGIS for Server Standard Enterprise 10.4.1 Portal for ArcGIS 10.4.1 Also i am using Web AppBuilder Developer Edition 2.3 and deploying webapps in our server. Normally when i deploy a ...
2
votes
1answer
315 views

GeoWebCache WMTS GetTile Request with HTTP POST KVP encoding

WMTS specifies GetTile requests using HTTP POST, by simply encoding all request params in the body. Is this supported by GWC, and if so, what headers etc. do I have to set? I naively tried this: ...
2
votes
2answers
292 views

How to batch create GeoServer users?

Is it possible to create GeoServer users for a list of usernames (and associated passwords) in one batch? (similar to using the Linux newusers command to create multiple users) I've asked a related ...
1
vote
0answers
96 views

Google.maps.ImageMapType getTileUrl maximum length

I am using google.maps.ImageMapType to render a GeoServer WMS to Google Map. When a request is made, it uses GET. I am concern the WMS getMap length might exceed 4k in length due to a requirement to ...
2
votes
1answer
559 views

Upload shapefile size limit

I'm trying to upload shapefile to GeoServer with REST API. It is working with most of the shapefiles, but I have problems when I try to upload a large shapefile. The .zip file is 21.1 MB. Contains ...