Skip to main content

Questions tagged [modulenotfounderror]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
36 views

No result from algorithm r.stats in QGIS

I don't understand why algorithm r.stats doesn't give me result in the sidepanel (show result); the error is 'impossible open the file' What can I do to solve the problem? I show you: Versione di QGIS:...
Nicolo Cappelletti's user avatar
0 votes
1 answer
69 views

QGIS python plugin install : miss python qgis mock module

I work with QGIS 3.32.2-Lima on Ubuntu. I would like to install and use this useful plugin : https://plugins.qgis.org/plugins/spectral_libraries/ But it seems to be deprecated? So when I try to ...
user35117's user avatar
  • 939
1 vote
0 answers
106 views

QGIS Flatpak installation 'ModuleNotFoundError' under Linux Mint

I'm pretty new to Linux and trying to install QGIS with some extra plugins for hydrodynamic modelling. I followed the instructions regarding the flatpak installation on qgis.org. After installing the ...
TimNmn's user avatar
  • 11
0 votes
0 answers
107 views

Importing fmeobjects module into python script

I've tried doing doing what this post suggests but still get errors. This code: import sys sys.path.append(r"C:\\Program Files\\FME\\fmeobjects\\python37") sys.path.append(r"C:\\...
liso_maps's user avatar
  • 103
7 votes
1 answer
177 views

Organize all dialogs in one package QGIS 3 Plugin

To organize better the code in my QGIS 3 Plugin, I tried to put all dialogs in one package called dialogs, but when I open QGIS it says ModuleNotFoundError: No module named 'dialogs' This is the code ...
Lorenzo's user avatar
  • 1,085
6 votes
1 answer
3k views

Import qgis.core in PyCharm: "No Module Named Pyqt5.Qtcore"

I would like to work on Python script with tools from qgis in a standalone software (like Pycharm or IDLE). I am quite new with Python programming and with setting up a work environnement. In order ...
JBihin's user avatar
  • 373
11 votes
6 answers
10k views

Access QGIS API from Anaconda python environment using Conda-Forge

I am trying to use QGIS in stand-alone python scripts (windows 10, python 3.6.6). After the following steps... create new conda environment (geospatial) install the qgis conda-forge package through ...
VincentV's user avatar
  • 111
22 votes
7 answers
13k views

QGIS 3.0 can't load plugin processing, no module named 'osgeo', on Manjaro Linux

I have installed QGIS3 from the AUR package, as well as all optional dependencies: https://aur.archlinux.org/packages/qgis/ However, when launching, I receive the following error: Couldn't load ...
thi_sanna's user avatar
  • 439