Skip to main content

Questions tagged [osx]

A proprietary Unix-based operating system created by Apple Inc.

Filter by
Sorted by
Tagged with
0 votes
0 answers
108 views

QGIS cannot read local Google Drive data on OSX Ventura?

I'm running OSX Ventura and store my GIS data on Google Drive so that my whole team can share. Problem is, Ventura just apparently implemented a change to move the location of the local storage for ...
Garlynn Woodsong's user avatar
0 votes
2 answers
347 views

Download of QGIS Version 3.24 'Tisler' not available

I've tried to find the OS X installer for QGIS Version 3.24 'Tisler' but couldn't find it anywhere in the installer archive. Many other, much older versions but not 3.24 Can anybody tell me where to ...
Hannes's user avatar
  • 129
0 votes
0 answers
34 views

QGIS 3.22 LTR on OSX 12.5 installation in 2022 post KyngChaos

I'm aiming to install the most compatible QGIS version and supporting packages with my OSX 12.5 system in 2022. My last setup used the KyngChaos package 3.16, however a perusal of the website shows ...
Ricardo's user avatar
  • 21
0 votes
1 answer
127 views

QGIS from conda-forge won't open on OSX 11.6 (Big Sur)

Installing QGIS using conda and conda-forge works really well on Windows and Linux (it includes a file driver not normally included with other installs), but for some reason on my MacBook QGIS won't ...
scalt's user avatar
  • 21
2 votes
1 answer
236 views

Inability to access the personal area in QGIS Cloud

For several months I have been unable to access my area in QGIS Cloud to update the changes in the meantime made to the desktop version, also to the map in QGIS Cloud that I created at the time (which ...
villarinino's user avatar
5 votes
0 answers
874 views

GeoPDF export in QGIS requires GDAL 3, how do I get GDAL 3?

I would like to use the new GeoPDF export feature of QGIS 3.10. The changelog states that it requires GDAL 3. I have QGIS 3.10 installed on OS X from the binary installer. The export GeoPDF feature is ...
Asterisk's user avatar
1 vote
0 answers
471 views

QGIS 3.10.0 SCP SSL Errors Downloading Landsat Mac OSX 10.14 (Mojave)

Semi-Automatic Classification Plugin (SCP) throws an SSL error when trying to download or preview Landsat images. Looking for a workaround, this has been addressed for Windows users but not Mac. ...
user2059376's user avatar
2 votes
0 answers
213 views

QGIS3 - Using QML in a python plugin on OSX - missing modules

I have the following QML file I am trying to display in a python plugin import QtCharts 2.0 import QtQuick 2.0 ChartView { antialiasing: true title: "Chart Title" titleColor: "white" ...
CitizenFish's user avatar
3 votes
1 answer
10k views

Layers Panel Disappeared Completely

I see that other people have mentioned losing track of the layers panel, and people have rightly pointed out that it can be restored by View > Panels > Layers. But in my install on MacOS 10.14.3, the ...
mcgeoff's user avatar
  • 31
5 votes
2 answers
1k views

QGIS install on OSX with homebrew: "You have other linked versions!"

I have an OSX Mojave setup where I've already installed PostGIS and GDAL using Homebrew. Now I'd like to install QGIS. I'm trying: brew install qgis But... I'm getting lots of warnings of the form: ...
Richard's user avatar
  • 3,299
2 votes
1 answer
177 views

OS X PYTHONPATH for QGIS Standalone Apps?

What's the correct PYTHONPATH for OS X and QGIS 3.4? I want to make a QGIS standalone app but get the "ModuleNotFoundError: No module named 'qgis'" error. This happens after following the OS X ...
QuickerClicker's user avatar
9 votes
1 answer
2k views

Stopping never ending QGIS processes instead of forcing QGIS to quit?

being a new to using QGIS on an iMac I often start processes on a large data-set that sets the spinning wheel in to a never ending state. I often need to force quit the whole QGIS program to break ...
nwastra's user avatar
  • 115
2 votes
0 answers
205 views

Error when trying to run GRASS 7 via processing toolbox in QGIS 2.18 on Mac

I have gone through the following steps: Installed the following packages that came with QGIS 2.18: 1 GDAL Complete.pkg 2 NumPy.pkg 3 matplotlib.pkg 4 Install QGIS.pkg Installed GRASS-7.4.1 from ...
Luca Jenal's user avatar
2 votes
1 answer
449 views

QGIS does not open image on Mac

I have tried various ways of making an action open on image on my Mac but no image shows up when the point is clicked. The best I got was when I made the field with the file path a "Photo" type. If I ...
sunday_funday's user avatar
4 votes
5 answers
5k views

Combine multiple USGS topo quads into a single seamless raster?

I'm quite new to GIS (so please be patient with my incorrect terminology) but I'm teaching myself as much as I can in order to create my own map of the Boundary Waters Canoe Area in northern Minnesota....
Jerod's user avatar
  • 51
1 vote
1 answer
376 views

Error installing QGIS on Mac OS X 10.11.6 (Why do I "need Xcode.app" to "compile qt5"?)

I'm trying to install QGIS by following the instructions in from this answer (using homebrew). I get the following error: $ brew install osgeo/osgeo4mac/qgis3 ==> Installing qgis3 from osgeo/...
user3.1415927's user avatar
3 votes
2 answers
1k views

PostgreSQL is loading wrong PostGIS library

I am attempting to upgrade my version of PostgreSQL (from 9.2 to 9.6) on a Mac running 10.13.5. I used pg_dumpall to backup the 9.2 database as per the instructions in the postgres documentation ...
Russell Fulton's user avatar
0 votes
1 answer
965 views

Open FileGDB Using QGIS 3 + OSX

I'm running the latest version of QGIS 3 from here and installed via DMG. However when I attempt to import a FileGDB, I'm not seeing the previous ESRI FileGDB option and the Open FileGDB driver doesn'...
John Van Hoesen's user avatar
3 votes
2 answers
177 views

When drawing polyline using QGIS it starts on outside of cursor and not in centre?

When drawing a polyline in QGIS 3 it starts on the outside of the cursor, not in the centre. Same thing when measuring a line. This makes accuracy difficult. Am I missing something? I am using OS ...
user119209's user avatar
1 vote
0 answers
201 views

Install of QGIS3.0 on Mac OSX using KyngChaos prebuilt binaries

The installer doesn't work because it requires Python 3.6 to be installed as a framework in /Library/Frameworks (or so I believe). It is insufficient to have Python 3.6 installed by Macports (in /opt/...
Rob Stevens's user avatar
2 votes
0 answers
550 views

Pixelated low res OSM XYZ tiles on retina display

After installing the latest Qgis3 for Osx on my Macbookpro w Retina display the Qgis canvas is still pixelated and appears at a (seemingly) low resolution (when loading OSM XYZ tiles). I knew this ...
James Nuccio's user avatar
1 vote
0 answers
615 views

QGIS 3 missing vector tab mac [duplicate]

I installed QGIS 3 as instructed and the Vector processing tab is missing. I did uninstall all previous versions and Python.
Preston's user avatar
  • 11
13 votes
1 answer
18k views

GDAL scripts not found in QGIS 3 on OSX

I installed QGIS 3, and tried to execute tools like "sieve" "merge" and "polygonize". All of them gave me the error message: GDAL command output: /bin/sh: (scriptname).py: command not found I found ...
Iris 's user avatar
  • 133
2 votes
0 answers
593 views

Error clipping raster using a mask layer

I am trying to clip a raster with a polygon with QGIS 3.0 on High Sierra OSX (I've done it before with OSX Sierra and QGIS 2.8, no issues), however I keep getting an error (see inputs in screenshot ...
Felipe Arrospide's user avatar
3 votes
0 answers
49 views

Installed plugins disappear after reinstalling 2.14

I am using Kyng Chaos package QGIS 2.14 on Mac OS 10.11.6, and uninstalled/reinstalled the software recently and each time I re-open a project I lose all my user-specified preferences that I initiated ...
pkampf's user avatar
  • 31
1 vote
0 answers
245 views

Freeze adding a CSV file to QGIS?

My Mac OX 9.5 freezes or does not respond every time I try to add a CSV file. I am using the following tutorial and following every step, but my computer hates it. http://fredgibbs.net/tutorials/...
Stephanie's user avatar
1 vote
0 answers
74 views

Using print composer in QGIS?

I have been having repeated issues with QGIS 2.18 print composer for OSX High Sierra. The composer seems to continuously stop working correctly, after inserting my map frame red guide lines will ...
ferus89's user avatar
  • 329
3 votes
1 answer
813 views

How to change the GeoServer port number in the "Mac OS X installer" version

There is a version of GeoServer available at http://docs.geoserver.org/latest/en/user/installation/osx_installer.html which is very simple to install on a Mac, only requiring the application to be ...
Stephen Lead's user avatar
  • 21.2k
4 votes
1 answer
3k views

Ogr2ogr: ERROR 1: Unable to find driver `PostgreSQL'

I need to import geojson files into a local PostgreSQL9.6 database on OSX system. ogr2ogr -f 'PostgreSQL' PG:"dbname=crossmap user=duccioa" "multigraph.geojson" -nln paris.multilayer Ogr2ogr gives ...
Duccio A's user avatar
  • 437
1 vote
0 answers
90 views

Error Opening QGIS from Python (OS X)

I want to be able to access QGIS (2.14) from Python, but I am having all sorts of problems. Python keeps crashing when I try to import the library. X-MacBook-Pro:~ X$ python2 Python 2.7.13 (default, ...
jtam's user avatar
  • 357
2 votes
0 answers
204 views

Configuring PyCharm for QGIS in OS X?

Can anyone point me to instructions for setting up PyCharm (or any IDE) on OS X to run QGIS for building standalone scripts/applications? I have seen many tutorials for Windows, but nothing out ...
jtam's user avatar
  • 357
1 vote
0 answers
26 views

Font style translation problem on OSX

I have a problem with osx font translate on Qgis. For example (with a french language selected in osx system preferences) when i want to use a "bold" style, the font stay in "normal&...
emmaguille's user avatar
1 vote
2 answers
1k views

using GDAL installed using homebrew from python on OSX

I would like to work with jpeg2000 files in python but when I install GDAL using pip or conda it can't read jpeg2000s. GDAL's version is: 2.1.0 module 'osgeo.gdal' from '/Applications/anaconda/lib/...
lapsel's user avatar
  • 13
2 votes
2 answers
2k views

Set QGIS 2.18.7 on OSX - 10.12 to use GRASS 7

I read this post, I read this post. I installed Qgis 2.18.7 (package maintained by William Kyngesburye), which contains GASS 7.0.4 with disable SIP. I executed what the post says, but in the "...
Antonio's user avatar
  • 133
5 votes
0 answers
698 views

QGIS 2.18 + Mac OSX sierra crashes and slow

I've been using QGis for quite a few years on Mac OSX, never had a problem. Now with the current configuration of OSX Sierra + QGIS 2.18.1 many project files that ones were opening nice and smooth ...
Damiano Cerrone's user avatar
3 votes
1 answer
2k views

Getting QGIS to work with Python2.7 Anaconda Distribution?

I use Python 2.7 from Anaconda installed in a python environment on my computer (MacOS Sierra 10.12). QGIS is installed from the KyngChaos framework, and I know that there are problems with mixing ...
nukenine's user avatar
  • 201
3 votes
1 answer
390 views

QSpatialite broken after update to QGIS 2.18

Lately I updated from QGIS 2.14 (LTS) to 2.18 on Mac OS X. Since then, the QSpatiaLite plugin has ceased to work, yielding following error message: I have tried the following to repair the problem, ...
Cyril's user avatar
  • 83
2 votes
1 answer
502 views

QGIS crashing when opening Layer Properties in v2.14 and after upgrading to 2.18

I have a similar problem to this post I believe the issue began after I re-arranged my directory structure (which included some .shp files). Now I am unable to open any layer properties in any .qgs ...
AnthonyV's user avatar
4 votes
1 answer
1k views

Pyspatialite installation error on MacOSX (QGIS plugin)

I am using Mac OSX Sierra (10.12.1), and I reinstalled QGIS 2.14.7 (and python 2.7, after a crash and clean install of OSX). Now when I open QGIS I get an error for Pyspatialite Plugin. I found the ...
leslie roberson's user avatar
1 vote
0 answers
120 views

How to debug failing Clip/Merge/Build Virtual Raster on OSX?

I'm trying to use a number of raster functions in QGIS version 2.12.1 Lyon under OS X10.10.5 Yosemite and repeatedly get the message that "The process failed to start. Either the invoked program is ...
Dave's user avatar
  • 11
1 vote
0 answers
327 views

QGIS installation error Qt versions OSX

I am trying to install QGIS 2.14 in OSX El Capitan using brew and osgeo/osgeo4mac repository. But when I tried to install it I got the following error CMake Error at /usr/local/Cellar/cmake/3.6.1/...
Sergio Peñafiel's user avatar
2 votes
1 answer
1k views

Why does the Select by expression dialog not show field values?

I haven't found a similar question that already has an answer so I hope I can get one... Please forgive me if the answer is obvious. I'm using QGIS version 2.14.0-Essen on my macbook pro with OSX ...
Lizardie's user avatar
  • 131
7 votes
1 answer
345 views

Different results from GDAL raster attribute table command on mac and windows

I am trying to get the raster attribute table of the following file: Shift_cult_past_current_prediction_20160107_gr1DD.tif available here: https://www.dropbox.com/s/fmomfpro3j6dmz8/...
user1186's user avatar
  • 121
2 votes
0 answers
154 views

Problem with installation of QGIS 2.8 in Mac OS X 10.7

I had followed the installation process of QGIS for installing in my Mac OS X 10.7 (http://www.kyngchaos.com/software/qgis). However, I had a problem in the moment when I open the Qgis, that could ...
Aymer Andres Vasquez Ordoñez's user avatar
1 vote
0 answers
1k views

Python plugins not available, OS X 10.10.5, QGIS 2.8.4

I’m using OS X Yosemite 10.10.5 and QGIS 2.8.4 Wien. My mainproblem is that python support is disabled and I can’t use python plugins. QGIS seems to act fine and I’ve done a lot of work with QGIS. ...
Jyri's user avatar
  • 11
1 vote
1 answer
264 views

Geoserver crashing permgen space error

I am running geoserver 2.8.1 on Mac OS X 10.10. I have installed geoserver with homebrew. I have no idea why geoserver is crashing but I get this error below when I try preview a layer, create a layer ...
Asle's user avatar
  • 111
1 vote
0 answers
65 views

v.net modules QGIS 2.14 OSX

the .net modules have been added to the toolbox for 2.14 but I can't see them running under OSX (10.11.1) using kyngchaos. I can see other Grass 7 tools but not the v.net ones. I know I can run these ...
Sethinacan's user avatar
  • 1,726
0 votes
2 answers
331 views

QGIS capabilities [closed]

Our office is considering to make an offer of a large scale master plan project. The end-user files are required to be shape files, or at least ArcGIS compatible files. (The base map for desing is ...
pv2013's user avatar
  • 47
2 votes
1 answer
2k views

Error installing GDAL for Python on OSX

I'm trying to install GDAL for Python on my mac (OSX 10.9.2). I did: >>> brew install GDAL and got: >>> 🍺 /usr/local/Cellar/gdal/1.11.3_1: 230 files, 33.1M now: >>> ...
OMRY VOLK's user avatar
  • 141
1 vote
0 answers
402 views

Using osx terminal ogr2ogr to batch convert .json to .kml?

using osx El Capitan terminal This works fine one file at a time to convert .json to .kml ogr2ogr -f "KML" xxx.kml xxx.json I would like to do all files at once I have tried for %f in (*.json) ...
nwastra's user avatar
  • 115