Questions tagged [precondition]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
315 views

ModelBuilder using iterator as precondition

Was wondering how I can iterate over field values and when all the iteration is done to move onto the group at the end. I've tried setting a precondition within the loop but that just causes the whole ...
5 votes
1 answer
858 views

Preconditions not working on second iteration of ModelBuilder?

I'm working on a project where I have to iterate through geodatabases and handle some debug errors if they exist. For this I've created a ModelBuilder model, in ArcGIS 10.7. Essentially, what the ...
4 votes
2 answers
373 views

How to skip some steps, and continue the running of a model from a later point, bases on a condition?

I am building a Model in ArcGIS Desktop 10.8. At some point in my model, I am dealing with Line feature classes. I turn them into Polygon feature classes, and then I merge them into one feature class. ...
1 vote
0 answers
80 views

Running Lookup tool in ModelBuilder using field that was joined in previous step

I'm trying to generate a model (ModelBuilder in ArcMap) that calculates the Landslide Susceptibility Index with standardized inputs (Conditioning factors in raster format and dbf's with weights). The ...
1 vote
1 answer
135 views

Code to return false if two preconditions are false in Modelbuilder

I'm trying to use Calculate Value in Modelbuilder's Arcmap to run a process if one of two booleans preconditions is true. So if both of precondintion are false the process shouldn't run, otherwise it ...
0 votes
1 answer
154 views

How to use preconditions with row counts when some row counts = 0?

I have a model that iterates through a series of neighborhood polygons and clips several different datasets using the iterated neighborhood polygon. I am trying to determine the number of features ...
2 votes
1 answer
167 views

Nested iterator in model not working?

I am trying to iterate through 2 folders (1 for points, and 1 for polygons) and use the output values as inputs for another submodel that applies IDW, Focal Statistics, and finally a Clip (to a ...
1 vote
1 answer
41 views

Running process in ModelBuilder before loading shapefiles?

I have a model which I would like to check if shapefiles exist or are up to date and download them if they are not before processing them. I wrote the script to do the checking. In the script, I use ...
1 vote
2 answers
55 views

Successful iteration as variable

In ArcGIS ModelBuilder, is it possible to create a variable (that can be used as a precondition for following tools) that tells if an iteration has been finished? Example: An iterator buffers all ...
2 votes
2 answers
300 views

How to calculate multiple variables with precondition

I want to do multiple "calculate values" in ModelBuilder. To make it simple let´s take only 2 simple calculations: 1) calculate sine from angle to variable "MySinus" 2) use this value in a second ...
1 vote
1 answer
107 views

Dissolve doesn't work with empty layers

I have this model: The tool dissolve has this precondition of the Calculate Tool in order not to run with empty layers: However, when it runs with a empty layer it returns the following error: ...
1 vote
1 answer
171 views

Use value of Field in Calculation in Modelbilder

In Modelbuilder I have set up a model, where in one step I do a "Calculate Field" like "round((!OID!-1- %MyField% /15)/452,1)+1" . For the calculation i use the value of %MyField%, which actually is ...
2 votes
1 answer
639 views

Iterating rasters in ModelBuilder - wildcard does not seem to work?

I've got some problem with the model below. I want to extract rasters from sde geodatabase, use one parameter from Copy Raster, and then export it to specified folder with preserved names as an ...
1 vote
1 answer
252 views

ArcMap modelbuilder CalculateValue precondition not working

I am using ModelBuilder in ArcMap 10, this is my model: Cell Statistics shall be calculated for only those rasters dating in summer months (April - October), input raster name format is yYYYYmMM, e.g....
3 votes
1 answer
463 views

Setting creation of feature dataset as precondition to iterative process using ArcGIS ModelBuilder?

When using ArcGIS ModelBuilder, how do you set the creation of a feature dataset as a precondition to an iterative process, and not have it re-create the feature dataset each time through? This is ...