Questions tagged [pymodis]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
6
votes
2answers
5k views

Are there Python packages for Landsat 8 processing?

While there are a number of python projects for MODIS acquisition and processing (pyModis and get_modis), I have yet to encounter a toolset for automating Landsat 8 processing in Python. There's ...
4
votes
2answers
2k views

Why is gdalwarp changing value in nodata pixels?

I'm using gdalwarp to convert MODIS NDVI mosaics from Sinusoidal to epsg:4326. To save space I'm using VRT files until I reach the final product. Here is my workflow. Mosaic NDVI Modis tiles using ...
3
votes
1answer
537 views

Pymodis downloading?

I'm trying to download and process MODIS imagery using pymodis. I have Python 2.7.8 (Spyder), numpy 1.9.1 and gdal 1.11.1. I've also installed WXPython. I originally tried to use the modis_download....
1
vote
2answers
1k views

Cannot access MODIS Download from FTP using Python

I tried to access the FTP site of MODIS data using Python ftplib module but always fail to connect. I am connecting using: ftp = ftplib.FTP("e4ftl01.cr.usgs.gov") here is the error: A connection ...
1
vote
2answers
112 views

Resampling 1000m resolution Aqua MODIS images to 30m resolution

I am trying to resample the MODIS (aqua) image from 1000m resolution to LandSat image resolution which is of 30m for applying ESTARTFM technique. So you need to do preprocessing (Resampling and ...
1
vote
1answer
379 views

as I install pymodis?

unfortunately I have tried to download images bulk MODIS (NDIV and LST), but since the USGS server ((http://e4ftl01.cr.usgs.gov/) exchange ftp http, based codes R and python obsolete because I know ...
1
vote
1answer
89 views

pyModis problems on Mac

I've installed pyModis on my Mac using pip install pyModis. No error messages. When I try to run modis_download.py I get this error: Traceback (most recent call last): File "/usr/local/bin/...
1
vote
1answer
417 views

PyMODIS: Setup and Running

I have installed pyMODIS along with Numpy and the necassary GDAL bindings. How do I go about running the scripts such as modis_convert.py and modis_download_from_list.py. Are these ran from the ...
1
vote
1answer
225 views

Dose pyModis work with “ModisSwathTool” too?

I am going to use pyModis to work with MODIS data, Since I am quite new to Python, before starting to learn and use pyModis, I have a question for those who are familiar and using pyModis, right now....
1
vote
0answers
137 views

Issue with mapping MODIS SIN grid to EASE 2.0 with gdalwarp

I am trying to merge and reproject MODIS 250m NDVI product (https://lpdaac.usgs.gov/dataset_discovery/modis/modis_products_table/myd13a3_v006) to EASE2.0 grid. I am interested in projecting these to ...
1
vote
0answers
159 views

Python pyModis installation give error on windows 10 using pip install pyModis [duplicate]

I am using windows 10 operating system on my HP i7 machine with Python 2.7 installed. For windows, it is possible to install pyModis using pip by writing the following syntax in Windows PowerShell: ...
1
vote
0answers
394 views

Using gdal_merge to merge a large amount of files (in pairs)

I'm new to python and how it can be applied to gis. I have a large amount of MODIS files to go through and I've already extracted, reprojected and converted to GTiff the bands that I need from each ...
0
votes
1answer
70 views

How Do I search for MODIS data using pyModis?

I want to download the latest Modis vegetation Index Data(MODIS/Terra Vegetation Indices 16-Day L3 Global 250m SIN Grid V006) , whenever it is available for my Study Area. I know the Tile that my ...
0
votes
1answer
361 views

Install pymodis on Win10 python 2.7 anaconda

I'm trying to install pyModis on anaconda win10 python 2.7 and I have GDAL and all the other dependencies installed. I get the following error - `PackageNotFoundError: Packages missing in current ...
0
votes
1answer
450 views

GDAL doesnot support HDF4 e [duplicate]

I am trying to import the pymodis library within python and I keep getting error that "GDAL installation has no support for HDF4, please update GDAL" I am running the latest version of GDAL [...