Questions tagged [python-3]

Use this tag when Python 3 (or any of its dot releases) is the version you are using.

Filter by
Sorted by
Tagged with
0
votes
1answer
947 views

Understanding ValueError from folium?

I was trying the following line of codes in python (that I learnt from a tutorial), import folium import pandas data=pandas.read_csv("Volcanoes.txt") lat = list(data["LAT"]) lon = list(data["LON"]) ...
3
votes
2answers
8k views

Fill color not showing appropriately in folium?

The following code should have shown different colored circles in a map. But my result was circles with no color at all. import folium import pandas data=pandas.read_csv("Volcanoes.txt") lat = list(...
3
votes
0answers
119 views

QGIS Build error : zzz-db_manager-5-depend error - qgis master 2.99

I am compiling QGIS from master in VS 2015 on x64. I am getting error as : Error MSB6006 "cmd.exe" exited with code 1. zzz-db_manager-5-depend 7 C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\...
0
votes
0answers
1k views

GDAL and JP2: Python3 installation through PIP

I have JP2 files, which I have procured from ESA Sentinel 2 website. I am interested in processing them through GDAL and Python3. I have manageed to install Python3 and GDAL. GDAL was installed ...
1
vote
1answer
59 views

GDAL deletes metedata file when creating GTiff

Reposting question explaining it better. I am doing TOA corrections on Landsat8 Images in Python(3.5) by reading all image_bands and after processing them creating new GTiff of those images with GDAL,...
4
votes
1answer
810 views

How to let ogr/gdal CreateLayer() create a `geom` field instead of `wkb_geometry`?

When creating a new table (PostGIS) using OGR/GDAL (2.1+), is there a way to select a specific name for the geometry field (such as geom), rather than using the default name? I created a new table ...
1
vote
0answers
1k views

Could NOT find PythonInterp for QGIS 2.18

I'm trying to build Qgis on windows, and I'm following the instructions provided by Qgis, but I've had problems with the python interpreter already being in cmake-gui. I think the following error: ...
3
votes
0answers
722 views

QGIS 2.99 and python 3.6

I install QGIS 2.99 development version on my windows 10. I see in the installation folder I have folders python27 and python36. I want to ask can i use python 3.6 to take QGIS python API in ...
3
votes
1answer
177 views

QGIS development version(2.99) and python api questions

Can I use QGIS 2.99 PyQGIS in standalone apps like the others QGIS version? Do I need python 3.6 to use this python api?
4
votes
4answers
5k views

How to (re)install gdal in python3 (mac)?

I am stuck trying to install gdal, running python3.6 on a Mac. When I run pip install gdal I get errors of Failed building wheel for gdal error: command 'gcc' failed with exit status 1 Command "/...
3
votes
0answers
242 views

Installing Esri FGDB API with GDAL (Python 3.5) [closed]

I've recently migrated to ArcGIS Pro 1.4 and have had no problems moving from Python 2.7 to 3.5 - except one. I try to use gdal/ogr when I can in order to share scripts easily with those who do not ...
1
vote
0answers
236 views

pyQt error in the PYQGIS API

I install QGIS via OSGeo4W 32 bit on windows 7 32 bit and i want to take PYQGIS API in standalone python script. First I have python 3.5.2 and I have before install sip via pip and pyqt4 via gohlke ...
0
votes
1answer
537 views

Installing Python bindings for 64-bit Python on Windows

I installed GDAL and its Python bindings from GISInternals. While I believe that GDAL was installed correctly, the Python bindings have an issue. After opening a file with gdal.open I cannot read ...
0
votes
1answer
197 views

Landmasking in SAR geotiff image?

I am working on masking land in a SAR geotiff grayscale image. The image is a tilted one and as I am new to this field, I do not know how to proceed. Also, I searched about rsgislib which provides ...
3
votes
0answers
5k views

install GDAL 2.0 on Ubuntu 14

I would like to install GDAL==2.0.1 on Ubuntu. A lot of possibilities are found on SO, but none did work for me. I'll give an overview of a selection of my attempts: 1. Using pip directly pip ...
5
votes
2answers
2k views

Starting Python Shell Window of IDLE for use with ArcGIS Pro?

Prior to installing ArcGIS Pro 1.3 (I am now at 1.3.1), on Windows 7 SP1, I have been starting IDLE in a Python Shell Window from the Windows Start Menu using IDLE (Python GUI) in the Python 3.4 ...
1
vote
1answer
3k views

Zonal Statistics of a polygon and assigning mean value to the polygon [closed]

I have a large shapefile filled with polygons, and a raster of that same area. I need to use Zonal statistics to find the mean value of the area under each polygon and then assign that value to the ...
1
vote
4answers
876 views

working standalone app .exe from python3 script that imports osgeo gdal?

I have a script written in python 3.5 that uses osgeo gdal (1.11) to extract maps and file info from geotiff files. I would like to compile this code to create a standalone app on windows, and I use ...
5
votes
1answer
972 views

Sending arguments to LAStools function from Python script not working

I`m trying to call the lasground module from a python script, using this method: args=['lasground', '-i *.las', output_file, arg_step, arg_spike, arg_spikedown, arg_offset, arg_bulge, arg_cores] proc=...
3
votes
1answer
475 views

Decoding this GIS blob

I am new to the decoding world (and even to the world of gis), but I am definitely not new to programming and large data. I was tasked with uncovering a column in our db with this information. It's ...
0
votes
2answers
209 views

Migrating ArcGIS for Desktop script to ArcGIS Pro? [closed]

Recently I've been considering switching my department over to ArcGIS Pro in an effort to stay ahead in the ever-advancing world of GIS software. Currently we run ArcGIS 10.3, and have many daily ...
2
votes
2answers
355 views

Terminology for distinguishing ArcPy installed with ArcGIS 10.x for Desktop from that which comes with ArcGIS Pro?

ArcGIS Pro uses Python 3 whereas the other ArcGIS for Desktop applications (ArcMap, ArcCatalog, ArcScene and ArcGlobe) use Python 2 and the changes introduced with ArcGIS Pro were significant ...
1
vote
1answer
342 views

GDAL install on Ubuntu 12.04 works for python 2.x but not python3

I need to install gdal 1.10 or greater to be compatible with python3 on ubuntu 12.04. The machine also has python2 installed. I followed instructions here Error While installing GDAL in Ubuntu 12.04....
1
vote
0answers
485 views

Installing QGIS with Python 2 and Python 3 on OSX [closed]

I just installed qgis (and all the dependencies, etc.) on my Mac OSX 10.10 via homebrew. Currently, I use both Python 2 and Python 3 on the machine. Whenever I change the Python path [to open qgis], ...
1
vote
0answers
79 views

Switching between python versions for Arcpy [duplicate]

I’m developing a multi-module project in Python. I’m new to GIS and my boss doesn’t have a strong technical background. I’ve been instructed to use the Arcpy module to do functions such as intersect. ...
7
votes
3answers
7k views

Where can I find GDAL Python bindings for python 3.4?

Am using python 3.4 for development. I need GDAL python bindings for python 3.4. I have already gone through this site. I can find up to only 3.3?
9
votes
3answers
3k views

Distinguishing Python version when using IDLE with ArcGIS Pro and ArcGIS 10.x for Desktop architecture?

I have just started to work with Python 3.4.1 which comes with ArcGIS Pro 1.0.0, on my laptop, which also has Python 2.7.8 which comes with ArcGIS 10.3 for Desktop installed, and I would like to ...
10
votes
2answers
5k views

Using Python 3.x in ArcGIS?

I've been reading the "Whats New in ArcGIS" for the ArcGIS 10.3 update and came across the Python and ArcPy portion. It states that: ArcGIS 10.3 has been upgraded to include Python 2.7.8. Now ...
3
votes
0answers
232 views

LatLon Package python 3.4

Does anybody know a package who work in python 3.4 as "LatLon" Package ? https://pypi.python.org/pypi/LatLon/1.0.1#downloads
3
votes
1answer
3k views

How to use two different Python versions (3.4 and 2.7) for QGIS scripting?

I´m intending to learn scripting with python in QGIS, but I have a couple of questions. I'm using Python 3.4 for learning which is installed in my laptop, but QGIS is using Python2.7 How could I ...
3
votes
0answers
977 views

Can't install pyspatialite with python3 and sqlite3 [closed]

I can't install pyspatialite. When I try it gives me this error: pip install pyspatialite Downloading/unpacking pyspatialite Could not find a version that satisfies the requirement pyspatialite (from ...
1
vote
0answers
660 views

How to export from ModelBuilder as script and then run using Python. 3.4? [closed]

I'm currently studying for a Msc in GIS. In my assignment I have been asked to produce a model, export that model as a script file and then run that script as a stand alone in IDLE. So I have created ...
5
votes
3answers
5k views

Using PyScripter with ArcGIS for Desktop?

Can someone please let me know how I can set the PyScripter 2.5.3.0 x64 works with Python 2.7.3 which comes with ArcGIS what I did was: I installed the ArcGIS 10.2 I installed PyScripter 2.5.3.0 x64 ...
5
votes
4answers
10k views

Is there Python 3 module to read .dbf files written by ArcGIS for Desktop?

I would like to know whether there are Python 3.x-compatible (preferably Python 3.3) modules to read the kind of .dbf files produced by ArcGIS for Desktop. All the modules I found were only ...
6
votes
2answers
4k views

Python 3 support in QGIS?

As python3 is getting standard more and more I wonder wether there is or will be support for python 3 in QGIS?
5
votes
2answers
995 views

Python 3 with QGIS on Mac?

I need to start learning Python, and I want to learn with version 3.x. I understand that QGIS--at least some plug-ins--relies on Python and Tcl/Tk, and probably on specific versions. Assuming that ...
13
votes
4answers
13k views

Will ArcGIS Desktop support latest Python 2.x or Python 3.x versions?

I'm curious to know whether ArcGIS Desktop 10.0 will support newer versions of Python than 2.6. And for that matter newer versions of NumPy (ie, 1.4, 1.5 etc). I'm sure that this documentation is on ...