Questions tagged [scp]

The Semi-Automatic Classification Plugin (SCP) allows for the supervised classification of remote sensing images, providing tools for the download, the preprocessing and postprocessing of images.

Filter by
Sorted by
Tagged with
7
votes
1answer
102 views

Advanced search terms in the Semi-automatic Classification plugin

Background: At QGIS 3.18.1, I can successfully download Sentinel Level-1C imagery by entering the granule that covers my area of interest (10UGU) in the Advanced search box. Now I would like to ...
1
vote
0answers
12 views

While clipping a Raster generated from SCP plugin (classification) all the colors are vanished in the end output and the raster generated is in B/W

I have done all the LULC classification using SCP plugin. after completing my classification, I wanted to clip the raster using a Shape File. But when I do it, the colors are vanished in the output ...
0
votes
0answers
263 views

QGIS issues on Mac OS Big Sur 11.2 GRASS and SCP issue

I have been having issues with QGIS on my Mac. The current operating system is Big Sur 11.2. The current workaround to the SCP plugin is to revert back to version 6 via these steps: https://...
0
votes
0answers
26 views

Division of a raster into multiple rasters by its value

After the supervised classification of the original raster I want to divide/split the classified raster into multiple rasters by its classes. My aim is to use the single classes as polygons and ...
0
votes
0answers
6 views

SCP - Keyerror when merging ROIs into one class

I want to merge the spectral signatures from the classes in the ROI list into one class. E.g. I have 4 ROIs representing water and I want to merge these 4 water ROIs into only one water class to ...
0
votes
1answer
41 views

Classification of drone imagery (RGB) with SCP

How can I work on the classification in orthophotos (generated by Metashape from a DJI Phantom drone) when I cannot input the orthopoto into the band set? SCP does not find the raster of the ...
1
vote
1answer
115 views

SCP: raster is not loaded

I have installed the semi-automatic classification plugin (SCP v. 7.7.1) on QGIS 3.4.11 (Madeira) using Kubuntu 18.04. I downloaded Sentinel 2 (Level 2A) images and wanted to test one of the semi-...
0
votes
0answers
53 views

QGIS: Error [24]: The following signature does not match the band set. MC_ID: 1 C_ID: 1

I have run my classification map in QGIS using the semi-automatic classification plugin or SCP. I want to use the same ROIs for different sentinel imageries. But I faced an error Error [24]: The ...
0
votes
1answer
95 views

SCP QGIS Training input is not loading?

I am using QGIS, version 3.10.14 and the semi-classification plugin and want to create a training input, to classify different land-use-types. I followed the manual (https://readthedocs.org/projects/...
0
votes
1answer
81 views

Error [37] : Unable to calculate. Metadata error - SCP plugin in QGIS - Preprocessing landsat 8

I am trying to preprocess Landsat 8 data using the SCP plugin - all the bands are processed except for bands 1 and 9. The metadata is read correctly in the table but on clicking "Run" I hit ...
0
votes
0answers
15 views

Downloading Sentinel-2 from SCP plugin

Whenever I specify my area of interest and set my coordinates and choose Sentinel-2 it gives me error of Error [50]: Internet error:HTTP Error 401: Unauthorized. How do I solve this problem hence I ...
0
votes
0answers
112 views

Unable to download images in Semi-Automatic Classification Plugin (SCP)

I am using version 3.10, and I am trying to download images directly from the QGIS. The Semi-Automatic Classification Plugin (SCP) seems to work fine, I can find all the available images. However, ...
0
votes
0answers
78 views

Semi-Automatic Image Classification Plugin error in Mac

I have recently added Semi-Automatic Image classification plugin in QGIS version 3.10 on my Mac (ver 10.14.6). I have gone through and followed each step advised in this stack exchange post while ...
0
votes
0answers
54 views

Information [18]: Select at least one signature

While performing run / previewing classified image in SCP, the statement Information [18]: Select at least one signature appears. What is the solution to this?
0
votes
0answers
153 views

What's the simplest way to address “multiprocessing.pool.RemoteTraceback” in QGIS?

I am trying to do semi-automatic classification (SCP) on an image but the error multiprocessing.pool.RemoteTraceback keeps terminating the process. I believe this is a Python error but I have no ...
0
votes
1answer
42 views

QGIS: Error code showed up after Landsat 8 TOA and crashed the program (SCP plugin)

Trying to get all bands corrected but it failed every single time in version 3.10 or 3.16. Error codes showed as below:
0
votes
0answers
27 views

Invalid Data Source : /Applications/from multiprocessing.semaphore_tracker import main;main(35) is not a valid or recognized data source

I'm using sentinel2 images but the scp plgin can't preprocess it QGIS 3.8 on Macbook
0
votes
0answers
20 views

Invalid Data Source - QGIS scp plugin

I just want to ask what these error messages mean... I am preprocessing jp2 images through SCP. QGIS3.8 Python 3.6 jp2 images downloaded on Sentinel 2
0
votes
0answers
169 views

Error 38 Unable to load raster - Trying to preprocess satellite images from Sentinel 2 through SCP plugin

I'm not sure why QGIS can't preprocess the jp2 file I downloaded from Sentinel 2. I'm using the SCP plugin. I hope someone can help me out. I think I have to obtain a tiff file before I can clip it ...
0
votes
0answers
138 views

Error [37] : Unable to calculate. Metadata error - QGIS SCP plugin

I was trying to preprocess the data I downloaded from Sentinel 2 through SCP plugin but Error 37 Shows up. I don't know why. I was suppose to clip the jp2 images but it also doesn't work readily so I ...
0
votes
1answer
27 views

Two Different Python Version in QGIS and in Macbook

How can I fix this and make sure that I'm installing Scipy, Matplotlib, GDAL, and Numpy in the correct python version if my QGIS 3.8 uses Python 3.6 and my Macbook Terminal is using Python 2.7? I'm ...
0
votes
0answers
34 views

Error Scipy in QGIS SCP plugin

After clipping I am receiving these errors. I was clipping some satellite images from Sentinel 2 via SCP plugin but QGIS is not processing it. I already posted my problem with Scipy where in QGIS 3.8 ...
1
vote
0answers
46 views

Performing supervised classification on old aerial imagery taken in 1950s

I am working on a project to track the expansion of the city's built area in the last 70-80 years, and I have to deal with scanned images taken before satellites were first used, and I can't seem to ...
1
vote
3answers
1k views

SCP Plugin for QGIS 3.10 on Mac

I'm using the semi-automatic classification (SCP) plugin in QGIS on a Mac OS Catalina 10.15.5. I've tried it in multiple versions and I'm having issues with saving files. Whenever I click the Run ...
1
vote
0answers
58 views

QGIS SCP doesn't stack all bands for Sentinel 2

I've been following various tutorials to try and stack and then eventually classify images from Sentinel 2, but after downloading the images and running the band set tool, it simply only stacks 4 ...
1
vote
0answers
89 views

AttributeError: 'NoneType' object has no attribute 'bandCount'

I have a problem with a plugin (SCP). When I run a raster file (or tried), I get this error. I have read other similar problems, but honestly I am new to this whole programming issue and there are ...
1
vote
0answers
39 views

QGIS SCP pulgin layer output

I use the plugin regularly and have already used every function. But I have often noticed that the output layers are not always intuitively understandable. I googled on the topic and found no ...
4
votes
0answers
288 views

Error with ROI Semi Automatic Classification Plugin QGIS 3.4

I have troubles for making ROI with SCP plugin in QGIS 3.4. I dowloaded some landsat images with the plugin and trying to create ROI. To do it, I made a Bandset with DOS1 atmospheric correction, ...
0
votes
1answer
83 views

SCP error in QGIS 2.18.28

I have installed SCP on QGIS 2.18.28 from the Plugins-manage and install plugins. When I tried opening it, it gave me an error of crashed dumped as shown below: minidump written to C: \users\KLED\...
0
votes
0answers
49 views

Export classifier from SCP Plugin for use in other image classification

I have run a classification using the SCP plugin in QGIS. I want to recreate these results in a neighboring area and I am looking for help to see if it is possible to save the classification ...
1
vote
0answers
61 views

I can't make an SCP file

I am using QGIS 2.8 and am trying to create/load an SCP file in which to classify a Sentinel 2 image. It won't let me create an SCP file and keeps asking if I want to add missing fields to the shape ...
1
vote
2answers
94 views

How to define new classes from a change detection raster layer [closed]

As part of my thesis, I'm looking at the atmospheric and landscape effects of the 2018 wildfire in the Algarve. As part of the process, I want to estimate total biomass loss so I have classified two ...
2
votes
1answer
48 views

Setting CRS for SCP within QGIS?

I am currently working with SCP within QGIS and am trying to classify the contents of a field (different flowers, grasses, bare ground etc.). I have loaded a raster image of my field and am now ...
2
votes
0answers
380 views

Python Floating Point Error when using SCP plug-in (QGIS 3.6)

I receive a python error every time i try to save a temporary ROI to training input in the Semi-automatic classification plug-in in QGIS 3.6. I'm unable to add any training ROI to training input. ...
1
vote
0answers
65 views

Landsat 4-5 using SCP classification

I am geodesy student from Slovenia. For my report I chose working with QGIS and I am having problems with SCP-classification. So, I am working with Landsat 4-5 TM year 2006 and I would like to ...
0
votes
1answer
307 views

QGIS 3 crashes when trying to download semi-automatic classification plugin

Installed QGIS 3 in prescribed manner. (i.e. FIRST python, then GDAL, then QGIS 3). Then installed matplotlib manually by typing "sudo pip3 install matplotlib" into terminal. Then, (as per ...
1
vote
0answers
233 views

FloatingPointError: invalid value encountered in greater_equal in Semi-Automatic Classification Plugin in QGIS

2019-04-05T00:29:33 WARNING Traceback (most recent call last): File "C:/Users/ASUS/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\SemiAutomaticClassificationPlugin\dock\scpdock.py", line ...
1
vote
0answers
116 views

ROI signature creation error

I'm trying to run a maximum likelihood classification on a Landsat 8 mosaic to assess land cover, but I keep getting the same error during signature generation: I never got this error before, and ...
0
votes
2answers
96 views

How can I find the percentage of representation of classes?

I have done a classification using the semi-automatic classification plugin, and now, I would like to express each class in percentage of the study area (e.g. forest represent 20% of the study area ...