Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [sip]

SIP is a tool for creating Python bindings for C and C++ libraries.

0
votes
0answers
12 views

QGIS Compiling 3.6.0 Troubleshooting about PyQt5, SIP, Qscintilla

I work on UBUNTU 18.04 LTS/bionic, I am trying to compile QGIS 3.6.0, for an upgrade from QGIS 3.2. 0. I am facing the same trouble as several people the release compatibility between SIP and PyQT5 ...
0
votes
0answers
20 views

SIP API Error - QGIS Noosa

I have QGIS Noosa installed on two separate PCs working on Xubuntu. Both the PCs are configured for the same QGIS repository. However, on one of the PCs, I have the following error: Traceback (...
1
vote
0answers
287 views

QGIS 3.4 Couldn't load SIP module. Python support will be disabled on Windows 10

I upgraded from QGIS 3.2 to 3.4 and bad things happened. On start-up I get the error. Couldn't load SIP module. Python support will be disabled. Traceback (most recent call last): File "", line 1,...
0
votes
1answer
203 views

Can't load PyQGIS on QGIS3 due to problem with API version of sip module

Again having issues with building QGIS 3 on Manjaro Linux, from AUR. After solving my previous problem (QGIS 3.0 can't load plugin processing, no module named 'osgeo', on Manjaro Linux), I ...
0
votes
0answers
109 views

No SIP module on Mac OS after installing Boundless Desktop 1.1.0 product

After installing a Boundless Desktop 1.1.0 product, when I tried to start QGIS, it gave an following error and processing toolbox does not started. Couldn't load SIP module. Python support will be ...
2
votes
1answer
1k views

How to avoid updating PATH by copying SIP module to appropriate directory

I continue to have very time-consuming problems with import statements in the Python scripts that I attempt to write. In this particular script, I want to use QGIS functionality, and so it begins: ...
2
votes
1answer
640 views

QGIS: sip module implements API v11.0 to v11.3 but the qgis._core module requires API v10.0

I have read all the questions on the SIP module and QGIS, but they do not answer my question. Most of these are dealing with screwed up paths; I do not think my environment variables are incorrect. ...
2
votes
1answer
495 views

error sip.setapi(api, 1) in pyQGIS

I have installed QGIS via osgeo4w 32 bit yesterday, to take pyqgis api in standalone script, but I have some problems. I have python 2.7.13 32bit and pyqt4 installed from Gohlke. After, I created a ...
1
vote
0answers
310 views

QGIS 2.18.3 path and sip module cannot be load in ubuntu 16.04

I'm currently installing QGIS 2.18.3 it works fine at first, after upgrading my ubuntu the problems comes out every time I run my QGIS; it always shows "Couldn't load SIP module. Python support will ...
3
votes
1answer
360 views

Trying to write standalone Python script for QGIS, can't load SIP

I'm trying to learn to write standalone Python scrips for QGIS, but can't get past first base. I'm using QGIS 2.18, installed with the OSgeo4W64 installer. I have modified my path as follows. SET ...
2
votes
1answer
846 views

How to solve SIP installation error?

I'm new to Python, and am trying to install Qt/PyQt for PyQGIS. I downloaded the PyQt and SIP packages, and tried to install them but have run into errors. Installing SIP: As far as I can tell, ...
2
votes
0answers
211 views

cannot load moule sip qgis 2.8.2

i have an error when i launch the qgis 2.8.2 it says that the module sip cannot be load python 2.7 has been installed i am under ubuntu 14 please if you have any idea here is the message (in french ...
1
vote
0answers
187 views

import qgis geoprocessing tools in python os x 10.9.5 [duplicate]

I'd like to use the python bindings from qgis, but in a standalone project. I need the geoprocessing tools for vectors. I updated QGIS (Wien - 2.8), python (3.4.3), etc. However, it always ends with ...
2
votes
1answer
4k views

Can we avoid using SIP library when writing standalone QGIS python script

I wanted to write a small custom python script using QGIS functionality. So I started with the QGIS documentation on the custom application section. After having some troubles with the import qgis....
1
vote
1answer
626 views

QGIS Wien 2.8.1 RuntimeError concerning the sip module on Win 7

I am running windows 7 64bit and python 2.7.9 I just installed QGIS Wien 2.8.1 and it crashes on start up with the following code: Couldn't load PyQGIS. Python support will be disabled. Traceback (...
3
votes
2answers
3k views

Couldn't load SIP module (QGIS doesn't load Python)

I recently installed QGIS 2.4, but Python does not load. I am running on a Windows 64 bit machine. I receive the error message "Couldn't load SIP module Python support will be disabled". Traceback (...
1
vote
0answers
359 views

Couldn't load PyQGIS, QGIS 2.0.1 on Ubuntu 12.04 Precise

After upgrading to QGIS 2.0.1 I still get the error: Couldn't load PyQGIS. Python support will be disabled. Traceback (most recent call last): File "", line 1, in File "/usr/lib/python2.7/dist-...
3
votes
1answer
276 views

Compiling QGIS 2.0.1 on Centos (SIP problems)

Trying to compile QGIS 2.0.1 on CentOS 6.4 (64 bit): /usr/share/sip/PyQt4/QtGui/qsyntaxhighlighter.sip: In function ‘PyObject* meth_QgsExpressionHighlighter_setCurrentBlockUserData(PyObject*, ...
1
vote
0answers
621 views

Couldn't load SIP module - python disabled

Recently my QGIS started refusing to load SIP module, from day to day without any significant changes in the system (I'm on Windows7 x64). Message thrown at startup: Nie można wczytać modułu SIP. (...
3
votes
3answers
2k views

Couldn't load SIP Module

After reinstalling QGIS, the desktop program runs but generates the python error "Couldn't load SIP Module Pythin support will be disabled" Because of this error, no plug-ins will load. I found a ...