As of May 31, 2023, we have updated our Code of Conduct.

Questions tagged [string]

A sequence of characters.

20 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3 votes
0 answers

QGIS3 python: right(QTextStream) - getting unexpected type ' str'

I have a field type double that I need to reduce from 9 digits to 8 ie 123456789 -> 23456789. If I do it as an integer I loose leading zeros ie 10002345 -> 2345. I am attempting to use refactor fields ...
BrendanP's user avatar
2 votes
0 answers

How to use WFS to update the value of a field to an empty string '', not Null?

I tried to set a field value of a feature to an empty string '' via WFS, but I didn't find a way to make it happen. I use the WFS protocol to send to Geoserver. I tried the following three methods: 1. ...
singh's user avatar
  • 43
2 votes
0 answers

Receiving strange characters from GPS tracker, is this HEX or binary?

I am struggling with a GSM GPS tracker. It looks like a clone of GT02A, and it is a relatively common model. My problem is that when it sends data to my server, it is not readable. I set it to send ...
adrianTNT's user avatar
  • 141
2 votes
0 answers

Conversion to_string provides NULL in QGIS

I've been trying to convert a decimal row into a string row using a few methods. Below is my CSV file: also, note that csv header has been updated too, State;AverageRainfall;ProbabilityBelow;...
BPDESILVA's user avatar
  • 151
2 votes
0 answers

Moving substring from end to beginning of string

Disclaimer: I'm very new to QGIS and using expressions. I have a large data set that contains a time range (00:00-00:00) and 1-6 three-day abbreviations of days of the week (MON, TUE, WED, etc.). I ...
S. Signs's user avatar
2 votes
0 answers

Inconsistent Value Using Calculate Value in ModelBuilder?

I have a set of models that use Calculate Value to store file locations as strings for use in model variables and outputs, and am having an issue with the model either hanging on to the first value it ...
troubbble's user avatar
  • 220
1 vote
1 answer

How to find the row number based on a set of SFC coordinates, in order to pull out the value from another column

I am new to geodetic data in R, so apologies if this is way off. I have got a dataset, with a column geometry, which contains SFC points, and a second column IntersectingPoints: IntersectingPoints ...
Alex's user avatar
  • 21
1 vote
0 answers

Using an input string in a file path for a input vector layer in QGIS model

I am building a QGIS model to perform field calculations on a large number of .shp files containing environmental information of different waterbodies. This model should be global for the different ...
Leesbiology's user avatar
1 vote
2 answers

TerraClimate: Error generating chart: Data column(s) for axis #0 cannot be of type string

I am using "TerraClimate: Monthly Climate and Climatic Water Balance for Global Terrestrial Surfaces, University of Idaho" dataset... When I try my code, I have this error message Error ...
Maria Castellaneta's user avatar
1 vote
0 answers

String slicing in ArcMap dynamic text element

Is it possible to slice a string in ArcMap's HTML-like dynamic text elements? I've got a string field "Code" with contents like 'A.3.5', I need to extract the number in the middle ('3' in this case). ...
user99006's user avatar
1 vote
0 answers

Converting @layer_name tokens into Shapefile Attributes (Columns/Rows) using QGIS Expression Editor?

I'm a fairly novice Python user and I've been banging my head against this problem for a number of days now. Assumptions I've made: This is doable within QGIS, and does not need to be done ...
Saijin_Naib's user avatar
  • 2,669
1 vote
0 answers

Converting table asset data type from 'Long' to 'String'

I am attempting to generate 50 random points per land use class through Google Earth Engine. I have performed this operation before on an earlier instance, where the inputs were the following (1) ...
Johanness's user avatar
  • 382
1 vote
0 answers

Attribute table reformatting fields on programme close

I'm creating a density map using the graduated style in qgis. The data is created from the points in polygon tool, this is then saved as an integer (not sure why the plugin doesn't automatically do ...
user13641's user avatar
  • 305
1 vote
0 answers

Feature Layer parameter showing only Polygon Shapefiles

I have created a Python Tool in ArcGIS where most of the paramaters musts be ONLY Polygon Shapefiles. You can also look on my previous question: Filter the Feature Layer parameter in Python Script ...
Panos's user avatar
  • 163
1 vote
1 answer

Iteratively name output files in a loop while using arcpy.conversion.FeatureClassToFeatureClass

I have four input feature classes and one feature dataset which I am trying to send them to. I would like the new feature classes to have the same names as the originals. My process is as follows: for ...
dre627's user avatar
  • 29
0 votes
0 answers

How to input a string (or any type) value to a field for multiple feature layers at once

I work in ArcMap 10.8.1. I added fields to all of my feature layers using Batch Add Field tool. Now I'm trying to find a way to enter values into those fields. Values are identical for each field. My ...
M. Tomas's user avatar
  • 173
0 votes
1 answer

Bounding Areas using Feature Collection values (RESOLVE Ecoregions 2017)

I'm pretty new to the Earth Engine and have been working through some of the tutorials to familiarize myself with it. I have very little code experience. What I am trying to accomplish is creating a ...
Carey Johnston's user avatar
0 votes
0 answers

ValueError: could not convert string to float: 'x_degree'

I want to create a decimal degree (dd) field from degree minute seconds (DMS) as a script tool. The CSV looks like this. My code looks like this: import arcpy inTable = arcpy.GetParameterAsText(...
Jessica's user avatar
  • 17
0 votes
0 answers

Using gdal_translate with a high number of gcp

I've a CSV file witch describes the coordinates of each pixels in a image, it is structured like this: xcoord,ycoord,row,col 716657.6518375501,4784215.095395751,0,0 716657.6915582813,4784215....
Giulio's user avatar
  • 131
0 votes
0 answers

File Geodatabase: storing text in an integer field?

I recently downloaded a FGDB from NOAA at The FGDB contains a point feature class with ship locations. One of its attribute fields, named [Status], is of type Long ...
Stu Smith's user avatar
  • 7,649