Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [ubuntu]

Ubuntu is a computer operating system based on the Debian Linux distribution and distributed as free and open source software, using its own desktop environment.

0
votes
1answer
24 views

PostGIS cannot create extention:ERROR: cache lookup failed for function 1

When trying to create PostGIS extension I am getting this error: ERROR: cache lookup failed for function 1 I am running PostgreSQL 11 on Ubuntu 16.04. I have installed PostGIS and PostGIS scripts. ...
0
votes
1answer
11 views

Configuring MapServer on Ubuntu with Apache

I am using Ubuntu 18.10 /x64 / Apache2. I wish to install MapServer on my system. The packages can be obtained from this place: https://launchpad.net/ubuntu/+source/mapserver/7.2.0-5/+build/15292173 ...
1
vote
1answer
32 views

Mapserver weird output of REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1.1.1

Once I use REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1.1.1 in my browser with the mapserv I get the following: $ cat ~/Downloads/ms ELF>�@@!@8 @@@@��888�� �� � �� �� � TTTDDP�tdLLQ�...
1
vote
0answers
58 views

QGIS 3.6 menu bar missing [closed]

I am running Ubuntu 18.04 with the XFCE interface and QGIS v3.6. When I start QGIS the menu bar at the top of the window is missing, and I can't find any way to bring it back. I found some solutions ...
1
vote
0answers
44 views

SAGA 2.3.1 makes QGIS 2.18 crash on Ubuntu 18.04 [closed]

On Ubuntu 18.04, using packages provided by universe repos QGIS 2.18.17+dfsg-1 SAGA 2.3.1+dfsg-3build7 When starting any SAGA algorithm, QGIS crashes with a "Segmentation fault" error message. We ...
2
votes
1answer
300 views

Can't install support for ECW in QGIS 3.6 / 3.4 on Ubuntu 18.04

I've been trying to install support for ECW so I can load them in latest QGIS 3.6 (also tried in QGIS 3.4.4) Having tried the following tutorials: https://wiki.openstreetmap.org/wiki/ECW (gdal 2.2....
0
votes
0answers
18 views

OpenDroneMap returns error on merging depthmaps?

I am doing a reconstruction on 424 Parrot Sequoia RGB images using OpenDroneMap. The reconstruction runs for about 2 hours then throws the error shown below. I have successfully done several ...
1
vote
0answers
20 views

Unable to use PyQGIS since python is unable to import qgis libraries

I am using Ubuntu 18.04. I have installed QGIS 3.4.4 Madeira on my laptop. I am learning PyQGIS. I have found these lines of code that I have executed in my terminal but I get a traceback saying that ...
0
votes
0answers
53 views

Cannot install QGIS 3 on Ubuntu 18.04 (From ubuntu repo. Not ubuntugis-unstable ) [duplicate]

When I want to install QGIS latest ver 3.3.4 to ubuntu 18.04 it rises error bellow : Setting up qgis-providers (1:3.4.4+28bionic) ... /usr/lib/qgis/crssync: error while loading shared libraries: ...
1
vote
1answer
82 views

Unable to install QGIS on Ubuntu 16.04

I am trying to install QGIS (any version) on Ubuntu 16.04 and Python 2.7 or Python 3.7.2 I run the sudo apt-get install qgis python-qgis qgis-plugin-grass saga and I get : Reading state information....
3
votes
2answers
480 views

Install QGIS 3.x on Ubuntu 18.04

I've tried several packages including ubuntugis but none helped. How to install qgis 3.x, more preferably qgis 3.4 lts in Ubuntu? I've added following repos:: sudo add-apt-repository ppa:ubuntugis/...
2
votes
0answers
37 views

How to tune the performance of Nominatim Reverse Geocoding Application

Running the query directly to the PostgreSQL takes 3-8ms. The PostgreSQL can handle 500 concurrent connections. The Apache server is running on 8 core CPUs. Analyzing the Apache access logs: There are ...
0
votes
1answer
53 views

Install osgeo live package in existing Ubuntu?

I am using Ubuntu. In my secondary computer I use Lubuntu based OSGEO-LIVE 12.0. OSGEO-LIVE is a great software when it comes to any GIS application and reduces tedious work of individual package ...
0
votes
0answers
117 views

PostGIS install Ubuntu: GEOS problems

Using apt-get install, I've added the following packages: postgis/bionic-pgdg,now 2.5.1+dfsg-1.pgdg18.04+1 amd64 [installed] postgis-doc/bionic-pgdg,now 2.5.1+dfsg-1.pgdg18.04+1 all [installed,...
0
votes
0answers
18 views

Zoo-Kernel error in compile

I am trying to install zoo-project on Ubuntu 18.04 based on Zoo-Project doc when I want to compile ZOO-Kernel with makecommand, I receive below error: gcc -shared -I/usr/include/gdal -Wl,-soname,...
1
vote
1answer
131 views

Is it possible to install zoo-project in Ubuntu 18.04?

I want to install zoo-project in Ubuntu 18.04 (bionic), but it seems there aren't any programs to do that, for example I have a problem with zoo-kernel install because there is not "ibmozjs185-dev" ...
2
votes
2answers
570 views

QGIS installation vanished! Re-installation attempts produce dependency-errors

So, I am using Ubuntu 18.04.1 LTS and use Qgis 3.4 for GIS analysis. I had a week long pause using QGIS for about a week, and it was quite an unhappy surprise to find out this morning that the whole ...
0
votes
1answer
76 views

How to downgrade from ubuntugis-unstable to ubuntugis-stable

I have some problems with gdal and I would like to downgrade all of my ubuntugis related libraries on Ubuntu 16.04 again to the stable libraries. How can I do that?
2
votes
0answers
77 views

QGIS 3 downgrade on Ubuntu

I updated to QGIS 3.4 on Ubuntu, but there are some functions that are not working so I want to downgrade. Therefore, I have several questions: How to downgrade or reinstall to some older version ...
1
vote
0answers
41 views

Error on simple standalone script

I want to develop a PyQGIS standalone script only using Ubuntu terminal, so to start I use: from qgis.core import * QgsApplication.setPrefixPath("/path/to/qgis/installation", True) qgs = ...
2
votes
2answers
92 views

GIS software that can work only on Ubuntu Terminal? [closed]

Recently, I tried to open a QGIS project on Ubuntu, but I can only use Ubuntu's terminal for that which gives me the following error: QGIS starting in non-interactive mode not supported. You are ...
0
votes
1answer
77 views

Can not set the GeoServer data directory location

I want to run GeoServer 2.14 with Jetty on a Ubuntu 18.04. I copied the war-file in the webapps folder and GeoServer is responding. Unfortunately I can not set the data directory location as ...
2
votes
0answers
22 views

QGIS does not remember paths to previous projects after restarting computer

I am running QGIS 2.18 on Ubuntu 16.02. After turning on my computer and opening QGIS I see that QGIS will not remember the paths to previously opened projects. I can see a thumbnail of these ...
1
vote
0answers
40 views

Can't select vector layer QGIS Zonal Statistics

I'm running QGIS 3.4.0 on Ubuntu 18.04.1. I have a raster layer and a vector layer from a .shp file in the same CRS. When The window pops up for zonal statistics, I can select my raster layer but ...
1
vote
0answers
123 views

QGIS 3.2 installation error on Ubuntu 16

I am installing QGIS, I added the repository and cleaned my machine of any QGIS Packages, I tried removing and reinstalling qgis-providers but the same issue occurred again (see error-message): ...
0
votes
0answers
122 views

Alternative of Web App Builder

I'm currently using: QGIS 3.2, OS: Linux (Ubuntu) The Boundless plugin i.e. QGIS web app builder isn't supported on QGIS 3 version I guess. I tried installing it through the zip file method but ...
3
votes
2answers
429 views

Linux Ubuntu 18.04 QGIS shuts down with no errors

Ubuntu 18.04, using this guide to install qgis on the machine. https://linuxhint.com/install-qgis3-geospatial-ubuntu/ sudo apt-get update sudo apt-get install qgis python-qgis qgis-plugin-grass I ...
1
vote
2answers
215 views

PostGIS 2.5 error while compiling from source on Ubuntu Server 18.04

I'm compiling PostGIS 2.5 from source on Ubuntu Server 18.04 The server had no internet connection due to client requirements, so I've been following PostGIS 2.5.1dev Manual, 2.4. Compiling and ...
1
vote
1answer
257 views

Error while installing QGIS with conda

I'm trying to install QGIS through conda $conda install -c conda-forge qgis but got the following error Solving environment: failed UnsatisfiableError: The following specifications were found to be ...
0
votes
0answers
339 views

Python bindings for PCL (Point Cloud Library)

I am curently searching for some Python 3.x bindings for PCL on Ubuntu (16.04). The ones I found are: pclpy: pip cannot find it. python-pcl: I have tried to install it but I always end up on ...
0
votes
0answers
32 views

Landsat util error when downloading data

I am having trouble when trying to download data using Landsat util. Using the following command: landsat download LC81710792016253LGN01 I get the following issue: landsat download ...
1
vote
0answers
46 views

QGIS won't save on to SAMBA on Ubuntu

I have a couple of QGIS applications (one 3.2.2-Bonn and one 2.18.9 Las Palmas) running on Ubuntu boxes (both 18.04.1 LTS). Files are loaded from a SAMBA file share and load fine. But when I try to ...
1
vote
1answer
57 views

Struggling to install sentinelsat

I am struggling to install sentinel sat. After exhausting all my options I have decided to ask if someone can just guide me in the right direction. Firstly I tried simply: sudo apt-get install ...
2
votes
1answer
532 views

Can't seem to get QGIS 3.2 installed in Linux Mint - Only 2.18

I'm at the end of my rope here. I'm trying to install QGIS 3.2 on my computer running Linux Mint 18.3 and I've gone through installing the unstable PPA and updating and upgrading half a dozen times ...
2
votes
1answer
348 views

OS with better performance for QGIS [closed]

I'm starting to use QGIS desktop and many other tools like Python, Geoserver or PostGIS as a Geo-information's master student and I want to know if can I get a better performance for these in Linux, ...
2
votes
2answers
113 views

How to Update the EPSG Database of Gdal on Ubuntu?

I have a Ubuntu 16.04 Server, with GDAL 2.1.3, released 2017/20/01. I need to project a Raster to EPSG:7755 which was added way back in 2016. When I use this EPSG code with gdalwarp, I get the ...
2
votes
1answer
181 views

Ubuntu: Updating Mapnik from 2.2.0 to 3.x, complications?

I'm wanting to upgrade Mapnik on a production system from 2.2.0 to 3.x to take advantage of improvements to data-driven rendering. Fortunately the install instructions for Ubuntu have been updated ...
2
votes
0answers
313 views

How to install filegdb driver with GDAL in linux?

I have been working on GDAL with windows platform but now I require to shift to linux. I have installed GDAL using apt-get install gdal-bin libgdal-dev pip3 install GDAL Now i require support for ...
0
votes
0answers
20 views

How to export images to JPEG images in Matlab/Ubuntu

I have processed my Landsat 8 data for previewing Band754, now I would like to export composite Band 754 image into JPEG images .I have used following codes in Matlab: system ([gdal_translate -ot ...
1
vote
2answers
348 views

How do i install ESRI File GDB API in Ubuntu 16.04 so QGIS 2.8 can see it?

Can someone tell me how to get QGIS 2.8 in Ubuntu to see the ESRI File GDB API? I am trying to install the ESRI File GDB API (https://github.com/Esri/file-geodatabase-api/tree/master/FileGDB_API_1.5) ...
1
vote
2answers
272 views

Failed to install Potree on Ubuntu 18.04 Bionic

I am trying to install Potree on my computer and I am stuck. I am following these instructions: $ sudo apt-get install python-software-properties git $ sudo apt-get install build-essential cmake g++ $...
0
votes
1answer
183 views

QPSQL driver on kubuntu 18.04

I am migrating a plugin to (K)Ubuntu 18.04 and QGIS 3.2 but oddly enough I can't seem to connect to a postgres database. As far as I can see the QPSQL driver is not loaded. I ran the following code: ...
2
votes
2answers
578 views

libpng problems for QGIS

I'm using ubuntu 18.04 and if I download QGIS 2.18 and I try to run it, I get this: libpng warning: Application jmp_buf size changed Segmentation fault (core dumped) If I try with QGIS 3.2, the ...
3
votes
0answers
163 views

QGIS 3.0.3 (and 3.2.0) crashes on start. Ubuntu 16.04, conda environment

I am trying to QGIS in a conda environment, python 3.6.5, conda 4.5.8, Ubuntu 16.04 Xenial. It crashes upon start-up without even loading all the way. I have tried both QGIS 3.0.3 and 3.2.0 (3.2.0 is ...
1
vote
2answers
382 views

Installing PgPointCloud extension for PostgreSQL on Ubuntu Bionic

I'm stuck with the installation of the PgPointCloud extension for PostgreSQL. I found this article: https://connect.boundlessgeo.com/docs/suite/4.6/dataadmin/pointcloud/install.html But when I run ...
0
votes
0answers
101 views

Running ArcGIS Server on Ubuntu Server?

I have install ArcGIS Server 10.6 on top of Ubuntu Server 18.4 ,gusting on a VM. I was able to create a new site after installation on Server Manager page but after restarting the VM I am not able to ...
3
votes
2answers
3k views

Cannot create PostGIS extension with Ubuntu 18.04

I am a few days new to Linux Ubuntu and am in the process of setting up a PostGIS database to use in GeoDjango. I am going to post all my commands that I have done so far these are installed in ...
1
vote
1answer
114 views

compile gdal with ESRI FileGDB_API Ubuntu

I'm trying to build GDAL on Ubuntu 16.04 with ESRI FileGDB_API driver support. I've followed the instructions here: https://trac.osgeo.org/gdal/wiki/FileGDB and have attempted to pass the location of ...
0
votes
2answers
728 views

Error building GEOS on Ubuntu 18.04

Following the directions to install geodjango on linux ubuntu 18.04, so far here are my commands: sudo apt-get install binutils libproj-dev gdal-bin wget http://download.osgeo.org/geos/geos-3.4.2....
2
votes
0answers
111 views

GDAL, Geolocation Arrays, and Overflow Error?

I'm trying to use GDAL to create raster images from NOAA GSIP L2 data products. By looking at the provided NetCDF files from NOAA, it appears that geolocation arrays are provided. I tried following ...